mount vom Raspi3B zur FritzBox OS-Version 7.29 funktioniert nicht mehr

  • Hallo,


    seit einigen Tagen klappt bei mir das automatische Backup von Dateien vom Raspi zum SSD-Speicher der FritzBox nicht mehr.

    Grundsätzlich hat dies über mehrere Jahre, nach der Anleitung von Hofei Netzwerkfreigabe mounten mit systemd Mount Unit bestens funktioniert.


    Damit ich das Problem eingrenzen kann, will ich zunächst manuell ein Verzeichnis mounten und darin nur mit nano eine Textdatei anlegen, selbst das klappt nicht und ich kann mir nicht vorstellen wo das Problem liegt.


    • Auf der FritzBox entferne ich den Haken bei SMBv1 somit werden nur mehr aktuelle Netzwerkprotokolle unterstützt.
    • Zur Sicherheit starte ich die FritzBox und den Raspi mal neu, ist wahrscheinlich nicht notwendig, aber schaden kann es auch nicht. Nach dem Neustart prüfe ich auf der FritzBox nochmals die Netzwerkeinstellungen und die Benutzerrechte des Users Fhem.

    Nun beende ich auf dem Raspi nach dem reboot (angemeldet als Pi, nicht als root) den mount wie folgt:

    Ich erkenne jetzt, dass aktuell kein Verzeichnis mehr gemountet ist.


    Nun versuche ich das Verzeichnis manuell zu mounten mit folgenden Befehl, angemeldet als Benutzer Pi über PuTTy:


    Das mounten wurde wieder ohne Fehler ausgeführt und scheint auch eingerichtet zu sein.


    Will ich nun mit nano wie folgt eine Datei anlegen (egal ob mit oder ohne "sudo"):


    Code
    pi@Fhem-Buster-SSD:/media $ cd /media/fritz_nas
    pi@Fhem-Buster-SSD:/media/fritz_nas $ ls -lh
    insgesamt 0
    pi@Fhem-Buster-SSD:/media/fritz_nas $ nano Text.txt


    So erhalte ich wieder folgende Fehlermeldung:

    Code
    [ Fehler beim Schreiben der Sperrdatei ./.Text.txt.swp: Datei oder Verzeichnis nicht gefunden ]


    Irgendwie kann oder darf der Raspi nicht in das Verzeichnis der SSD auf der FritzBox schreiben.

    Habt ihr als Linux Profis einige Tipps für einen Linux Anfänger was ich da falsch mache oder wie ich mein Problem eingrenzen kann?


    Noch ein Hinweis:

    Richte ich den mount zu einem Windows10 PC ein, so kann ich mit "sudo" problemlos eine Textdatei im gemounteten Verzeichnis erstellen. Ich habe fast die Vermutung da hat sich im Linux System oder im OS der FritzBox etwas geändert weil es bei mir nicht mehr klappt.


    Gruß Reinhard

  • Hallo hyle,


    das mit der Mountoption noserverino habe ich auch schon versucht, vorher natürlich ein umount gemacht, klappt aber auch nicht.


    Anbei noch die Ausgabe von ls -lisa /media/fritz_nas vor dem mount:

    Code
    pi@Fhem-Buster-SSD:~ $ ls -lisa /media/fritz_nas
    insgesamt 8
    1545218 4 drwxr-xr-x 2 root root 4096 Dez  5 10:19 .
    1545217 4 drwxr-xr-x 5 root root 4096 Dez  5 15:55 ..


    und nochmals, bei gemountetem Verzeichnis ohne Option noserverino:

    Code
    pi@Fhem-Buster-SSD:~ $ ls -lisa /media/fritz_nas
    insgesamt 4
    9332993024842119429 0 drwxr-xr-x 2 pi   pi      0 Dez  5 12:04 .
                1545217 4 drwxr-xr-x 5 root root 4096 Dez  5 15:55 ..


    und einmal, bei gemounteten Verzeichnis mit Option noserverino:

    Code
    pi@Fhem-Buster-SSD:~ $ ls -lisa /media/fritz_nas
    insgesamt 4
        120 0 drwxr-xr-x 2 pi   pi      0 Dez  5 12:04 .
    1545217 4 drwxr-xr-x 5 root root 4096 Dez  5 15:55 ..


    Ich hoffe ihr könnt da etwas erkennen.


    Gruß Reinhard

  • Hallo,


    nun habe ich die Ursache gefunden, es waren zuviele / im mount Befehl enthalten, deshalb hat es nur auf der FritzBox nicht mehr funktioniert.



    Danke

    Gruß Reinhard