Remote Desktop Problem

  • Hallo,

    ich habe vor ein paar Tagen von "Stretch" auf "Bullseye" upgedatet. (Hardware glaube ich RaPi 2B). Unter Stretch hatte ich keine Remote Desktop Probleme (zu Win7 PC). Die Darstellung war full screen (2560 x 1440) und lief flüssig. Nach dem Update muss ich die Anzeige-Einstellung von Remote Desktop auf 1920 x 1200 runtersetzen, da sonst die Darstellung fehlerhaft ist. Weiterhin fällt auf, dass die Übertragungsrate anscheinend gering ist. So wird der Desktop sichtbar blockweise aufgebaut und nicht wie früher nahezu "am Stück". Verschiebe ich Icons auf dem Desktop, wird die neue Position erst nach einem Klick an eine andere Stelle dargestellt, es fehlt also ein "refresh" zwischendurch.


    Kennt ihr das Problem, oder besser, habt ihr eine Lösung dafür?


    Grüße vom Pi2-user

    Edited once, last by Pi2-user ().

  • Bullseye scheint noch "im Reifeprozess" zu sein 😉

  • Da kann nicht viel reifen, wenn die Gegenstelle nocht mit der Buschtrommel trommelt. WIN98 dürfte überhaupt nicht mehr funktionieren.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • An Win7 liegt es nicht!

    Mit Win10 ist das Verhalten gleich.

    Benutzt niemand von euch Bullseye + Remote Desktop?

  • Ich habe nur das VNC, das war schon vorinstalliert.

    Dito!

    Verschiebe ich Icons auf dem Desktop, wird die neue Position erst nach einem Klick an eine andere Stelle dargestellt, es fehlt also ein "refresh" zwischendurch.

    Kann ich damit (VNC) bestätigen. Ein Problem mit blockweisem Aufbau des Desktops habe ich auch bei höherer Auflösung allserdings nicht. Getestet mit einem RPi 3B (ohne Plus).

  • Ich habe heute VNC getestet. Verbindung klappt, allerdings wird nur das obere, linke Viertel vom Desktop angezeigt, alle Icons werden hierhin zusammengequetscht verschoben. Die Titelleiste wird an den Blidausschnitt angepasst. Wird ein Fenster geöffnet erscheint es in der Mitte des eigentlichen Desktop, also sieht man nur die linke, obere Ecke davon.

    Ganz witzig, in der Titelleiste ist das VNC Symbol zu sehen wenn die Verbindung mit VNC aufgebaut ist, GLEICHZEITIG verbunden mit RDP ist das Symbol in der Leiste nicht sichtbar. Ich hänge hier mal zwei Bilder dran, VNC und RDP zur gleichen Zeit, damit ihr seht was ich meine.


    Habe mit allen Einstellungen rumgespielt, das ändert leider nichts. Mit anderen Worten, VNC funktioniert bei mir noch schlechter als RDP.


    Für Lösungsansätze bin ich dankbar,

    Gruß, Pi2-user

  • Vielen Dank hyle! Jetzt funktioniert mein RDP im Vollbild-Modus.

    Dieses Problem:

    Verschiebe ich Icons auf dem Desktop, wird die neue Position erst nach einem Klick an eine andere Stelle dargestellt, es fehlt also ein "refresh" zwischendurch.


    wird dadurch nicht gelöst, ist mir aber auch nicht so wichtig.


    VNC wird in Postkartengröße jetzt mittig positioniert dargestellt. VNC werde ich weiterverfolgen, da RDP ja jetzt nutzbar ist.


    Einen schönen Sonntag wünscht,

    Pi2-user

  • Dieses Problem:

    Verschiebe ich Icons auf dem Desktop, wird die neue Position erst nach einem Klick an eine andere Stelle dargestellt, es fehlt also ein "refresh" zwischendurch.


    wird dadurch nicht gelöst, ist mir aber auch nicht so wichtig.

    Ist leider doch wichtig !


    Icons verschiebt man ja nicht so häufig, aber Fenster! Das verschieben von Fenstern ist ein Geduldspiel, teilweise 3 -5 Sekunden nach der letzen Mausbewegung kommt das Fenster an seiner Position an. Das nervt extrem.


    Ich habe die Einstellungen der conf.txt mit der conf.txt des alten "Stretch" verglichen, da ich die Probleme da ja nicht hatte. Mir sind allerdings keine verdächtigen Einträge aufgefallen.


    Wenn jemand einen Tipp hat, warum meine Grafik eine so geringe refresh-rate hat, wäre ich sehr dankbar.


    Gruß, Pi2-user

  • da RDP ja jetzt nutzbar ist.

    Scheinbar doch nicht. :conf:


    Das verschieben von Fenstern ist ein Geduldspiel, teilweise 3 -5 Sekunden nach der letzen Mausbewegung kommt das Fenster an seiner Position an.

    Dieses Problem habe ich nicht. Natürlich ist es nicht so flüssig wie wenn man vor dem Monitor sitzt, aber die Fenster "hängen" am Mauspfeil.

  • @ hyle: Ich hatte mich zu früh gefreut, Full-Screen funktionert ja seit deinem Tipp.


    Das langsame Verschieben der Fenster ist absolut nicht normal, ich vermute, dass die Grafikeinstellungen nicht passen, oder zu wenig Speicher bereitgestellt wird. Ich durchforste gerade das WWW um passende Hinweise zu finden. Teilweise erscheinen von Python erstellte Fenster nicht, weil sie vermutlich nur einmal erstellt werden. Findet dann gerade kein Screen-Update statt, sieht man eben kein Fenster.

  • Zwei kleine Schritte Richtung Ziel:

    - Mein Netzteil war ein wenig schwach, wurde gegen ein leistunsfähigeres ausgetauscht. Brachte gefühlt etwas bessere Performance.

    - Bei den Einstellungen der RDP Verbindung (amPC) habe ich die Farbtiefe von "Höchste Qualität 32 Bit" auf "High Color 16 Bit" reduziert. Damit lassen sich die Fenster normal verschieben. (Das Icon-versteck-dich-Spiel ist aber immer noch da)

  • Was haste denn der GPU an Speicher in der config.txt (und/oder über raspi-config) zugewiesen ??


    An Probleme kann ich mich eigentlich nicht mehr erinnern aber ich habe inzwischen auf Ubuntu umgestellt, bis das Raspberry Pi OS in 64 Bit finalisiert wurde.

    ;) Gruß Outi :D
    PIs: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Tests) / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 (B. Lite) / 2x Pi Zero 1.3 (B. Lite)
    2x Pi Zero W 1.1 (B. Lite) / 1x Pi Zero 2 (noch ohne) / 1x Pi 3 B+ (Tests) / 1x Pi 4 B 4GB (Ubuntu Server 64 Bit) / Pi 400 (Bullseye 64 Bit) / 2x Pi Pico
    Platinen: Sense HAT / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT

  • Hallo,

    ich habe mich heute auch mit einem VNC Auflösungsproblem rumgeschlagen und einen Workaround gefunden.

    System:

    Win10, RealVNC <-> RPi4B Buster


    Problem:

    Auflösung mit ungestecktem HDMI Kabel am RPI nur 1024, mit gesteckten Kabel am RPI 1920.

    Egal ob HDMI Port 0 oder 1.

    Häh???


    Lösung:

    Aber VORSICHT:

    Es kann passieren, dass beim Probieren der RPI nicht mehr bootet. Also immer ein Backup haben (2. SDCard oder USB Stick) oder einfach die SDCard in den Win10 PC stecken (Kartenleser!) und die Änderung im Laufwerk "boot" in der Datei config.txt zurücknehmen.

    Beispiel: Wenn ich vor hdmi_cvt=1920 1200 60 ein Kommentarzeichen machte (#hdmi_cvt=1920 1200 60), ließ sich der RPi NICHT mehr booten.


    Nach stundenlangen Rumprobieren und Internetsuche habe ich ein Setting für die config.txt (Komplette Datei im Anhang) gefunden und folgendes eingefügt:

    # STICKY: HOWTO: Create Custom HDMI modes (needed for vnc realvnc viewer without plugged monitor)

    # https://forums.raspberrypi.com/viewtopic.php?f=29&t=24679

    # https://elinux.org/RPiconfig#Video_mode_options

    # https://learn.adafruit.com/usi…pberry-pi/everything-else

    # https://www.raspberrypi.com/do…html#hdmi-groups-and-mode

    # set custom mode and DMT group:

    hdmi_cvt=1920 1200 60

    hdmi_group=2

    # activate cutom mode

    hdmi_mode=87


    Ebenfalls war auch hdmi_cvt=1920 1080 60 möglich.


    Ach ja:

    Mit obiger Einstellung wird die Auflösung festgenagelt und kann dann nicht "online" über die "Screen Configuration" geändert werden!


    Viel Glück...



    Mein Raspi System:

    hostname:

    Static hostname: raspberrypi

    Icon name: computer

    Machine ID: 5ff5aac40c5140c786b9ac9e9c34729d

    Boot ID: 028c1d1e4463426280fb9c305659ce74

    Operating System: Raspbian GNU/Linux 10 (buster)

    Kernel: Linux 5.10.63-v7l+

    Architecture: arm


    OS Kernel version:

    Linux raspberrypi 5.10.63-v7l+ #1496 SMP Wed Dec 1 15:58:56 GMT 2021 armv7l GNU/Linux


    VC6 VideoCore firmware build date and version:

    Dec 1 2021 15:02:46

    Copyright (c) 2012 Broadcom

    version 71bd3109023a0c8575585ba87cbb374d2eeb038f (clean) (release) (start_x)


    Raspberry hardware version:

    Raspberry Pi 4 Model B Rev 1.2

  • Hallo,


    ich habe mich gerade in dem Form angemeldet, weil ich über einen Lösungsansatz für RDP unter Bullseye gestolpert bin, und diesen gern teilen möchte. Ich habe unter dem Link eine Lösung gefunden, die für mich funktioniert. Ich verstehe nicht genau warum, dafür bin ich noch zu sehr Laie, aber es funktioniert.


    In dem Eintrag wird auch genau mein Problem beschrieben, beim Pi 3 funktioniert RDP, beim Pi 4 nicht, obwohl ich (eigentlich) genau das selbe gemacht habe.


    Vielleicht hilft es ja auch bei anderen.


    Gruß, Waldwuffel