Uhrzeit mit Unipi 1,1 RTC synchronisieren

  • Hi,

    ich habe einen Raspi4 mit einer Unipi 1.1-Platine. Die Unipi hat ja ein RTC-Modul. Dort habe ich auch eine Knopfzelle eingelegt. Zum Testen habe ich WLAN deaktiviert und das Gerät eine Zeit ausgeschaltet, die Zeit bleibt dann aber stehen.

    Nun zur Frage: Wo muss man was einstellen, damit er die Zeit mit der Unipi synchronisiert?

    Wäre sehr wichtig, da ich für einen Kunden eine Zeitsteuerung gebaut habe und dort die Zeit auch nach einem Stromausfall wieder passen muss.


    Betriebssystem Raspberry OS Desktop(neustes Release)


    Danke im Voraus.

  • Die Unity Platine kenne ich nicht. Ich weiss daher nicht, wie bisher Deine Konfiguration eingestellt wurde.


    Normalerweise wird (ohne Spezialimage) am Pi von Linux die fake-hwclock verwendet und die Systemzeit von einem Zeitserver nachjustiert. Beim Shutdown wird die System-Zeit in /etc/fake-hwclock.data gespeichert und beim nächsten Booten wieder eingelesen und solange als Systemzeit weiterverwendet, bis eine andere Zeitsyncronisation (Netzwerkzeit) erfolgt.


    Ein I2C RTC wird normalerweise wie folgt konfiguriert.

    In /boot/config.txt muss der (spezielle) I2C Uhrenchip als dtoverlay= angegeben werden.

    fake-hwclock.service muss gestoppt, disabled und soll maskiert werden.

    hwclock.service muss unmaskiert, gestartet und enabled werden.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Es handelt sich vermutlich um diese Platine: https://www.unipi.technology/unipi-1-1-p36


    Hast du die Platine vielleicht schon in Betrieb genommen, ohne eingelegter Knopfzelle? Falls ja, kann laut "Technical and safety information" das RTC Modul und andere Komponenten kaputt gehen.


    In der Anleitung konnte ich sonst nichts zur Inbetriebnahme der RTC finden. Daher würde ich den Rat von RTFM folgen, oder den Hersteller fragen.

  • Hast du die Libraries von Github geholt und nach Handbuch erst die 2032 eingelegt, bevor du das Modul in Betrieb genommen hast (siehe auch die Antwort vonRTFM)? Hast du eine eigene Stromversorgung für das Modul installiert? Es wird nicht empfohlen, die Stromversorgung über den Pi zu leisten.


    Alles Fragen, die ich in fünf Minuten Lesen der Doku gefunden habe. Die 12 Seiten sind ja schnell gelesen.