RaspiBackup bricht mit RC1 (RBK0021E) ab | Fehlercode 109

  • Hallo Framp,


    ich habe hier einen Zero2 mit recht frisch installiertem Bullseye.


    Das Verzeichnis /backup habe ich über SMB mit einem NAS verbunden.


    Dein Script habe ich installiert. Rsync lehnte dein Script ab, da das Backupziel keine Dateiattribute kann. Also habe ich in der raspiBackup.conf den Backuptyp von rsync auf "tar" gestellt, sowie zip eingeschaltet.


    Code
    # Typ des Backups: dd, tar or rsync
    DEFAULT_BACKUPTYPE="tar"
    
    # zip tar oder dd backup
    DEFAULT_ZIP_BACKUP="1"


    Wenn ich jetzt das Backup starte, läuft es sauber los. Das Image von der Bootpartition wird angelegt, dann legt er die TGZ-Datei an und kommt nach 20min ca. 1100MB weit.


    Dann bricht das Script ab.


    Fehlermeldung:

    Code
    ??? RBK0021E: Backupprogramm des Typs tgz beendete sich mit RC 1.

    Error 109 habe ich noch gefunden, was auf einen Fehler von tar hinweist. Einen Logeintrag von tar habe ich in den Logs (/var/log) nicht finden können.


    Anbei das vollständige Log (raspiBackup.log).


    Was kann ich noch tun?


    Viele Grüße

    Peter


    ##################################


    Nachtrag:

    Ich lasse das Script gerade noch mal mit "--systemstatus" laufen.

  • Auszug aus dem Logfile:

    Code
    tar: /etc/pihole: Datei hat sich beim Lesen geändert.
    tar: Entferne führende „/“ von Zielen harter Verknüpfungen
    20220212-215006 DBG 2296:                  <-- executeCmd 1
    20220212-215006 DBG 4781:              <-- tarBackup 1
    20220212-215006 DBG 3594:              --> colorAnnotation 1
    20220212-215006 DBG 3618:              <-- colorAnnotation 
    ??? RBK0021E: Backupprogramm des Typs tgz beendete sich mit RC 1.

    Vermutlich ist die Warnmeldung tar: /etc/pihole: Datei hat sich beim Lesen geändert. verantwortlich.

    Hier auf Englisch zum Gugeln:

    Code
    tar: /: file changed as we read it


    Evtl. hilft die tar Option [tt]--warning=no-file-changed[/tt].

    Wie es sich dann aber mit dem Returncode verhält, weiß ich nicht. Er bleibt wohl bei "1".


  • Leider hilft mir das Log auch nicht. Es hat sich waehrend des Backups eine Datei geaendert ... Siehe auch hier.

    Ich lasse das Script gerade noch mal mit "--systemstatus" laufen.

    Das ist der richtige Weg. Leider sagt tar nicht welche Datei es ist. rsync wuerde es Dir sagen. D.h. Du musst leider etwas suchen. Es gibt auch die Moeglichkeit den RC1 Abbruch bei raspiBackup zu verhindern. Wenn Du nicht weisst was die Ursache ist finde ich das aber sehr gefaehrlich. Vermutlich musst Du nur weitere Services stoppen.

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect."

    Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert :fies: Bei mir tut das raspiBackup automatisch :shy:

    Edited once, last by framp ().

  • Danke für das (schnelle) Feedback.


    Ich lasse mal das Script sprechen (nachdem ich pi-hole gestoppt habe):

    Code
    --- RBK0017I: Backup erfolgreich beendet.

    Der Zeile:

    Code
    tar: /etc/pihole: Datei hat sich beim Lesen geändert.

    habe ich nicht die Aufmerksamkeit gewidmet, die sie benötigt hätte.


    Ich bin in meiner (manchmal grenzenlosen) Naivität davon ausgegangen, dass eine Datei, die sich während des Lesens ändert, einfach noch mal gelesen wird.

    Viele Grüße,

    Peter

  • Vermutlich ist die Warnmeldung tar: /etc/pihole: Datei hat sich beim Lesen geändert. verantwortlich.

    Die habe ich doch echt uebersehen im Log :blush: Dann reicht es wohl pihole vor dem Backup zu stoppen. Allerdings frage ich mich wer oder was in der /etc/pihole eine Datei aendert :conf: Ich sichere meine NetzwerkRaspi auf der auch Pihole laeuft ohne Stoppen von Pihole :shy:

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect."

    Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert :fies: Bei mir tut das raspiBackup automatisch :shy:

  • /etc/pihole eine Datei aendert

    Dort werden regelmäßig vier Dateien geändert.

    Ich vermute, dass es bei mir die pihole-FTL.db ist. Die ist bei mir auch rund 100MB groß.


    Da ich ungern den Pi-hole für rund 20min offline legen will, habe ich in deiner Conf-Datei nun folgendes eingetragen:

    Code
    DEFAULT_EXCLUDE_LIST="/etc/pihole/pihole-FTL.db /etc/pihole/dhcp.leases /etc/pihole/localbranches /etc/pihole/localversions"

    und den Stop vom Pi-Hole wieder rausgenommen.


    Zum Testen bin ich jetzt noch nicht gekommen. Das hole ich morgen nach.

    Viele Grüße,

    Peter

    Edited once, last by Peter0311 ().

  • Das mit der exclude Liste wird so nicht funktionieren. Du musst die tar Syntax beruecksichtigen ;) Siehe dazu auch hier.

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect."

    Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert :fies: Bei mir tut das raspiBackup automatisch :shy:

  • Ich habe den Durchlauf mit folgendem Eintrag gemacht:

    Code
    DEFAULT_EXCLUDE_LIST="--exclude=/etc/pihole/pihole-FTL.db --exclude=/etc/pihole/dhcp.leases --exclude=/etc/pihole/localbranches --exclude=/etc/pihole/localversions"

    Obwohl das die vier Dateien sind, die sich alle paar Minuten ändern, hat das Backup nicht geklappt (gleiche Fehlermeldung).


    Erst mit:

    Code
     DEFAULT_EXCLUDE_LIST="--exclude=/etc/pihole"

    lief das Backup durch.


    Da ich mit dem Fehlen vom Verzeichnis leben kann und das Backup nun funktioniert, werde ich es dabei belassen.


    Danke für die Hinweise und Hilfe.

    Viele Grüße,

    Peter

  • mit dem Fehlen vom Verzeichnis leben

    Du könntest vor dem Backup das aktuelle PiholeVerzeichnis an eine andere Stelle kopieren. Dann kannst Du beim restorten Backup zur Not die alten Daten zurueckkopieren. Option DEFAULT_BEFORE_STOPSERVICES könntest Du dafür nehmen.

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect."

    Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert :fies: Bei mir tut das raspiBackup automatisch :shy:

  • Bin auch gerade über den gleichen Fehlercode gestolpert... ebenfalls mit einer Datei die sich geändert hat...

    "system.journal: file changed as we read it"

    Danach kamen noch knapp 100 Meldungen

    "tar: /var/lib/samba/private/msg.sock/xxxx: socket ignored" wobei xxxx verschiedene Ziffern hatte...


    Aus diesem Grunde beschäftige ich mich gerade mit dem Thema "Services stoppen".

    Ich mache das manuell, stoppe iobroker und mysql... ich habe allerdings auch einige der Services aktiv die in deinen Manuals online gelistet sind, die man beachten sollte.

    Dazu ein paar konkrete Fragen:

    • Macht das Sinn alles zu stoppen was da gelistet ist ?
    • Funktioniert danach noch die mount-Verbindung zu einem Windows-Shared-Drive auf die ich sichern will ?
    • Haben sich die stop-Befehle vielleicht in der Zwischenzeit geändert? "sudo /bin/systemctl stop samba" bringt bei mir eine Fehlermeldung "Failed to stop samba.service: Unit samba.service not loaded."
  • Macht das Sinn alles zu stoppen was da gelistet ist ?

    Sinn macht es nicht. Nur die Servcices die irgendwelche Stati im Speicher halten wie z.B. iobroker und mysql. nfsserver und samba machen vermutlich auch Sinn.

    Funktioniert danach noch die mount-Verbindung zu einem Windows-Shared-Drive auf die ich sichern will ?

    Dazu wird der Samba Client genutzt - nicht der Server.

    Haben sich die stop-Befehle vielleicht in der Zwischenzeit geändert?

    Nein. Die Meldung sagt dass Samba schon gestoppt ist :)

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect."

    Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert :fies: Bei mir tut das raspiBackup automatisch :shy:

  • Dazu wird der Samba Client genutzt - nicht der Server.

    Nein. Die Meldung sagt dass Samba schon gestoppt ist :)

    Seltsam... samba läuft bei mir aber... ich habe ein Share erzeugt mit dem ein Verzeichnis vom Raspberry im Netzwerk freigegebn ist und das ist auch erreichbar...

  • samba

    ... ist fuer mich ein Tool was ich nicht nutze und demnach Dir auch so gut wie nicht helfen kann :no_sad:

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect."

    Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert :fies: Bei mir tut das raspiBackup automatisch :shy:

  • Haben sich die stop-Befehle vielleicht in der Zwischenzeit geändert? "sudo /bin/systemctl stop samba" bringt bei mir eine Fehlermeldung "Failed to stop samba.service: Unit samba.service not loaded."


    Seltsam... samba läuft bei mir aber

    Samba Server ist die smbd.service Datei, die gestoppt werden müsste.