PI 3 B lässt sich nicht auf "booten von USB" umschalten.

  • Moin,

    bin Anfänger in Sachen Raspberry.

    Ich habe einen Raspbery Pi 3 B und möchte ihn gerne von einem USB-Stick booten lassen.

    Dazu muss man wohl einen Eintrag in der config.txt-Datei machen, anschliessend soll man prüfen ob nach dem Booten umgestellt wurde.

    Wenn ich mit:


    vcgencmd otp_dump | grep 17:


    prüfe kommt nur die Antwort 17:1020000a statt 17:3020000a


    Was kann ich machen ? Bzw gibt es eine bestimme Betriebssysemversion mit der bestimmt klappt, und auf der auch iobroker läuft?

  • Hallo stevensen,


    willkommen im Forum! :)


    Öffne die /boot/config.txt und lösch die Zeile program_usb_boot_mode=1 wieder, dann speichern und die Datei schließen.


    Danach im Terminal:

    Code
    echo program_usb_boot_mode=1 | sudo tee -a /boot/config.txt

    und den RPi neu starten.


    Wie ist jetzt die Ausgabe von

    Code
    vcgencmd otp_dump | grep 17:

    ?


    Und was ist die Ausgabe von

    Code
    grep -E "Model|Revision" /proc/cpuinfo

    ?

  • Ha wie witzig, ich fühl' mich ein wenig verar...


    Aber jetzt klappts!!! :D


    Das gibts doch gar nicht.


    Ich habe ja verschiedene Tutorial angeschaut und genau so gemacht und alles upgedatet und auch den Eintrag in der config.txt schonmal gelöscht und wieder eingetragen.

    Und dann hier mal nachgefragt und dann klappts.

    Also vielen Dank hyle und auch RTFM für die Antworten!

    Ich müsste ich noch wissen wie ich mit dem iobroker auf den Usb-Stick umziehe, aber dann melde ich mich ggfs. wieder

  • Der Eintrag program_usb_boot_mode=1 muss wirklich am Dateiende stehen, sonst funktioniert das nicht. Da einige Editoren, u.a. auch nano, am Ende der bearbeiteten Datei eine Leerzeile erstellen, wird das damit nichts.


    Durch tee mit der Option -a für append, also anhängen, passiert das nicht und der Eintrag steht damit wirklich am Dateiende.

  • Ich habe geschaut in dem Tutorial ist genau die selbe Zeile und ich habe auch diese Zeile benutzt und nicht selbst manuell eingetragen.
    Es ist merkwürdig, aber irgendwas hat wohl nicht gestimmt, sonst wäre es ja gelaufen.

  • Ich musste auf meinem Raspi 3B+ in der Config.txt noch die Zeile program_usb_boot_timeout=1 hinzufügen, damit der Raspi von der USB SSD bootete. Davor musste ich noch das USB Kabel wechseln, weil mir demsg zeigte, dass das Kabel offenbar defekt war. Nach dem Kabeltausch und der zusätzlichen Zeile, durch die länger auf die Meldung des USB Datenträgers gewartet wird, startet der Raspi nun auch von der USB SSD.