Raspberry 3 B / Retropie Update fehlgeschlagen

  • Hallo,


    ich habe seit 2017 einen Raspberry 3 B auf dem Retropie und ein Betriebssystem installiert ist und wunderbar funktionierte.

    Das ganze hatte damals ein Arbeitskollege für mich installiert. Von daher habe ich nur wenig Ahnung davon.


    Man konnte die Emulatoren ohne Probleme verwenden aber eins fehlte noch zum richtigen Retroerlebnis. Und zwar die Möglichkeit alte Joysticks anzuschließen.


    Also kaufte ich jetzt einen Adapter mit dem das möglich ist.

    Doch der funktionierte nicht auf dem Atari.

    Also versuchte ich es mit einem Update von Retropie und einem für den Raspberry.

    Danach funktionierte der Atari Emulator aber der Amiga nicht mehr. Also habe ich dann auch noch versucht den zu deinstallieren und zu installieren, was dann aber nicht mehr ging.


    Also stand der a Dinge ist, ich habe jetzt Retropie ohne Amiga und, ach ja, kein Betriebssystem mehr. Wenn ich startx ausführen will, gibt es Fehlermeldungen.


    Ich würde jetzt gerne alles platt machen und alles nochmal frisch installieren.

    Jetzt meine Frage, wie mache ich das?

    Oder gibt es eine Möglichkeit das Betriebssystem wieder zu reparieren und den Amiga Emulator wieder zu installieren?


    Für zweites würde ich die Fehlermeldungen hier posten. Also die beim Start vom Betriebssystem kommen und die bei der Installation des Amigas unter Retropie.


    Danke euch schon mal.

  • Ich würde jetzt gerne alles platt machen und alles nochmal frisch installieren.

    Jetzt meine Frage, wie mache ich das?

    Mit dem Raspberry Pi Imager das Raspberry Pi OS auf der Karte installieren. Wenn das funktioniert hat, du das Raspberry Pi OS gestartet hast und apt update && apt dist-upgrade ausgeführt, einmal das System neu starten. Danach kann man RetroPie manuell installieren.

    Oder gibt es eine Möglichkeit das Betriebssystem wieder zu reparieren und den Amiga Emulator wieder zu installieren?

    Ohne Fehlermeldungen wird es wohl schwer zu helfen.

  • Und wenn ich ab alles nochmal neu aufsetze?

    Also die SD Karte formatierte, neues Betriebssystem und Retropie neu.


    Wie mache ich das? Gibt es dazu eine Anleitung?

  • Danke!

    Werde ich ausprobieren.


    Aber eine Frage habe ich vorab.

    Ich möchte die alte sd Karte vorher kopieren um z.B Konfigdaten später zurück zu holen.


    Ich habe einen Mac mit Sd-Kartenslot.


    Wenn ich die Karte vom Raspberry darüber öffne, kann ich aber auf keine Dateien zugreifen. Ist ja auch klar, ist ja nicht das selbe Betriebssystem.

    Wie kann ich denn eine Kopie davon machen, so dass ich da später nochmal an die Daten komme?


    Also erstes Problem, wie kopiere ich die Daten überhaupt (einfach copy n paste?) und zweites Problem, wie konnte ich später wieder dran.


    Danke nochmal!

  • Im Menü -> Zubehör ist der "SD Card Copier" zu finden. Damit sollte es möglich sein die SD Karte auf einen an USB angeschlossenen Massenspeicher zu kopieren. Davon sollte man auch einfach die benötigten Daten wieder auf SD Karte kopieren können.


    Es gibt aber noch andere Möglichkeiten zu kopieren (z.B. mit rsync, cp, tar oder ...). Am besten man wählt immer das gleiche Dateisystem für Quelle und Ziel (in diesem Fall ext4). Das ist wichtig um Dateiattribute und Links beim kopieren zu erhalten. Mit tar sollte aber auch ein fremdes Dateisystem kein Problem sein. Kopieren über Netzwerk ist auch möglich und es gilt i.d.R. das selbe zu beachten.

  • Mit dem Raspberry Pi Imager das Raspberry Pi OS auf der Karte installieren. Wenn das funktioniert hat, du das Raspberry Pi OS gestartet hast und apt update && apt dist-upgrade ausgeführt, einmal das System neu starten. Danach kann man RetroPie manuell installieren.

    Ohne Fehlermeldungen wird es wohl schwer zu helfen.

    Hallo,

    soweit hat alles geklappt.
    Beim Boot startet es in der grafischen Benutzeroberfläche und nicht auf der Konsole.
    Habe jetzt dort die Konsole geöffnet und apt update ausführen wollen.

    Da kommt aber eine Fehlermeldung:
    "Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)"
    "Unable to lock directory /var/lib/apt/lists/"

    Was nun?

    Danke schonmal!!!!

  • Post by PhiGiro ().

    This post was deleted by the author themselves ().
  • Anscheinend fehlen die entsprechenden Rechte beim Aufruf "apt update". Probiere es mal mit "sudo apt update", oder wechsle zum Benutzer root und dann "apt update".

  • Huhu!

    Ich habe mittlerweile, nach der oben genannten Anleitung Retropie installiert. Im Menü Basic Install durchgeführt.

    Es endete mit vielen Fehlermeldungen, dass diverse Dinge nicht installiert werden konnten.

    Zu viele um sie hier aufzuführen


    Wenn ich nun Emulationstation ausführen möchte, kommt, dass er den Befehl nicht kennt.


    Warum?

    Und warum die Fehlermeldungen?


    Vielleicht kann mir nochmal jemand helfen.

    Ich habe wirklich jeden Schritt in der Anleitung richtig durchgeführt.


    Danke schon mal!

  • Mit dem Raspberry Pi Imager das Raspberry Pi OS auf der Karte installieren. Wenn das funktioniert hat, du das Raspberry Pi OS gestartet hast und apt update && apt dist-upgrade ausgeführt, einmal das System neu starten. Danach kann man RetroPie manuell installieren.

    Warum so umständlich?

    Du kannst mit dem Pi Imager das entsprechende Image für den entsprechenden Pi direkt flashen.

    Es gibt für jeden Pi eine entsprechende Version.


  • Post by PhiGiro ().

    This post was deleted by the author themselves ().
  • Post by PhiGiro ().

    This post was deleted by the author themselves ().
  • Habe das Image RetroPie 4.8 (RPI 2/3/Zero 2 W) installiert.

    Nun ist es wieder gecrashed mit der Fehlermeldung:

    “emulation station crashed! If this is your first boot of retropie - make sure you are using the correct image for your system. Check your rom file/folder permissions and if running on a raspberry pi make sure your gpu split is set high enough and/or switch back to using carbon theme.”

    Wie mach ich das, was da in der Fehlermeldung steht?

  • Warum so umständlich?

    Weil PhiGiro Raspberry Pi OS (bzw. vermutlich Raspbian Stretch, da von 2017) und RetroPie laufen hatte und es wohl auch so wieder haben wollte.

    Wie mach ich das, was da in der Fehlermeldung steht?

    Hast du wirklich das richtige Image für den Raspberry Pi 3B gewählt? Siehe auch den Beitrag von Franjo G. Ansonsten würde ich es mal mit einer neuen SD Karte probieren. Der GPU Speicher sollte eigentlich schon richtig gesetzt sein, aber du kannst es kontrollieren (zu finden in der Datei /boot/config.txt).

  • Weil PhiGiro Raspberry Pi OS (bzw. vermutlich Raspbian Stretch, da von 2017) und RetroPie laufen hatte und es wohl auch so wieder haben wollte.

    Ja, genau. Geht das denn jetzt nicht mehr?



    Hast du wirklich das richtige Image für den Raspberry Pi 3B gewählt? Siehe auch den Beitrag von Franjo G. Ansonsten würde ich es mal mit einer neuen SD Karte probieren. Der GPU Speicher sollte eigentlich schon richtig gesetzt sein, aber du kannst es kontrollieren (zu finden in der Datei /boot/config.txt).

    welches ist denn das richtige für den 3B?
    Ich hatte das zweite von oben genommen.

    Die Rechte der Roms stehen übrigens auf drwxr-xr-x Gruppe und User sind pi

  • Also ich habe einen Raspberry 3 B und das Image RetroPie 4.8 (RPI 2/3/Zero 2 W) auf die SD Karte gespielt.

    Nach einem Reboot startet Emulationstation jedoch sind keine Emulatoren da.
    Man kann nur die Configuration auswählen.

    Der Controller funktioniert.

    Was muss ich denn jetzt tun, damit einer der Emulatoren erscheint?

  • Ja, genau. Geht das denn jetzt nicht mehr?

    Ich kenne das RetroPie Image nicht. Kann aber sein, dass es einen Menüpunkt gibt, der Raspberry Pi OS nach installiert. Das wäre dann recht einfach. Wird sich aber vermutlich leicht vom offiziellen Raspberry Pi OS unterscheiden. Ansonsten müsste man es selber manuell nach installieren. Das wäre eher schwierig, wenn man nicht weiss wie. In dem Fall würde sich halt anbieten, erst Raspberry Pi OS installieren und dann RetroPie hinterher. Das ist zumindest einfach. Kannst du nicht deinen Arbeitskollegen fragen wie/was er damals gemacht hat?


    Wie lief denn dein System? Wurde RetroPie gestartet und du konntest von dort Raspberry Pi OS starten, oder umgekehrt?

    Also ich habe einen Raspberry 3 B und das Image RetroPie 4.8 (RPI 2/3/Zero 2 W) auf die SD Karte gespielt.

    Das sollte/wird das richtige sein.

  • Ah, ok!
    Hm, ich habe gerade versucht über das Retropie Configmenü, den C64 (Vice) zu installieren.
    Über manage Package / optional package.

    Das geht nicht, da steht die Info "install option disabled" und das CURL nicht funktioniert.
    Besser gesagt, da steht "Could not resolve host: files.retropie.org.uk"

    Warum kann er den Server denn nicht erreichen? Die Internetverbindung müsste funktionieren.