booten von usb pi 3b+ 64bit bullseye

Registriere dich jetzt, um exklusive Vorteile zu genießen! Als registriertes Mitglied kannst du Inhalte herunterladen und profitierst von einem werbefreien Forum.
Mach mit und werde Teil unserer Community!
  • hi @ all!


    ich hab da mal wieder nen kleines problem.

    problem: booten von HDD mit 3b+ geht nicht.


    HW: 3b+, 2,5 " HDD in einem gehäuse ohne aktive stromversorgung

    OS: raspbian bullseye 64bit


    beim rumsuchen im inet habe ich gefunden, das der 3b+ usb-boot kann ohne gefummel, naja mein 3b+ hat den artikel wohl nicht gelesen.


    also hab ich probiert, mit eintrag in config.txt mit usb-boot auf 1 setzen.

    beim testen mit vcg... grep 17 kommt ne fehlermeldung - also war das keine lösung.


    dann hab ich mit update und uprade - rpi-update und dann rpi-eeprom sagt mir ist nur für pi4.

    ging auch nicht.


    dann hab ich ne SSD genommen wegen dem stromthema und der reaktionszeit - hat auch nichts gebracht.


    hab es auf der HDD mit einem frischen image und einem backup-image von der SD-karte probiert. der 3b+ liest mal ganz kurz auf der HDD aber booten ist nicht.


    wenn ich mit der SD-karte boote ist alles normal und die platte ist sofort da.


    hat jemand ne idee?


    danke für ideen im voraus. :danke_ATDE:

    die wahrheit will keiner hören oder lesen.

  • in dem artikel statt nichts davon das ne SD-karte im PI sein muss.

    in wiederum anderen stand das sie bei einem 3b ohne plus die SD-karte mit der boot-partion auf der karte gelassen haben und root-fs ausgelagert haben.


    dann ist das aber kein USB-boot.

    die wahrheit will keiner hören oder lesen.

  • hyle - ich verwende immer nur orginal NTs von meinem PI-dealer. - spoiler - berrybase


    die erwähnten images war einmal ein unverändertes basis-image von raspbian und das andere beeinhaltet anpassungen an mein netzwerk und benutzer.

    das angepasste image erzeuge ich als image von der SD-karte nach installation und konfiguration, mit LW (genome disk utility) auf einem anderen PI.

    das verändete image hat den 3b+ als einzigen PI zum starten gehabt und stammt von dessen SD-karte, keine nutzung mit einem 4er oder 400erter.

    dann schreib ich das direkt auf die HDD, so wie ich das bei meinen 4er bzw. 400er PIs auch gemacht habe.

    ich nehme keine modifikationen am kernel oder anderen OS relevanten teilen vor.


    das mit der leeren SD-karte stand in einem anderen artikel, das soll ja nur das booten beschleunigen, aber das ist nicht das problem das die boot-dauer ein kritischer aspekt ist.


    der 3b+ ist nur der steuercomputer für mein heimkino system, das stört mich nicht, wenn der 1 minute oder 2 braucht zum booten.


    und bei den 4ern und 400ern kann ich die PIs durchtauschen und alle starten ganz normal.


    als frage dazu, stört das das ein 64bit OS ist?

    die wahrheit will keiner hören oder lesen.

  • als frage dazu, stört das das ein 64bit OS ist?

    Sollte eigentlich nicht stören.


    Ich würde einfach mal den aktuellen Raspberry Pi Imager installieren, in dem ein Raspberry pi OS auswählen, die Einstellungen (Zahnrad) erledigen, die HDD als Ziellaufwerk auswählen, das OS runterladen und installieren lassen.


    Für diesen Test würde ja auch erstmal ein Lite OS ausreichen, um die Downloadzeit zu verkürzen.

  • @ hyle - den imager kenn ich und ich habe die images auf meinem 6TB lager-LW also muß ich nix extra runterladen.


    es sollte doch keine rolle spielen mit welchem PRG ich das image schreibe, da das image eine bitweise 1 zu 1 kopie ist.


    aber ich probiere auch das aus.

    die wahrheit will keiner hören oder lesen.

  • dann hab ich mit update und uprade - rpi-update

    rpi-update ist keine gute Idee.


    Ansonsten bootet der 3B+ von Haus aus von usb.

    Es spielt auch keine Rolle, ob 32 oder 64 bit.


    Was für einen USB-SATA Adapter verwendest du denn? Möglicherweise machen einige auch Probleme beim 3B+.

    Wenn der allerdings mit nem 4er funktioniert, sollte das nicht das Problem sein.

  • also ich hab jetz mal try and error gespielt

    mit der neuen lite und mit GUI -orginal image.

    und auch das nretzteil gewechselt von meinem anderen 3b+ - ja ist auch orginal

    hab auch ne SSD mit anderen adapter/gehäuse probiert schon .


    wie gesagt weis mein 3b+ wohl nicht das er von huse aus usb-boot kann, sonst hätte ich ja nicht mit rum experimentieren und dumme fragen stellen angefangen.

    die wahrheit will keiner hören oder lesen.

  • RTFM - nein kein mysterium - nur mein "sprichwörtliches glück" - also die reziproke version davon.

    und zum spass ist mein basteltisch display wohl auch noch im eimer - läuft also wieder wie immer.

    die wahrheit will keiner hören oder lesen.

  • hyle ja ich weis dumme fragen gibts nicht - nur dumme antworten.

    der andere 3b+ ist mit dem offiziellen DSI-display in einem dazugehörigen gehäuse - also die SD-karte da rauspullen ist etwas umständlich aber dann werde ich den wohl mal wieder zerlegen müssen.

    die wahrheit will keiner hören oder lesen.

  • so ich hab den zerlegt und einmal die HDD dran und die SSD - auf der HDD ist das frische image mit dem imager draufgemacht - keine reaktion

    mit der SSD mit dem modifizierten also der 1:1 kopie von der SD-karte - das lief.

    die wahrheit will keiner hören oder lesen.

  • HW: 3b+, 2,5 " HDD in einem gehäuse ohne aktive stromversorgung

    Mit einer SSD klappt das ohne zusätzliche Stromversorgung,

    mit einer HDD habe ich so meine Zweifel.

    Zumindestens bei mir hat das auch nicht funktioniert, aber ich habe es auch nur einmal probiert (Neugier).


    Versuch mal zwischen der hdd und dem RPi einen USB-Hub zu setzen.



    MfG


    Jürgen

  • Jürgen Böhm nein es war kein aktiver HUB dazwischen - die HDD had 2 anschlüße wegen dem stromthema und das half auch nicht

    .

    die HDD läuft auch alleine mit einem wenn ich von der SD-karte boote.

    die wahrheit will keiner hören oder lesen.

  • die HDD läuft auch alleine mit einem wenn ich von der SD-karte boote.

    Dann bootet die HDD aber nicht oder anders ausgedrückt, es wird nicht so viel Leistung (Strom) gebraucht wie bei einem Systemstart.


    //Edit

    Was macht eigentlich die rote LED, wenn Du versuchst von der HDD zu booten? Gibt es Meldungen bezüglich "undervoltage" in den Logs?

  • Moin scorpionesc9999,


    ich habe mal versucht dein Problem nachzustellen. Einzigster Unterschied, die HDD ist ein USB-Stick mit 16GB.


    Mein RPI: Raspberry Pi 3 Model B Plus Rev 1.3

    Code
    vcgencmd otp_dump | grep 17:
    17:3020000a

    Teilausgabe von uname -a 5.15.32-v8+ #1538 SMP PREEMPT Thu Mar 31 19:40:39 BST 2022 aarch64 GNU/Linux


    Mit dem RPI-Imager 1.72 das Raspberry Pi OS Lite (64-bit) auf dem Stick installiert.

    Eingesteckt, Spannung angelegt und gewartet.....


    Per SSH eingeloggt und rennt.


    Falls du einen USB-Stick über hast, dann, bitte, damit testen.


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • danke an alle für eure teilnahme, aber da sich der 3er so bockig benimmt werde ich das beim SD-karten-boot belassen und wenn ich dann irgendwann auf nen 4er umstelle eine HDD zum booten benutzen.


    danke für die ideen und tips

    .


    meine schlussfolgerung ist, das die kleine alte platte zu langsam reagiert beim starten und das sie zu viel strom will beim anlaufen.

    ich kann nicht sagen welche revision meine beiden 3er sind, vielleicht liegt es auch daran.


    dann muß ich halt bei der SD-karte bleiben und kann die nicht freisetzen und werde die verzeichnisse /tmp und /var/log in ein tmpfs in den RAM verlegen und das overlayfilesystem wieder aktivieren, sobald ich den DAB/DVB-T-stick in betrieb habe.


    ich schließe den thread damit.

    die wahrheit will keiner hören oder lesen.