Beim Kopieren von Bildern auf einen USB-Stick werden diese sporadisch korrupt

  • Smartphone Netzteil

    Der Anspruch an ein Netzteil Ladegerät für ein Smartphone sind viel geringer als an ein Netzteil für einen Rechner.

    Ladegerät Smartphone:

    durchweg gleichmäßige Last beim Laden, dadurch kaum Spannungsschwankungen, dazu Smartphone unempfindlich auf Spannungsschwankungen

    Netzteil Rechner:

    wechselnde schnelle Lastzustände, die vom Netzteil abgefangen werden müssen, dazu Rechner empfindlich auf Spannungsschwankungen

    Wie man daran sieht, sind die Ansprüche an ein NT für einen Rechner viel höher. Das NT muss sofort auf eine höhere Last reagieren und die Spannung halten. Ein Ladegerät für ein Smartphone reagiert auf Lastwechsel viel träger oder je nach Modell gar nicht (Spannung sinkt halt etwas).

    Ob deine Wandwarze nun dein Hauptproblem ist und es durch das Original-NT gelöst wird, kann ich dir nicht sagen. Aber im Grunde tust du dir auf jeden Fall was Gutes und dein Pi wird ordentlich versorgt.

    Viele Grüße,

    Peter

  • Beim Kopieren von Bildern auf einen USB-Stick werden diese sporadisch korrupt? Schau mal ob du hier fündig wirst!

  • Ich habe nochmal neue Erkenntnisse, die gerne mitteilen möchte. Leider bin ich jedoch noch nicht wirklich weiter gekommen.

    - Der Tausch des Netzteils hat nichts verändert

    - Die USB-Sticks, bei denen die Probleme aufgetreten sind, habe ich mit "h2testw.exe" überprüft, es wurden keine Fehler gefunden

    Außerdem bin ich mir mittlerweile eig. sehr sicher, dass die Bilder nach der Aufnahme nicht korrupt sind, sondern erst später korrupt werden. Es gib eine Art "Vorschau", bei der das aufgenommene Foto angezeigt wird, zu diesem Zeitpunkt ist es auf der SD-Karte gespeichert -> hier ist immer alles fein. Will ich mir später alle Fotos, die mittlerweile auf den USB-Stick verschoben wurden, nochmal Durchschauen, fallen die korrupten Bilder auf.

    In Verdacht hatte ich bisher trotzdem den USB-Stick, auch wenn h2testw.exe keine Fehler gefunden hat. Ich hatte vermutet, dass vielleicht erst nach gewisser Zeit Daten verloren gehen. Allerdings habe ich nun einfach mal in Windows viele Daten drauf geschrieben, diese waren auch nach längerer Zeit alle vorhanden und nicht korrupt.

    Ich habe mein Skript jetzt mal noch geändert, sodass die Bilder von SD-Karte zu USB-Stick nicht verschoben sondern kopiert werden. Seitdem ist das Problem nicht mehr aufgetreten, allerdings war das auch noch kein Dauertest.

  • ps915 February 2, 2024 at 9:08 PM

    Added the Label RPi 4

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!