Haushaltsgerät auf USB-C umrüsten (Ladestrom drosseln)

  • Moin,


    für den Akku-Fenstersauger (Kärcher WV2 [1]) habe ich das Netzteil verbummelt und weil ein Ersatz-Netzteil für ca. 10€ langweilig und zu einfach wäre, habe ich mir USB-C Module [2] gekauft und eins davon an die Kontakte gelötet. Zuvor hatte ich Jumperkabel auf die Kontakte gesteckt und den Sauger dann mit meinem Labornetzteil geladen - funktioniert super, ist aber nicht benutzerfreundlich^^. Ich beschreibe mal, wie ich vorgegangen bin und was mein aktuelles Problem ist. Vor dem Löten habe ich die Jumperkabel an das USB-C Modul gehalten und das Gerät konnte laden (grüne LED blinkt langsam). Nach diesem Versuchsaufbau habe ich dickere Kabel genommen und alles miteinander verlötet. Wenn ich dann aber ein USB-Kabel angeschlossen habe, konnte nicht geladen werden und die LED blinkt nun schnell -> Laut Anleitung "Hersteller kontaktieren". Also alles nochmal abgelötet und jetzt die Jumperkabel angelötet, weil die ja vorher im Versuchsaufbau funktioniert haben. Auch das funktioniert jetzt nicht mehr und die LED blinkt schnell. Das lustige ist nun aber, dass ich die Jumperkabel jetzt auch nochmal abgelötet habe und wenn ich die nur lieblos wieder an die Kontakte halte, funktioniert der Ladevorgang wieder. Scheinbar muss die Verbindung schlecht sein, damit es funktioniert?? Gibt es eine Sache, die ich übersehen habe? Muss/kann ich irgendwo einen Widerstand setzen?


    Die Spannung stimmt zwar nicht ganz mit dem originalen Netzteil (5,5 V DC) überein, aber mit dem Labornetzteil konnte ich auch bis auf 4V runter und es wurde immer noch geladen.



    [1] https://www.kaercher.com/ch/ni…t/wv-2-plus-16333010.html

    [2] https://www.amazon.de/gp/product/B09YLVSPQX (Affiliate-Link)

    Kelvin

  • Kelvin

    Changed the title of the thread from “Haushaltsgerät auf USB-C umrüsten” to “Haushaltsgerät auf USB-C umrüsten (Problem bei guter Verbindung)”.
  • Habe jetzt nochmal weiter herumprobiert und es sieht nach einem Überstromschutz aus. Anstatt nur so viel Ampere zu ziehen, wie gebraucht werden, geht der Kärcher auf mind. 1,2A hoch und löst dann den Fehler aus. Das originale Netzteil hatte einen Ladestrom von 600mA, während das USB-C Modul bis zu 3A liefern kann. Ich habe sogar gerade ein altes Netzteil mit 5V 850mA gefunden und es funktioniert auch alles wie gewünscht, aber so richtig habe ich damit nichts gekonnt, weil ich so immer vom Ladestrom des Netzteils abhängig bin. Was bringt mir der USB-C Anschluss, wenn ich weiterhin nur ein bestimmtes Netzteil benutzen kann, das ich eventuell auch noch verlieren kann? 😅


    Um eine allgemein gültige Lösung zu finden, wollte ich es nun mit Widerständen versuchen. Wenn ich das Labornetzteil auf 600mA limitiere, liegt die Spannung bei 4,5V während der Kärcher lädt. Am USB-Modul liegen 5V an. Ich habe keinen Background in Elektrotechnik, aber in der Theorie bräuchte ich einen Widerstand mit (5V - 4,5V) / 0,6A = 0,83 Ohm?

    Kelvin

  • Kelvin

    Changed the title of the thread from “Haushaltsgerät auf USB-C umrüsten (Problem bei guter Verbindung)” to “Haushaltsgerät auf USB-C umrüsten (Ladestrom drosseln)”.
  • Verstehe ich das richtig, das O-Netzteil liefert 600mA und alles war wunderbar, aber jetzt "zieht" der Verbraucher den doppelten Ladestrom!???

    Kann es sein, das Du durch das Löten im Sauger etwas zerstört hast, das den Ladestrom so hoch werden läßt? :conf:


    Gruss

  • Verstehe ich das richtig, das O-Netzteil liefert 600mA und alles war wunderbar, aber jetzt "zieht" der Verbraucher den doppelten Ladestrom!???

    Kann es sein, das Du durch das Löten im Sauger etwas zerstört hast, das den Ladestrom so hoch werden läßt? :conf:


    Gruss

    Das war (zum Glück) auch schon vorher der Fall, bevor ich den Lötkolben in die Nähe gelassen habe 😅 Mein Labornetzteil war zu Beginn des ganzen Projektes auf 5,5V 1A eingestellt, weil ich bloß nicht die 5,5V vom O-Netzteil überschreiten wollte und die Geräte ja eigentlich nur so viel Ampere ziehen, wie sie haben wollen. Das Laden hat gut funktioniert, doch als ich dann die 600mA auf dem O-Netzteil gelesen habe und der Sauger gerade die vollen 1A gezogen hat, habe ich dann auf 600mA limitiert. Zu dem Zeitpunkt bin ich auch nie in diese Fehlermeldung (schnelles Blinken) gekommen, weil das Labornetzteil nie höher als 1A eingestellt war und der Kärcher ja erst bei 1,2A den Fehler auslöst.


    Ob ich gleich beim ersten Mal mit dem Labornetzteil etwas gegrillt habe, kann ich nicht sagen. Das O-Netzteil hat einen proprietären Anschluss für Kärcher-Geräte und deshalb können die Geräte auch immer so viel Ampere ziehen, wie vorhanden sind, weil es eben nur dieses eine Netzteil mit 600mA gibt. Da ist der limitierende Faktor das Netzteil und nicht das Gerät selbst. Jetzt gerade kann ich auch über ein anderes Netzteil mit 850mA den Strom limitieren und auch laden, allerdings würde ich es lieber direkt am Gerät begrenzen, damit ich jedes USB-Netzteil benutzen kann.

    Kelvin

  • Das klingt beinahe, als hätten die die Ladeeleektronik nicht im Gerät/Akku verbaut, sondern im zugehörigen Netzteil.

    Würde es nicht genügen, wenn du hinter der Buchse noch einen Laderegler einbaust? Die Dinger haben doch in der Regel auch die Funktion, den Ladestrom zu begrenzen.

    Oh, man kann hier unliebsame Nutzer blockieren. Wie praktisch!

  • Würde es nicht genügen, wenn du hinter der Buchse noch einen Laderegler einbaust?

    Ja stimmt, ich habe sogar schon solche Stepdown-Wandler hier liegen. Aus Platzgründen müsste ich den zwischen USB-C-Modul und Buchse setzen und dann auf 4,5V begrenzen. Das macht die Sache leider ziemlich klobig und deshalb wollte ich es erstmal mit Widerständen probieren.

    Kelvin

  • Stepdown-Wandler meinte ich nicht, sondern Laderegler. Mit meinen bescheidenen Kenntnissen über Akkus verstehe ich das eher so, dass man nicht die Spannung, sondern den Strom einstellt, beim Laden. Nur Indirekt steuert man damit die Spannung. Ein leerer Akku lädt wohl bei gleicher Spannung schneller (mit mehr Strom), als ein fast voller. Damit es nicht zu heftig wird, begrenzt man den Strom - mit anderen Worten, der Regler fährt die Spannung so weit runter, dass der gewünschte Maximalstrom nicht überschritten wird. Füllt sich der Akku, kann auch die Spannung langsam erhöht werden. Bis er voll ist, dann muss die Spannung so weit reduziert werden, dass kein weiteres Laden mehr stattfindet, bzw. nur noch eine Erhaltungsladung.

    Dafür gibts doch diese kleinen Ladereglerplatinen (die auch in Akkus verbaut sind).

    Oh, man kann hier unliebsame Nutzer blockieren. Wie praktisch!