GPIO funktionieren irgenwie nicht, hm?

  • Hallo liebe Experten oder angehende Experten,


    ich habe mir vor kurzem ein Raspberry PI Rev 2.0 gekauft mit Neugierde auf die GPIO´s als erstes Projekt möchte ich einfach nur eine Glühlampe (3,5 Volt was anderes wie Diode + Widerstand habe ich auf die Schnelle nicht bekommen, man ist ja neugierig ^^) zum leuchten bringen sie ist wie folgt angeschlossen (ich gehe davon aus das es der GPIO17 ist) am PIN 9+11. Die Glühbirne (Birnen hängen am Baum hat meine Physik Leherin immer gesagt, sorry ;)) funktioniert ich habe sie an PIN 1+9 angeschlossen gehabt. Nun habe ich ein kleines Programm geschrieben macht keinen Sinn aber es soll ja nur Strom fließen.



    import RPi.GPIO as GPIO
    GPIO.setmode(GPIO.BCM)


    GPIO.setup(17, GPIO.OUT)


    GPIO.output(17, True)


    nun führe ich über die Shell das Script aus (schlagt mich nicht ich hoffe es ist ein Script :angel:)


    sudo python 17.py #ich bin hier schon im Verzeichniss! eingeloggt bin ich al pi


    aber die Birne leutet einfach nicht habe schon viele tut's angeschaut bei allen funktionierts nur bei mir nicht ?!


    Über Hilfe würde ich mich sehr freuen.


    Grüße Aroxus
    Ps. Das Script läuft ich habe auch ein mal einen Text in die Console schreiben lassen!

    Einmal editiert, zuletzt von Aroxus ()

  • wenn das eine Glühlampe ist wird der Strom aus dem PI nicht reichen, die brauchen doch mindesten 0,2A

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr

  • Also beschädigt wird vermutlich nichts sein, denke ich.
    Der Strom durch die GPIOs wird ja hardwareseitig begrenzt.
    Aber bei 16mA wird man bei einer "Glühlampe" nichts glühen sehen. Allerdings gehe ich davon aus, dass der TO eine LED meint. Wozu hat er sonst den Widerstand erwähnt?... Wobei es kann auch sein, dass ich den Satz aufgrund fehlender Satzzeichen nicht ganz nachvollziehen kann ;-)
    Falls es sich tatsächlich um die Lampe handelt, wird das Problem am fehlenden Strom liegen.

  • wir raten uns hier einen Wolf, ist das sinnvoll ?


    ich bin der Meinung das nicht nur Antworten genau und detailiert in den Forumsregeln gefordert werden, die Fragen müssten in den Forenregeln genauso gefordert werden.....

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr


  • bitte :thumbs1:


    bist du etwa anderer Meinung ? :mad_GREEN:


    wie soll man helfen wenn man das Problem nicht kennt ?


    LED oder Glühlampe ? das ist hier die Frage ......:D

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr


  • wenn das eine Glühlampe ist wird der Strom aus dem PI nicht reichen, die brauchen doch mindesten 0,2A


    Hallo jar,


    genau das war das Problem, ich habe nun eine Leuchtdiode besorgt und kann nun experimentieren.


    Grüße Aroxus
    [hr]


    Und mit ziemlicher Sicherheit wird nun der entsprechende GPIO defekt sein.


    MfG Turbotoni


    Hallo Turbotoni,


    es ist so wie jar es geschrieben hat. Auch dir Danke für deine Information.


    Grüße Aroxus
    [hr]


    Also beschädigt wird vermutlich nichts sein, denke ich.
    Der Strom durch die GPIOs wird ja hardwareseitig begrenzt.
    Aber bei 16mA wird man bei einer "Glühlampe" nichts glühen sehen. Allerdings gehe ich davon aus, dass der TO eine LED meint. Wozu hat er sonst den Widerstand erwähnt?... Wobei es kann auch sein, dass ich den Satz aufgrund fehlender Satzzeichen nicht ganz nachvollziehen kann ;-)
    Falls es sich tatsächlich um die Lampe handelt, wird das Problem am fehlenden Strom liegen.


    Hallo Chritoph1985,


    auch du hast recht mit deiner Antwort ich dachte überall kommt die gleiche Spannung raus wie bei PIN 1


    Grüße Aroxus

    Einmal editiert, zuletzt von Aroxus ()