Bilder komplett schwarz, Kamera defekt?

  • Hallo zusammen,


    befasse mich z.Zt. mit der Timelapse Funktion auf folgender Basis:

    RPi 3aplus, schon über ein Jahr einwandfrei mit anderem Programm 24/7 gelaufen.

    OS (ohne Desktop) seit heute neu PiOS lite bullseye 2022 04 04,

    Kamera original RPi 5M (rev 1.3) von AZ-Delivery von Mai 2022.

    SD-Karte schon getauscht, USB Stick auch getauscht.


    Sollte beim Start automatisch aufzeichnen mit:



    in der rc.local ist eingefügt:


    Bash
    #!/bin/bash
        sleep 60
        /usr/bin/python3 /home/pi/bildermachen.py &


    USB-Stick in der fstab angelegt und nach media/usbmedia gemountet (beim Hochfahren).

    5V Stabil aus einem Meanwell - Netzteil.

    Kamera funktionierte am Anfang einwandfrei.

    Statische Aufladungen können es nicht sein, die Gefahr kenn ich und behandle Platinen entsprechend vorsichtig.

    Es funktioniert 1A super mit den Einstellungen und dem Script, bekomme die Bilder auf den Stick geliefert - nur leider sind alle schwarz.


    Jetzt bin ich ratlos. Kann die Kamera durch die mehrstündigen Tests hin sein?

    Habt ihr so etwas schon mal gehabt? Dann würde ich die Kamera reklamieren.


    Danke für jeden Tipp.

  • müsste denn nicht eines der folgenden Bilder hell erscheinen?

    Bei den Tests war das erste Bild immer flau, das zweite war dann gut.


    ich füge mal ein sleep(2) vor der Schleife ein....



    ... 10min später: leider keine Verbesserung...

    Edited once, last by rpi-joe ().

  • hab's versucht


    Code
    pi@rpi3aplus:~ $ raspistill -tl 1000 -t 10000 -o bild_%04d.jpg
    mmal: Skipping frame 7 to restart at frame 12
    pi@rpi3aplus:~ $ 


    sollte ca 10 Bilder machen 7 sind mit Inhalt, danach kam nur das 12te und das ist wieder schwarz. :(


    Hatte auch mal ins Home-Verzeichis schreiben lassen, waren auch schwarz.

  • als Pi gestartet auch schwarze Bilder


    und mit sudo:


    pi@rpi3aplus:~ $ sudo python3 bildermachen.py

    Traceback (most recent call last):

    File "/home/pi/bildermachen.py", line 1, in <module>

    from picamera import PiCamera

    ModuleNotFoundError: No module named 'picamera'



    hmmm - weil ich das Modul als pi installiert habe ??


    installiere es gerade nochmal mit sudo.....

  • und mit sudo

    Dann wundert es mich, dass es in der der rc.local eingetragen Bild-Dateien erzeugt, denn die läuft als root.


    weil ich das Modul als pi installiert habe ??

    Ja genau.



    //Edit


    Sieht trotzdem nicht gut aus für die Cam. :no_sad:


    Sieh Dir mal libcamara an https://www.raspberrypi.com/do…camera-and-libcamera-apps an! Vielleicht hakt es auch nur an der alten Software.

  • Habe nochmal "Bullseye-lite" neu aufgespielt, nur die notwendigsten Einstelluungen/Änderungen gemacht. Bild bleibt schwarz.

    Eine Info hatte ich unterschlagen, hab kein Display und keine Tastatur dran, gehe über Terminal und Filezilla auf den Rpi.


    Test mit libcamera-jpeg gemacht, eine Datei wird geliefert, schwarzes Bild.


    Anschließend hab ich noch den Test mit Ausgabe eines RAW-Bildes gemacht um den Bildprozessor als Fehlerquelle auszuschließen. In Gimp mit Rawtherapee angesehen - viele vertikale dunkelblaue Striche, mehr nicht.


    Für mein Verständnis ist der Sensor defekt, oder?

  • Das Upgrade auf Bullseye hat auch eine MAJOR Release Änderung der Grafik Engine und dadurch eine Komplettänderung der Camera Software bedingt. Dadurch wurden die proprietären picamera-Module durch Open Souce libcamera ersetzt, was aber noch nicht vollständig funktioniert.


    Damit die CSI Kamera in gewohnter Weise verwendet und (mit picamera-Py Modul) programmiert werden kann, hat die Foundation ein eigenes Image erstellt, das als Rasbperry Pi OS - Legacy zum Download angeboten wird. Das ist zwar nur eine aktuelle Buster Version, erlaubt aber die picamera (und deren Anleitungen) uneingeschränkt weiterzuverwenden.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Damit die CSI Kamera in gewohnter Weise verwendet und (mit picamera-Py Modul) programmiert werden kann, hat die Foundation ein eigenes Image erstellt, das als Rasbperry Pi OS - Legacy zum Download angeboten wird. Das ist zwar nur eine aktuelle Buster Version, erlaubt aber die picamera (und deren Anleitungen) uneingeschränkt weiterzuverwenden.

    Es sollte ausreichend sein, in bullseye mit raspi-config den alten camera support einzuschalten, in der Dokumentation wird python-Support ausdrücklich erwähnt. Das alte Image braucht man dafür nicht, wenn ich das nicht völlig flachs verstanden habe.

    :rolleyes: sudo !!

  • Ich hatte das Problem mit allen Daten und Softwareständen dem Lieferanten gemeldet. Er hat ohne große Nachfrage einen Ersatz auf den Weg gebracht.

    Wenn die Kamera klappt funktioniert, war die alte defekt.

  • Ich hatte das Problem mit allen Daten und Softwareständen dem Lieferanten gemeldet. Er hat ohne große Nachfrage einen Ersatz auf den Weg gebracht.

    Wenn die Kamera klappt funktioniert, war die alte defekt.

    Die neue Kamera hab ich an den Raspberry gesteckt und läuft, einfach so :D

    Erstmal mit Raspistill um ein Bild zu haben. Jetzt fehlten mir noch Python-Bibliotheken, um auch mein skript zu starten. Aber da picamera ja veraltet sein soll, gehe ich den vorgeschlagenen neuen Weg mit libcamera.

    Wird schon klappen.

  • Hmmm, jemand hat geschrieben, dass es noch keine Python-Bibliothek für libcamera gibt. Mit subprocess muss es sein.

    Da muß ich mich erstmal einlesen, hab ich noch gar nicht gemacht.