Empfehlung/Erfahrungen mit Relais

  • Moinsen hyle, helloBavari, @ALL,

    Jetzt bin ich total neben der Rolle. Kannst du mir erklären, wie die zu schaltende Last eine Rückkopplungswirkungen auf die Stromversorgung des PI s haben soll ?

    1. ...ohne dass eine Last angeschlossen ist: Relais schaltet, keine Probleme treten auf

    2. ...mit kleiner Last: Relais schaltet, es treten selten Probleme auf

    3. ...mit größerer Last: Relais schaltet, es treten häufig Probleme auf

    Also müßte es nach deiner Annahme eine unmittelbaren Zusammenhang zwischen "geschalteter Last" und der Fehlerwahrscheinlichkeit bestehen, die mit einem Zusammenbruch der Versorgungsspannung des Pi einhergeht :conf:

    Mit deiner Annahme, daß das Relais direkt über Vc(Relais) welches von den 5V des PIs gespeist wird, und du die Funktionsstörung bei dort in Zusammenhang mit einem Zusammenbruch der Vc des PIs suchst, hätte ich wohl eher eine Fehlermeldung aus der Richtung erwartet, daß der TO so etwas schreibt wie: "Das zu steuernde PI macht abhängig von der zu schaltenden Last immer mal wieder einen Neustart." !? :gk1:

    Ich würde meinen Arsch fast darauf verwetten, daß in der Vorgeschichte der TO durch wiederholtes und häufiges Schalten induktiver Lasten die Schaltkontaktflächen schon dermaßen ruiniert hat. In der Folge nun aus Herstellungsqualität des Relais, Betriebszeit, sowie der der Anzahl der schon stattgefundenen Schaltvorgänge das Lebenszeitende des Relais unmittelbar bevor steht. Dazu kann ich mich noch an meine Ausbildungszeit erinnern. Da sagte mir mal der Meister in der E-Werkstatt so etwas wie: "Beim Schalten reiner induktiven Lasten sollte die Auslegung der Schaltkontakte auf mindestens dem dreifachen des normalen Nennstroms ausgelegt sein." :daumendreh2:
    Selbst wenn er damit ein 80 Watt Schaltnetzteil, wie für einen Laptop oder ähnliches, geschaltet hat wäre das eine nachvollziehbare Erklärung.
    Aber nun Gut, es bringt uns hier alle nicht weiter, solange der TO seine Angaben nicht präzisiert. :elektro:

    In diesem Sinn ein schönes WE, und weniger Hitze wie die letzten Tage

    Franky

  • Als Schiedsrichter muss ich nicht in ein Spiel eingreifen oder den Ball beeinflussen, aber ich kann und darf das, wenn ich das als nötig empfinde. Das kann Dir gefallen oder auch nicht.


    Btw. Nun gut, Sarkasmus versteht nicht jeder. Das akzeptiere ich.

    Sorry, aber das kann ich so nicht stehen lassen. Kein einziger der vorhergegangenen Posts war off topic, der Tonfall gemäßigt und es wurde auch niemand persönlich angegangen. Wieso meinst du dann als "Schiedsrichter" eingreifen zu müssen? Und auch noch mit einem solchen Post, der eher geeignet ist anzustacheln und den Thread ins OT zu drücken? Wieso machst du das?

  • Danke erstmal für eure Antworten, Tipps und Hinweise.

    Es ist so, dass das Relais mit 5V vom Pi versorgt wird und mit den 3,3V geschalten wird.

    Die Last, die am Relais hängt ist eine LED-Lampe.


    Mein Verdacht ist mittlerweile, dass der Funke beim Schalten die Probleme verursacht, da LEDs ja einen sehr hohen Einschaltstrom haben....

  • Guten Tag,

    Ich weiß zwar nicht was du für LEDs verwendest, aber LEDs haben keinen höheren Einschaltstrom. Der Anlauf- oder Einschaltstrom ist dem Betriebsstrom fast gleich.
    Da gibt es keinen zeitlichen Unterscheid wie lange oder wie extrem kurz schon die LED leuchtet.
    Wer hat dir solchen Unsinn erzählt ?

    Und was soll das für eine LED Lampe sein, die ein 1A Relais überfordern sollte ? 1 Ampere bedeutet, dass man ungefähr von einer Lastleistung von 220 Watt rechnen müsste !

    Sorry, was soll das für eine Monsterscheinwerfer sein ?

    Es ist rein vom Funktionsprinzip her ist es Unlogisch, dass ein Relais ein lastabhängiges Verhalten zeigt: außer :!:
    - Die internen Schaltkontakte sind breit, kaputt, durch Schaltfunken verbrannt, oder durch sonstige Einflüsse verschließen,
    - Die Spule selber hat durch eine zu hohe Betriebsspannung einen Leitungsschluss,
    - Die Spule erwärmt sich aus allen möglichen Gründen übermäßig, was auch zum kurzzeitigen Zusammenbruch des Magnetfeldes und damit der Haltekraft führen kann, was sich in einem Kontaktflattern äußern kann.
    - sonstige mechanische Schäden im inneren durch Schlag, Absturz usw. bis hin zu der Tatsache, dass auch der Eisenkern der Spule unter Spannung stehen kann, und somit ein indirektes Überschlagen vom Sekundärstromkreis auf den Primärstromkreis möglich ist.

    Bevor du hier weiter hypothetisierst , tausche das Relais einfach mal es, bevor als mittelbare Folge noch andere Komponenten einen Schaden nehmen. Denn dieses Relais, bzw diese Platine ist mit keiner galvanischen Trennung ausgestattet, was im schlimmsten Fall dein PI, oder was auch immer dieses Teil ansteuert, ins ewige Nirwana des Elektroschrotts geschickt würde.

    es grüßt euer
    Willy

  • Wer hat dir solchen Unsinn erzählt ?

    Ich habe das in der Schule gelernt. Wenn man "Einschaltstrom LED" googelt dann kann man das auch nachlesen.


    Ein Einschaltstrombegrenzer (Heißleiter) brachte mir nun Abhilfe. Seit ich so einen mit verbaut habe treten keine Störungen mehr auf

  • Moinsen helloBavaria,


    Jetzt mußt du anfangen zu differenzieren ! Eine LED als Halbleiterbauelement hat keinen erhöhten Einschaltstrom. Das ist eine Tatsache die man jedem Datenblatt für Single LEDs entnehmen kann.
    Du sprichst hier von einem Leuchtmittel mit LEDs. Und hier beginnen die großen Unterschiede die auf die Auslegung der Versorgungsspannungsbereitstellungschaltung sich konzentriert.
    Hierbei gibt es sehr wohl große, nicht zu verachtende Unterscheide. Aber damit ist immer noch nicht gesagt, daß dein LED Leuchtmittel diese Einschaltspitzenbelastung auch aufweist. Das kannst du meiner Ansicht nach auch nicht nachmessen, wenn du nur ein Multimeter zu Hause hast. Wir sprechen hier von Impulsen im unter 1msek Bereich, meist sogar unter 500µsek.
    Das kann man eigentlich vernachlässigen. Wenn man sich bei einem solchen Vorschaltgerät den Graphen anschaut, und diesen auch richtig interpretieren kann, sind das irgendwo knappe 4,2 A für weniger als 400µsek. Das ist eigentlich nichts, da wird nicht einmal ein zu dünner Draht, oder elektrische Leiter warm. Oder damit du mal von deinem Vorbehaltglaube etwas wegkommst, für 0,0004 sek = 400µsek fließt ein gerade mal 6-facher Einschaltstrom, im Vergleich zum Nennstrom. Für flinke Sicherungsautomaten ist diese Kennziffer durchaus relevant, aber nicht für eine Relais ! Mit Ausnahme du betreibst dieses im Stroboskop-Modus.

    Das du dieses Relais für ein Stroboskop verwenden willst ist jedoch nirgendwo zu lesen ! Entschuldige Bitte, aber Fakten sind und bleiben Fakten, und man muß diese Diagramme auch lesen können. Nicht nur einen Aufschrei wagen, weil man mal was von einen Peak-Strom gelesen hat. Hier spielt immer der Faktor Zeit die entscheidende Rolle mit.

    Selbst wenn dein LED Scheinwerfer einen Peak-Einschaltstrom von über einem 1 A verursachen würde, oder sagen wir mal dieses eine Ampere erreichen würde, läge der danach permanent fließende Betriebsstrom bei unter 1/5-tel. Oder anders ausgedrückt die Netto-Leistung der LEDs in diesem Leuchtmittel würden in der Summe fast 44 Watt benötigen - Was du aber als solche auch noch nicht bestätigt hättest.
    Also einfach die abschließende Bitte, lege alle Fakten zu deiner Schaltung offen, wir können alle nicht sehen, auch nicht erahnen was du dort so machst. :gk1:

    PS: Es gibt auch LED Vorschaltgeräte mit ESP ( Einschaltimpulsunterdrückung ) wo der Delta-Peak bei nur 1,5 bis 1,7 des Nennstroms liegt.

    Franky

  • Ein nur mal so auf die Schnelle ergoogeltes Datenblatt eines LED-Leuchtmittels E27 / 20 Watt.


    Den Nennstrom kann man sich leicht näherungsweise ausrechnen. 20 Watt / 230 V = 87 mA.

    Einschaltstrom laut Datenblatt: 45 A. Das ist also mehr als das 500-fache des Nennstromes.


    Wenn das Relais schaltet und dabei (wenn auch sehr kurz) ein Strom von 45 A fließt, dann "funkt es ganz gewaltig". Da die Stromspitzen sehr kurz sind, wird es wahrscheinlich nicht zu klebenden Kontakten kommen, es führt aber auf jeden Fall zu Störimpulsen, wenn man keine Maßnahmen ergreift. Das einfache Schalten eines LED-Leuchtmittels mit einem Relais ohne Strombegrenzung kann also erheblich Probleme machen.

    Edited 2 times, last by Gnom ().

  • Moinsen helloBavaria

    Sorry, das war nicht klar ausgedrückt. Es sind LED Leuchtmittel.

    Gnom hat das Problem schön zusammengefasst, danke dafür :)

    Schon erstaunlich wie hier die Kommunikation außerhalb der Öffentlichkeit stattfindet !
    Wenn dieser GNOM etwas weiß, was kein anderer Wissen kann, oder zu erfahren bekommt, dann liegt es ganz offensichtlich an deiner Kommunikationsqualität. Nirgendwo in den bisherigen Veröffentlichungen von dir ist zu lesen, daß es sich um ein sg E27 Leuchtmittel handelt ! Schaut man hingegen bei Standard-LED-Vorschaltgeräten nach, kommt man auf andere Ergebnisse.
    Danke für deine umfassende Problemdarstellung, die sich wirklich erst in den letzten Zügen zu einem Gesamtbild zusammengefunden hat, womit man eine solche Frage auch den realen Umständen entsprechend hätte beantworten können :thumbdown:

  • Tja Gnom hat sich zum anerkannten Elektro Guru gebildet, seine Helligkeit lässt andere da verblassen! (sie schweigen künftig) :stumm:

    Ich habe das in der Schule gelernt.

    In Bayern? Was das bayrische Abitur bringt habe ich kennengelernt, mA * kOHM = MVolt :lol:


    PS.

    LED = Bauteil Leuchtdiode.

    Leuchtmittel LED "Birne" = Schaltung mit vielen Bauteilen != LED


    Da wir hier mittlerweile 230V~ Nennspannung haben die +-10% schwanken darf ergibt maximal 253V~ sind diese Miniwürfel Relais hier eh nicht zulässig, das ist alles auf USA mit 115V zugeschnitten. Die Leiterbahnenabstände und alle Abstände allgemein sind für hiesige Spannungen unzureichend!

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

    Edited once, last by jar ().

  • Hallo jar,

    In Bayern? Was das bayrische Abitur bringt habe ich kennengelernt, mA * kOHM = MVolt :lol:

    danke für die Steilvorlage. Die Geschichte kennst Du von mir schon. War auch in Bayern.


    Ich habe da 2016 eine Anlage im Reinraum qualifiziert. In der Betriebsanleitung stehen die elektrischen Daten, u.a. "50 MA" für die Stromstärke.

    Mit den einschlägigen Formeln habe ich den Mindestdurchmesser der Kupferlitze ausgerechnet. War irgendwas mit 5 m - ausgeschrieben 5 Meter. Nicht, dass jemand auf die Idee kommen kann von wegen 5 milli irgendwas.


    Na ja, der Schaltschrank mit seinen dürren Käbelchen ist da schon mal ausgeschieden. Dann habe ich den Reinraum verlassen und habe die umliegenden Räumlichkeiten nach der 5-Meter dicken Leitung abgesucht. Auf der gleichen Etage ging kein so'n dickes Kabel in den Raum, aus dem ich kam.


    'Ne Etage tiefer auch nicht - war also nicht in der Erde verlegt. Hätte ich wohl für sinnvoll empfunden.


    Dann gab es nur noch eine letzte Möglichkeit! Eine Etage höher und dann fliegend über die Dächer gelegt.


    Also habe ich das Gebäude verlassen und mal so unauffällig meinen Blick über die Dächer schweifen lassen.


    Da war zwar einiges verlegt und lag auch einiges dumm rum. Aber nichts, das nach rund 5 Meter dickem Kupferkabel aussah.


    Dann ging ich wieder in den Reinraum und habe den Verzapfer dieser Fehlinformation angerufen und erzählt, was ich alles unternommen habe, um die paar Strippen der Spannungsversorgung zu finden und dass ich den Eindruck gewonnen habe, dass man damals bei der Installation die 50 Mega-Ampere-Strippen vergessen haben muss. Er meinte sehr kleinlaut - man hat ihn fast nicht mehr vernommen - dass das grosse "M" ein kleines "m" hätte werden sollen. Nicht Mega-Ampere sondern milli-Ampere. MILLI!


    Er nannte dann den Anschluss im Schaltschrank und schon wurde es mir sehr schlüssig. Die dort verlegten Strippen sahen aus wie aus dem 7,68€-Arduino-Bastelset 2016. Die gleiche Farbvielfalt, die gleichen Längen. Alles passte zusammen, der Schaltplan auf Papier und die Schalte im Schaltschrank stimmten überraschend gut überein. Sogar Zahlenangaben waren nachvollziehbar hier und dort identisch.



    Beste Grüsse


    Andreas



    helloBavaria,


    mach den Thread lieber ganz schnell zu, bevor irgend ein Moderator diesen wegen groben Unfugs löscht.

    Ich find das schon derbe, was hier abgegangen ist. Alle Rückmeldungen sind aus der Sicht LED = Light Emitting Diode absolut korrekt. Hättest Du Deine Funzel korrekt bezeichnet, hätte man Dir bereits im 2. Beitrag zur finalen Lösung verhelfen können.

    Alle Aussagen, so irreführend sie auch sein mögen, ergeben erst mit der Auflösung Sinn. Aber bis dahin wird diesen Thread kaum jemand aufgrund der sonderbaren Informationsrückhaltung lesen wollen.

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

    Edited 2 times, last by Andreas ().

  • Guten Morgen helloBavaria,

    Danke erstmal für eure Antworten, Tipps und Hinweise.

    Es ist so, dass das Relais mit 5V vom Pi versorgt wird und mit den 3,3V geschalten wird.

    Die Last, die am Relais hängt ist eine LED-Lampe.


    Mein Verdacht ist mittlerweile, dass der Funke beim Schalten die Probleme verursacht, da LEDs ja einen sehr hohen Einschaltstrom haben....

    Hier kann man sich nur Andreas anschließen. Scheinbar ist es so, dass in Bayern auch Google anders funktioniert !
    Eine LED, wie Andreas schon sagte, ist ein Halbleiterbauelement, und eine Latuchtel ( Leuchtmittel ) welches mehrere LEDs als Lichtquelle verwendet wird als LED-Leuchtmittel bezeichnet.
    Soweit sollte das auch schon bis nach Bayern durchgedrungen sein ?
    Für dieses Zusammenspiel eines allen unbekannten E27 Leuchtmittels mit einer Kücken-Relais Platine kann man nur als Pfusch bezeichnen. Egal was dir das GNOM vorgeschlagen hat. Es war, ist und bleibt Pfusch :!: Und bringt jeden mit etwas Verantwortungsbewusstsein und elementaren Grundkenntnissen um den elektrischen Strom, hier nun sogar 220/230 Volt ~ zum kotzen.

    es grüßt euer
    Willy