Synology Mount über fstab-Eintrag funktioniert nicht beim Booten

  • Hallo,

    das Backup auf meiner Synology (RS819) habe ich erfolgreich hinbekommen, insofern bin ich sicher, dass die Einstellungen im Prinzip auch korrekt sind. Allerdings klappt das nur im manuellen Modus, d. h. noch ohne Eintrag in crontab, weil nach dem Start des Raspi der Inhalt des Backup-Verzeichnisses nicht zu sehen bzw. darauf zuzugreifen ist.

    Eintrag in fstab

    Code
    192.168.XXX.XX:/volume1/Pi/ /backup nfs rw,nfsvers=3 0 0

    Wenn ich dann

    Code
    sudo mount -a

    ausführe, kann ich auf das Backup-Verzeichnis auch zugreifen. raspiBackup macht dann auch brav eine Kopie (so wie in der Anleitung beschrieben) auf das Synology-Verzeichnis.

    Sowiet ist ja alles in Ordnung, aber leider - fürchte ich - braucht es dazu immer den beschriebenen manuellen Eingriff, so dass ein automatisches Sichern nicht klappt. Trotz längeren Forschens hier und im I-Net konnte ich keine Lösung finden, außer der, ein Script zu erstellen, dass nach dem Starten des Raspi den Mount-Vorgang zu Ende bringt. Aber aus den Beschreibungen von raspiBackup habe ich den Eindruck gewonnen, dass das nicht unbedingt nötig ist. Aber da ich mit Linux noch nicht so firm bin, bin ich jetzt leider mit meinem Latein am Ende und hoffe auf weitere sachdienliche Hinweise.


    Beste Grüße
    Jürgen


    Synology DSM 7.1-42661 Update 3

    Raspi 3B+ mit Raspbian GBU/Linux 11 (bullseye)

    PC mit openSUSE Leap 15.3

    Beste Grüße
    Jürgen

  • Ich habe denselben Synostand und Raspi4 sowie Raspi3B (ohne plus) die mit raspiBackup auf meine Syno sichern. In der /etc/fstab habe ich kein nfsvers=3 - dafuer aber auf der Syno nfs3 als maximales nfs Protokoll definiert.


    Frueher hatte ich den Backupspace statisch beim Booten erfolgreich gemounted. Jetzt nutze ich die DYNAMIC_MOUNT Option so dass nur fuer den Backup der Space gemounted wird. ich vermute aus irgendeinem Grunde ist zum Mountzeitpunkt Dein Netzwerk noch nicht verfuegbar und der Bootmount failed. Du kannst ja mal in /var/log/syslog nachsehen ob Du eine Fehlermeldung findest.


    Als Workaround kannst Du die DYNAMIC_MOUNT Option nutzen. Da raspiBackup sicherlich nicht gleich nach dem Boot gestartet wird sollte das Netzwerk oben sein wenn raspiBackup per cron gestartet wird und der dynamic Mount erfolgreich sein.

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect."

    Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert :fies: Bei mir tut das raspiBackup automatisch :shy:

  • Alternativ über eine Systemd mount-unit mit Abhängigkeit vom Netzwerk mounten (After=network-online.target).

    Manche werden im Alter weise, manche nur alt.

  • Hallo,


    Danke erst einmal für eure Antworten.

    framp: ich nutze die gleichen Einstellungen auf der Synology. Aber wo stelle ich die Option DYNAMIC_MOUNT ein?

    llutz: Dieser Weg überfordert zurzeit meine Linux-Kenntnisse, da muss ich mich erst noch einarbeiten.

    RTFM: Ich habe die Option im Manual gefunden (nach längerem Suchen ;) ), wird die ans Ende der Zeile gehängt? Z. B.

    Code
    192.168.XXX.XX:/volume1/Pi/ /backup nfs rw,nfsvers=3 0 0 _netdev

    oder

    Code
    192.168.XXX.XX:/volume1/Pi/ /backup nfs rw,nfsvers=3 0 0,_netdev

    Die Option "aufs Netzwerk warten" in raspi-config habe ich aktiviert, hat nur zunächst keinen Erfolg gebracht. Nach dem ersten reboot war das Verzeichnis auf der Synology noch nicht eingebunden, nach einem weiteren reboot war es das aber. Das verstehe ich jetzt nicht, aber damit kann ich leben. ;)


    Als Plan B ist mir noch eingefallen, einen Zweizeiler in der Form

    Code
    # !/bin/bash
    sudo mount -a
    raspiBackup

    zu schreiben und den dann von cron ausführen zu lassen.


    Beste Grüße
    Jürgen

    Beste Grüße
    Jürgen

  • ...wo wird die neue Option wohl hinkommen?

    Die Frage bezog sich auf eine eventuell vorgegebene Reihenfolge, da hatte ich in der Dokumentation nichts gefunden. Ich nehme dann meine letzte Version (mit Komma getrennt am Ende der Zeile)

    Beste Grüße
    Jürgen

  • Die Frage bezog sich auf eine eventuell vorgegebene Reihenfolge, da hatte ich in der Dokumentation nichts gefunden.

    Dann hast Du aber nach < man fstab > gar nicht gesucht, auch nicht mit < apropos fstab >


    Servus!

    RTFM = Read The Factory Manual, oder so