Zero 2 W verliert Wlan

  • Hi,


    Mein Raspi2 Zero verliert ab und an das Netz. Ich hatte es mit mehreren Dingen probiert, wenn das passiert.

    Aktuell boote ich den Raspi durch.

    Ich hab jetzt mal folgende Abfragen im Fehlerfall gemacht:

    in dev: gibt kein Gerät mehr an

    iwconfig: kein wlan0 mehr vorhanden

    Ifconfig: kein wlan0

    Kann sich da jemand einen Reim drauf machen?

    Sieht irgendwie so aus, als wenn das Device nicht mehr da ist?

  • Sieht irgendwie so aus, als wenn das Device nicht mehr da ist?

    Vergleiche mal auch die Ausgaben von:

    Code
    rfkill list
    lsmod
    arp -a

    wenn die Wlan-Verbindung funktioniert und wenn das Device nicht mehr da ist. Poste hier nur evtl. vorhandene _Unterschiede_ in den Ausgaben und nicht die vollständigen Ausgaben.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Hier mal die Ausgaben die ich bis jetzt habe (heute morgen am PC etwas einfacher):

    Ich baue deine Befehle mal mit ein.

  • Ich baue deine Befehle mal mit ein.

    BTW: Diese Befehle sind nicht geeignet, dort eingebaut zu werden. ... und es geht ja auch um die Unterschiede in der Ausgabe ...

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Ich komme aber ja nicht mehr an das Gerät dran, weil es Headless ist.

    D.h. entweder ich kann den Zustand in dem Moment per Script "festhalten" ansonsten ist es schwierig.

    Edit:

    Vorhin ist es wieder passiert. Habe mal die Ausgabe angehängt.

    Man sieht gut: rfkill list zeigt das wlan Gerät nicht mehr an

    arp hat nur noch die internen Netze von Docker

    lsmod hab ich mal verglichen und finde keine Unterschiede.


    Edited 3 times, last by Mr-Fly ().

  • Vorhin ist es wieder passiert. Habe mal die Ausgabe angehängt.

    Man sieht gut: rfkill list zeigt das wlan Gerät nicht mehr an

    arp hat nur noch die internen Netze von Docker

    Welchen WLAN-Router benutzt Du?

    Konfiguriere mal (als Test und temporär für z. B. ca. 1 Woche) in deinem PI einen cronjob (in der systemweiten crontab), der alle 2 Minuten einen arping (mit arping aus dem package iputils-arping) auf die IP-Adresse vom WLAN-Router macht und beobachte, ob die WLAN-Verbindung auf dann noch unterbrochen wird.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Router ist ein 6690 und ein 1750E Mesh repeater. Der Raspi wechselt auch ab und an zwischen diesen.

    Mich macht nur stutzig, dass das wlan0 halt nirgends mehr auftaucht, als wenn der treiber oder was auch immer sich beendet hat

  • Router ist ein 6690 und ein 1750E Mesh repeater. Der Raspi wechselt auch ab und an zwischen diesen.

    Konfiguriere deinen PI so, dass dieser nicht wechselt bzw. den Repeater immer ignoriert und die WLAN-Verbindung nur zwischen der FB6690 und dem PI zustande kommt bzw. besteht.


    EDIT:


    Zum testen auch kein band steering (d. h. 5GHz-Wlan deaktivieren) und kein Autokanal benutzen. Am besten nur Kanal 13 im 2.4GHz-Wlan.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited once, last by rpi444 ().

  • Ok, habe dann die WPA_Su... geändert auf:

    Code
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev 
    update_config=1 
    country=DE 
    
    network={ 
            ssid="myhyperspeedwlan" 
            bssid=aa:bb:cc:dd:ee:ff 
           psk=sdfgjsdfgjkldfklgjsdfklgksdfg
    } 

    Ich hatte das schon mal so und es war dann so, dass der Raspi ab und an nicht mehr auf den Router connected hat.

    Wie gesagt habe ich immer noch die Vermutung, dass das Gerät (wlan0) da in dem Moment nicht sauber tickt.....

    Es läuft wie gesagt Docker auf dem Teil (PiHole) und Homebridge nativ (wegen Bluetooth)

  • Wie gesagt habe ich immer noch die Vermutung, dass das Gerät (wlan0) da in dem Moment nicht sauber tickt.....

    Benutzt Du nur 2.4GHz-Wlan oder auch 5.0GHz?

    ... Homebridge nativ (wegen Bluetooth)

    BTW: Es kann auch an der Koexistenz von wifi und bluetooth liegen. Zum temporären testen, könntest Du ja bluetooth (schon in der config.txt bzw. durch blacklisten) deaktivieren.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Ich nutze beides daheim, weil das 2,4 GHZ ziemlich ausgelastet ist (durch die Nachbarn).

    Die meisten Geräte nehmen 5 GHZ.

    Ein Raspi4 läuft ürbigens problemlos online seit x-Wochen.

    Auch ein RaspiZero W (ohne 2) hat vorher immer das netz sauber gehalten.

    Es ist erst der RaspiZero2 W welcher diese Probleme bereitet.

  • Ich nutze beides daheim, weil das 2,4 GHZ ziemlich ausgelastet ist (durch die Nachbarn).

    Ja, aber zum testen eignet sich 2.4GHz-Wlan (only) besser. BTW: Eine Überlastung/Störung durch WLANs aus der Nachbarschaft gibt es nicht (... und deshalb sollst Du ja auch zum testen, den festen Kanal 13 benutzen).


    EDIT:


    Die FritzBoxen und andere WLAN-Router auch, "lernen Rücksicht und nehmen Rücksicht", wenn es um WLAN-Koexistenz geht.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited 2 times, last by rpi444 ().

  • Das mit der Last stimmt ja nicht ganz. Die Bandbreite ist leider sehr begrenzt durch ca. 20 andere Netze in der Umgebung. Für den Raspi für die reine connection ist das nicht wichtig, für den Rest schon, denn die 1 GB/Sec (von denen natürlich nicht alles bei den Endgeräten ankommt) wollen auch genutzt werden. Zumindest das iPad bekommt auf 5 GHz locker 850 MBit hin ;)

    ausschalten werde ich die 5 GHz erstmal nicht, denn für den Raspi2 sollte das ja eigentlich gar nichts ausmachen, weil er ja nicht mal 5 GHz hat ?

    Wie gesagt läuft der 4er durchgängig mit 5 GHz und ein RaspiZeroW hat mit der selben Situation auch NIE sein Netz verloren. Es muss was spezifisches an dem WLAN Adapter der Zero2W sein,