Veraltete Dependencies

  • Hallo,


    ich versuche gerade das PocketVj Projekt umzusetzen. Nun habe ich das Problem das die Dependencies veraltet sind und ich diese Fehlermeldungen bekomme.

    Ich hoffe ihr könnt mir das irgendwie erklären. das ist der dependencies installations pfad:

    Code
    sudo apt-get -y install lxde-core lxterminal lxappearance xinit lightdm ntfs-3g python-pexpect vim figlet git-core firmware-ralink hostapd isc-dhcp-server lighttpd samba samba-common-bin php5-common php5-cgi php5 php5-mysql screen fbi ttf-mscorefonts-installer mediainfo gparted php5-cli iptables xtightvncviewer imagemagick dosfstools exfat-utils exfat-fuse hfsplus hfsprogs hfsutils xdotool expect expect-dev avahi-daemon libavahi-compat-libdnssd-dev feh libjpeg8 libjpeg8-dev libao-dev avahi-utils libavahi-compat-libdnssd-dev libva-dev youtube-dl python-smbus mpg321 mpg123 libreoffice-impress rc-gui python-pip iceweasel python-dev python-dbus xpdf x11-xserver-utils libncurses5-dev shellinabox tk okular usbmount libgstreamer0.10-0 libgstreamer0.10-dev gstreamer0.10-tools gstreamer0.10-plugins-base libgstreamer-plugins-base0.10-dev gstreamer0.10-plugins-good gstreamer0.10-plugins-ugly gstreamer0.10-plugins-bad libgstreamer-plugins-base1.0-dev gstreamer1.0

    kann ich die fehlenden irgendwie herziehen oder klappt das nicht?

  • ich versuche gerade das PocketVj Projekt umzusetzen. Nun habe ich das Problem das die Dependencies veraltet sind und ich diese Fehlermeldungen bekomme.

    Welchen Pi und welches OS (Version) hast Du?

    Poste mal nach:

    Code
    sudo apt autoremove
    sudo dpkg --configure -a
    sudo apt update

    die Ausgabe von:

    Code
    sudo apt-get -f install

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Os version :

    PRETTY_NAME="Raspbian GNU/Linux 11 (bullseye)"

    NAME="Raspbian GNU/Linux"

    VERSION_ID="11"

    VERSION="11 (bullseye)"

    VERSION_CODENAME=bullseye

    ID=raspbian

    ID_LIKE=debian

    HOME_URL="http://www.raspbian.org/"

    SUPPORT_URL="http://www.raspbian.org/RaspbianForums"

    BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"


    Und das ist das Ergebnis von:

    sudo apt-get -f install

    Reading package lists... Done

    Building dependency tree... Done

    Reading state information... Done

    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


    Edit:


    Raspberry 3+ wenn ich mich nicht irre

  • Os version :

    PRETTY_NAME="Raspbian GNU/Linux 11 (bullseye)"

    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    OK. Von wo hast Du die Liste der packages (wie in deinem Beitrag #1) die Du installieren willst?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Von einer Anleitung der Ersteller des Programmes hat die dependencies nicht mehr upgedated. Anleitung :

    External Content gist.github.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    Projekt: https://github.com/magdesign/PocketVJ-CP-v3

  • Von einer Anleitung der Ersteller des Programmes hat die dependencies nicht mehr upgedated.

    Naja, nicht die dependencies. Die packages sind "veraltet" für bullseye. Z. B.:

    Code
    :~ $ apt-cache policy gstreamer0.10-plugins-base
    N: Unable to locate package gstreamer0.10-plugins-base
    N: Couldn't find any package by glob 'gstreamer0.10-plugins-base'
    N: Couldn't find any package by regex 'gstreamer0.10-plugins-base'

    aber:

    Code
    :~ $ apt-cache policy gstreamer1.0-plugins-base
    gstreamer1.0-plugins-base:
      Installed: (none)
      Candidate: 1.18.4-2
      Version table:
         1.18.4-2 500
            500 https://deb.debian.org/debian bullseye/main arm64 Packages

    D. h., keine alte Anleitungen benutzen.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Ist leider die aktuellste Anleitung die verfügbar ist. Also sollte ich auf eine ältere raspbian version umsteigen?

    Nein. Du sollst das PocketVj Projekt nicht umsetzen bzw. ignorieren. Oder den dev/Autor bitten, sein Programm auf den neusten Stand zu bringen.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Würde es gerne umsetzen da es die einzige open source Möglichkeit ist die ich habe.

    Dann solltest Du dir das Wissen aneignen, um es auf den neusten Stand zu bringen und erst wenn das erledigt ist, das Programm installieren.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden