Keine WLAN-Verbindung bei APs mit Unterstrich in SSID

  • Ich habe jetzt schon dreimal meinen Pi 4 mit 4 GB RAM neu aufgesetzt, nur um festzustellen, dass das neueste 64-bit Pi-OS (Bullseye mit Desktop) anscheinend Probleme damit hat, mich mit einem Router zu verbinden, wenn die SSID einen Unterstrich im Namen hat, wie "Router_Nord" oder "Router_Sued". Nur "Router" funktioniert. Bei meinen anderen Pis geht das problemlos, auch mit Bullseye.

    Kann das mal jemand nachstellen ? :danke_ATDE:

  • Keine WLAN-Verbindung bei APs mit Unterstrich in SSID? Schau mal ob du hier fündig wirst!

  • Sogar Unicode ist zulässig. Möglicherweise spinnt die GUI etwas.

    Ich würde prüfen, was in der /etc/wpa_supplicant/wpa_supplicant.conf drinsteht.

    SSID und Key stehen dort auch drin. Der Key wird aus der SSID + Passwort erstellt.

    Wenn also die SSID richtig drinsteht, sollte auch der Key stimmen.

    Prüfen kann man das mit:

    Code
    wpa_passphrase "SSID_NAME" "Passwort"

    Es muss dann derselbe Key ausgegeben werden, wie in der Config.

  • In der wpa_supplicant.conf stehen alle 3 Router richtig drin, aber nur mit dem ohne Unterstrich verbindet er sich.

    Wo finde ich denn den Key, um die Ausgabe von wpa_passphrase zu checken ?

    In der wpa_supplicant.conf steht das Passwort ja im Klartext.

    Wenn ich testweise die anderen Router auf disabled=1 stelle und dann in der GUI mich verbinden will, nimmt er mir den Eintrag disabled=1 wieder aus der wpa_supplicant.conf raus, aber verbindet sich nicht.

  • In der wpa_supplicant.conf steht das Passwort ja im Klartext.

    Wenn ich testweise die anderen Router auf disabled=1 stelle und dann in der GUI mich verbinden will, nimmt er mir den Eintrag disabled=1 wieder aus der wpa_supplicant.conf raus, aber verbindet sich nicht.

    Du kannst den Key manuell generieren, mit wpa_passphrase (aus der SSID und dem Passwort) und danach manuell in die wpa_supplicant.conf eintragen (aber ohne "").

    In den networkblock kannst Du auch die Zeile mit "priority" eintragen oder temporär die zwei networkblocks mit denen er sich gerade nicht verbinden soll, deaktivieren (disabled=1).

    Danach änderst Du in der wpa_supplicant.conf, die Zeile:

    Code
    update_config=1

    in

    Code
    update_config=0

    speichern und danach erneut probieren.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Meine PIs

    PI4B/8GB (border device) OpenBSD 7.4 (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, stunnel-Proxy, Mumble-Server

    PI3B+ FreeBSD 14.0-R-p3 (arm64): SSH-Serv., WireGuard-Serv., ircd-hybrid-Serv., stunnel-Proxy, Mumble-Serv., ddclient

    PI4B/4GB Bullseye-lite (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, stunnel-Proxy, Mumble-Server, botamusique, ample

    PI3B OpenBSD 7.4 (64bit), mit stayauth-Flag 24/7 im Wlan

  • :no_sad:

    Code
    Error enabling network - Failed to save wpa_supplicant configuration.
    You should add update_config=1 to /etc/wpa_supplicant.conf.

    Wie bzw. mit was versuchst Du die wpa_supplicant.conf zu speichern bzw. zu ändern?

    Das dbus-Zeugs oder irgendwelches Frontend-/GUI-Gedöns solltest Du nicht benutzen. Nur den Editor in der Kommandozeile.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Meine PIs

    PI4B/8GB (border device) OpenBSD 7.4 (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, stunnel-Proxy, Mumble-Server

    PI3B+ FreeBSD 14.0-R-p3 (arm64): SSH-Serv., WireGuard-Serv., ircd-hybrid-Serv., stunnel-Proxy, Mumble-Serv., ddclient

    PI4B/4GB Bullseye-lite (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, stunnel-Proxy, Mumble-Server, botamusique, ample

    PI3B OpenBSD 7.4 (64bit), mit stayauth-Flag 24/7 im Wlan

  • Ich benutze nano zum editieren.

    OK, aber diese Meldung:

    Code
    Error enabling network - Failed to save wpa_supplicant configuration.

    kommt doch nicht von nano, oder?

    Welches Frontend, das Du benutzt, verlangt nach:

    Code
    update_config=1

    und akzeptiert:

    Code
    update_config=0

    in der wpa_supplicant.conf, nicht?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Meine PIs

    PI4B/8GB (border device) OpenBSD 7.4 (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, stunnel-Proxy, Mumble-Server

    PI3B+ FreeBSD 14.0-R-p3 (arm64): SSH-Serv., WireGuard-Serv., ircd-hybrid-Serv., stunnel-Proxy, Mumble-Serv., ddclient

    PI4B/4GB Bullseye-lite (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, stunnel-Proxy, Mumble-Server, botamusique, ample

    PI3B OpenBSD 7.4 (64bit), mit stayauth-Flag 24/7 im Wlan

  • Ja, die Meldung kommt dann, wenn nach dem Neustart kein WLAN verbunden wird und ich dann auf dem Desktop versuche, eine WLAN-Verbindung herzustellen. Ich habe jetzt mal mit wpa_supplicant -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf -d > /home/pi/wpa_log.txt mitloggen lassen.

    Ergebnis:

    rfkill sagt:

    Code
    ID TYPE      DEVICE    SOFT      HARD
     0 wlan      phy0   blocked unblocked
     1 bluetooth hci0   blocked unblocked
  • Ich habe jetzt mal mit wpa_supplicant -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf -d > /home/pi/wpa_log.txt mitloggen lassen.

    Ergebnis:

    Code
    rfkill: WLAN soft blocked
    nl80211: Could not yet enable interface 'wlan0' due to rfkill

    rfkill sagt:

    Code
    ID TYPE      DEVICE    SOFT      HARD
     0 wlan      phy0   blocked unblocked
     1 bluetooth hci0   blocked unblocked

    SOFT sollte auch auf unblocked gestellt werden.

    EDIT:

    Code
    sudo rfkill unblock all
    rfkill list

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Meine PIs

    PI4B/8GB (border device) OpenBSD 7.4 (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, stunnel-Proxy, Mumble-Server

    PI3B+ FreeBSD 14.0-R-p3 (arm64): SSH-Serv., WireGuard-Serv., ircd-hybrid-Serv., stunnel-Proxy, Mumble-Serv., ddclient

    PI4B/4GB Bullseye-lite (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, stunnel-Proxy, Mumble-Server, botamusique, ample

    PI3B OpenBSD 7.4 (64bit), mit stayauth-Flag 24/7 im Wlan

  • Ok, nochmal:

    Code
    rfkill list
    0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

    Ausgabe ohne Unterstrich:

    Verbindung wird aufgebaut und auch in der GUI angezeigt.

    Jetzt die Ausgabe mit Unterstrich im nächsten Beitrag:

  • Ausgabe mit Unterstrich in der SSID, keine Verbindung möglich:

  • Ausgabe mit Unterstrich in der SSID, keine Verbindung möglich:

    Lass mal das "-d" weg in der Kommandozeile. Die "normale" Ausgabe reicht erstmal.

    War der Inhalt des Verzeichnisses "/var/run/wpa_supplicant" leer und alle wpa_supplicant-prozesse gekillt, vor der Ausführung in der Kommandozeile?

    Code
    ls -la /var/run/wpa_supplicant
    ps aux | grep -i [w]pa

    ?

    Versuch mal auch mit deaktivierter "p2pon"-Option beim Treiber "brcmfmac" (siehe "modinfo brcmfmac") und mit "p2p_disabled=1" in der wpa_supplicant.conf (außerhalb der network-blocks).

    EDIT:

    In der wpa_supplicant.conf muss:

    Code
    update_config=0

    sein, denn nur Du entscheidest was der wpa_supplicant via config bekommt und sonst niemand.

    Wie unterscheiden sich die APs, mit und ohne Unterstrich, bzgl. Wlan-Konfiguration und WPS?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Meine PIs

    PI4B/8GB (border device) OpenBSD 7.4 (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, stunnel-Proxy, Mumble-Server

    PI3B+ FreeBSD 14.0-R-p3 (arm64): SSH-Serv., WireGuard-Serv., ircd-hybrid-Serv., stunnel-Proxy, Mumble-Serv., ddclient

    PI4B/4GB Bullseye-lite (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, stunnel-Proxy, Mumble-Server, botamusique, ample

    PI3B OpenBSD 7.4 (64bit), mit stayauth-Flag 24/7 im Wlan

    Edited once, last by rpi444 (November 8, 2022 at 10:56 AM).

  • Ja, Prozess beendet, /var/run/wpa... nicht mehr vorhanden.

    Die Router sind normale WLAN-Router, die unterscheiden sich nur durch ihre IP und dem Namen in der SSID, alle anderen Geräte haben ja auch kein Problem sich zu verbinden.

    Ich hätte ja schon längst die SSID auf den Routern umbenannt, wären da nicht die ganzen ESPs, die verbaut sind und ich keine Lust habe alle auszubauen und neu zu flashen, zumal mich der Grund für die Verbindungsverweigerung interessieren würde.

    Mittlerweile geht es auch nicht mehr ohne Unterstrich:

    Code
    Successfully initialized wpa_supplicant
    wlan0: Trying to associate with SSID 'Router'
    wlan0: CTRL-EVENT-ASSOC-REJECT bssid=00:00:00:00:00:00 status_code=16
    wlan0: Trying to associate with SSID 'Router'
    wlan0: CTRL-EVENT-ASSOC-REJECT bssid=00:00:00:00:00:00 status_code=16
    wlan0: Trying to associate with SSID 'Router'
    wlan0: CTRL-EVENT-DISCONNECTED bssid=12:34:56:78:90:12 reason=3 locally_generated=1
    nl80211: deinit ifname=wlan0 disabled_11b_rates=0
    wlan0: CTRL-EVENT-TERMINATING

    Genauso wenig mit Unterstrich:

    Code
    Successfully initialized wpa_supplicant
    wlan0: Trying to associate with SSID 'Router_Mitte'
    wlan0: CTRL-EVENT-ASSOC-REJECT bssid=00:00:00:00:00:00 status_code=16
    wlan0: Trying to associate with SSID 'Router_Mitte'
    wlan0: CTRL-EVENT-ASSOC-REJECT bssid=00:00:00:00:00:00 status_code=16
    nl80211: deinit ifname=wlan0 disabled_11b_rates=0
    wlan0: CTRL-EVENT-TERMINATING

    :wallbash:

    Passend dazu habe ich das gefunden:

    https://forums.raspberrypi.com/viewtopic.php?t=274715

    und das:

    https://forums.raspberrypi.com/viewtopic.php?t=198104

    wmm habe ich auch mal testweise im Router deaktiviert.

    Auch das hat nichts gebracht:

    Code
    rmmod brcmfmac
    modprobe brcmfmac roamoff=1

    Ausgabe mit allen wieder auf Original in der .conf:

  • Mittlerweile geht es auch nicht mehr ohne Unterstrich:

    Code
    wlan0: CTRL-EVENT-ASSOC-REJECT bssid=00:00:00:00:00:00 status_code=16

    Genauso wenig mit Unterstrich:

    "status_code 16" bedeutet nur:

    Quote

    Authentication rejected due to timeout waiting for next frame in sequence

    Ohne genaue Informationen bzgl. Peripherie, Konstellation, Anwendung, etc. kommen wir m. E. nicht weiter (... oder evtl. nur durch Zufall). Es kann hdmi sein, es kann eine "Funkmaus" sein, es kann am roaming liegen, es kann ein anderer AP in der Nähe sein, es kann ein Smartphone/Tablet sein, etc., etc.

    EDIT:

    Was Du noch probieren kannst, ist, in der wpa_supplicant.conf auch die BSSID des AP und den 2.4GHz-Kanal/Frequenz (wenn fester Kanal am AP konfiguriert) einzutragen.

    In der "/etc/modprobe.d/brcmfmac.conf"-Datei, die Option:

    Code
    options brcmfmac roamoff=1

    konfigurieren, damit der PI (per WLAN) gezielt nur den einen AP sucht, findet und sich dann auch nicht mehr "stören" lässt.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Meine PIs

    PI4B/8GB (border device) OpenBSD 7.4 (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, stunnel-Proxy, Mumble-Server

    PI3B+ FreeBSD 14.0-R-p3 (arm64): SSH-Serv., WireGuard-Serv., ircd-hybrid-Serv., stunnel-Proxy, Mumble-Serv., ddclient

    PI4B/4GB Bullseye-lite (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, stunnel-Proxy, Mumble-Server, botamusique, ample

    PI3B OpenBSD 7.4 (64bit), mit stayauth-Flag 24/7 im Wlan

    Edited once, last by rpi444 (November 9, 2022 at 9:16 AM).

  • Ok, wenn man etwas wartet, verbindet er sich mit dem Router ohne Unterstrich.

    Aber jetzt wird es lustig:

    Ich habe mal einen externen WLAN-USB-Stick drangesteckt, jetzt verbindet sich das interne WLAN auch mit den Routern mit Unterstrich.

    Der externe will aber noch nicht:

    Code
    Successfully initialized wpa_supplicant
    nl80211: Could not configure driver mode
    nl80211: deinit ifname=wlan1 disabled_11b_rates=0
    wlan1: Failed to initialize driver interface

    Erstmal "schnell" den Treiber kompilieren und installieren. :daumendreh2:

    So, jetzt verbinden sich beide auch mit den Routern mit Unterstrich.

    Jetzt mal den USB-Stick abziehen und neu starten...

    Und er verbindet sich auch mit den Routern mit dem Unterstrich.

    Komisch, aber ist so. :bravo2::lol:

  • Welchen Treiber hat der WLAN-USB-Stick benutzt?

    Hast Du bzw. wenn ja wie, vor dem kompilieren, bestimmte Optionen für den Treiber (brcmfmac?) konfiguriert/geändert/angepasst?

    Wie sind jetzt die Ausgaben von:

    Code
    ls -la /lib/modules/$(uname -r)/kernel/drivers/net/wireless/broadcom/brcm80211/brcmfmac
    modinfo brcmfmac

    und nach einem:

    Code
    sudo modprobe -v configs

    auch die Ausgabe von:

    Code
    zcat /proc/config.gz | grep -i brcmf

    ?

    EDIT:

    Evtl. sind auch die default-Werte der parms, beim Original-Treiber anders als in deinem kompilierten Treiber:

    Display Spoiler
    Code
    parm:           txglomsz:Maximum tx packet chain size [SDIO] (int)
    parm:           debug:Level of debug output (int)
    parm:           p2pon:Enable legacy p2p management functionality (int)
    parm:           feature_disable:Disable features (int)
    parm:           alternative_fw_path:Alternative firmware path (string)
    parm:           fcmode:Mode of firmware signalled flow control (int)
    parm:           roamoff:Do not use internal roaming engine (int)
    parm:           iapp:Enable partial support for the obsoleted Inter-Access Point Protocol (int)
    parm:           ignore_probe_fail:always succeed probe for debugging (int)

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Meine PIs

    PI4B/8GB (border device) OpenBSD 7.4 (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, stunnel-Proxy, Mumble-Server

    PI3B+ FreeBSD 14.0-R-p3 (arm64): SSH-Serv., WireGuard-Serv., ircd-hybrid-Serv., stunnel-Proxy, Mumble-Serv., ddclient

    PI4B/4GB Bullseye-lite (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, stunnel-Proxy, Mumble-Server, botamusique, ample

    PI3B OpenBSD 7.4 (64bit), mit stayauth-Flag 24/7 im Wlan

    Edited once, last by rpi444 (November 9, 2022 at 11:11 AM).

  • rtl8188eus mit dem von Github/aircrack-ng, sonst nichts, nur make && make install.

  • rtl8188eus mit dem ...

    Hm ..., das ist aber nicht der Treiber für das built-in-Wifi? Oder verstehe ich da etwas nicht richtig?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Meine PIs

    PI4B/8GB (border device) OpenBSD 7.4 (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, stunnel-Proxy, Mumble-Server

    PI3B+ FreeBSD 14.0-R-p3 (arm64): SSH-Serv., WireGuard-Serv., ircd-hybrid-Serv., stunnel-Proxy, Mumble-Serv., ddclient

    PI4B/4GB Bullseye-lite (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, stunnel-Proxy, Mumble-Server, botamusique, ample

    PI3B OpenBSD 7.4 (64bit), mit stayauth-Flag 24/7 im Wlan

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!