Raspberry Pi OS Bullseye 64bit am Raspi-400 friert plötzlich ein

  • Hi Leute,

    weil es gerade wieder vorgekommen ist: alle Heiligenzeiten mal friert ohne Vorwarnung mein Bullseye 64bit am Raspi-400 ein. Externe Tastatur und Maus hängen via USB3-Hub am Raspi (wird gelegentlich umgestöpselt auf dem Desktop-PC, damit ich hier nicht 2 Tastaturen und 2 Mäuse am Schreibtisch habe). Jetzt habe ich kurz im Augenwinkel bemerkt, dass die LEDs am USB-Hub ein wenig geblinzelt hatten, kurz danach fror die Maus ein und die Tastatur reagierte auch nicht mehr. Am Firefox lief ein YT-Video, das anfangs noch normal lief, danach fror das Bild ein, der Ton lief weiter - und dann stellte auch der Lautsprecher seinen Dienst ein; ich vermute, dass hier noch die Daten im Cache abgearbeitet wurden, aber keine Daten mehr über das LAN-Kabel im Raspi ankamen (oder er sie nicht mehr übernommen hat).

    Meine Fragen:

    1. Gibt es noch irgendeinen Trick in dieser Situation, um das System noch ordnungsgemäß herunter zu fahren? Bislang habe ich den Raspi einfach von der Spannungsversorgung getrennt und das ging erstaunlicherweise bislang gut.

    2. Ich würde nur allzu gerne wissen, was zu diesen Effekt führt, dazu brauche ich aber Hinweise von Euch, wie ich eventuell das verursachende Problem aus den Log-Files extrahieren kann.

    Danke für jede Unterstützung.

  • Raspberry Pi OS Bullseye 64bit am Raspi-400 friert plötzlich ein? Schau mal ob du hier fündig wirst!

  • Keine Ausgabe:

    Code
    pi@RaspiH:~ $ cat /var/log/syslog* | grep "under-voltage"
    pi@RaspiH:~ $ 

    Wäre es möglich, dass das Schreiben ins Log-File nimmer möglich war nach/während des Einfrierens? Jedenfalls kann es meiner Meinung nach nicht daran liegen, weil ich auch schon über länger Zeit auch mal einen Arduino Nano betrieben und programmiert habe und da kam es nie zu diesem Effekt.

  • hyle

    Reinsehen kann ich wohl, aber was ich daraus entnehmen soll, weiß ich nicht. Aber zu der Zeit sieht es ein wenig wirr aus, wenn ich die Zeitangaben verfolge. Siehe hier:

    Davor sind nur die Logs von der Sitzung davor, also von 10:34 oder früher. Interessant ist, dass es nach dem Zeitstempel 17:05:30 mit 17:02:55 weitergeht. Aber irgendwie kann ich mir vorstellen, dass mit dem stromlos Machen die letzten Log-Daten verschwinden und man so gar nicht das verursachende Problem erkennt. Eine Frage: Sieht das ab 17:02:55 nach einem Boot-Vorgang aus?

    Speicherprobleme möchte ich ebenfalls ausschließen, weil oft genug der Rechner stundenlang läuft und ich häufig YT-Videos laufen lasse - trotzdem kommt dieser Effekt höchst selten vor.

    Qvrgre

    Die Idee mit dem KVM wäre gut, wenn ich damit nicht auch mal andere USB-Geräte anschließen möchte wie externe Speichergeräte (Sticks oder Platten oder SSDs) oder Scanner etc. Und so oft trifft mich das Problem auch nicht, vielleicht 2 bis 3 mal im Jahr (bei täglich bis zu 10 Stunden Laufzeit).

    _______________

    Ich werde mir mal die genaue Uhrzeit notieren, wenn es wieder mal so weit sein sollte und werde den Rechner dann trotzdem noch 5 Minuten laufen lassen, vielleicht schreibt er ja dadurch das Logfile vollständig auf die SSD.

  • ... und was dazu führen könnte das er sich beim abziehen von Mouse/Tastatur aufhängt, könnte an dem backpower vom aktiven Hub kommen (Spannungsspitze?) ...

    Das kann ich definitiv ausschließen, weil der Hub im Normalfall ohne aktivem Netzteil betrieben wird; für die Maus und die Tastatur reicht das vollkommen aus, weil wie schon gesagt, das System normalerweise auch über Stunden stabil läuft. Und sogar fürs Programmieren und den Betrieb eines Arduinos oder für einen USB-Stick noch genügend Strom zur Verfügung steht.

    Zugegeben, ich schalte das Netzteil für den USB-Hub nur selten zu, aber auf diese Weise hatte ich diesen Effekt noch nie.

    Für mich als Laien sieht es eher so aus, als würde irgend ein Stück Software unter ganz bestimmten (noch nicht bekannten) Voraussetzungen das Problem verursacht. Vielleicht ein Treiber?

  • Du hast recht, daran hab ich jetzt wieder mal nicht gedacht, dass der Raspi ja keine Echtzeit-Uhr hat. Bei dem Schnippsel oben handelt es sich genau um jene Sitzung, die eingefroren ist - bis zum Beginn des Boot-Vorgangs, nachdem ich dem Rechner den Strom weggenommen habe. Der Teil vor der Zeit-Synchronisierung habe ich als Dateianhang hochgeladen. Aber ich denke, das wird nichts aussagen, weil bis dahin war ja alles in Ordnung.

    logfile.txt

  • Der Teil vor der Zeit-Synchronisierung habe ich als Dateianhang hochgeladen.

    Zeig mal bitte noch den Rest vor 10:34:26 (ab dem Systemstart), den Du als Anhang hochgeladen hast. Auch da sollte/könnte die erste Zeile irgendetwas mit systemd-timesyncd enthalten, aber das siehst Du ja an den Zeiten. ;)

    Aber ja, das ist reine Neugier von mir! Ob da ein Vergleich etwas bringt werden wir sehen.

  • Vor dem Teil, den ich als Anhang hochgeladen habe, kommen meiner Interpretation nach nur die letzten Zeilen vom ordnungsgemäßen Shutdown der Sitzung davor:

  • Das ist nun wirklich seltsam, denn dann würde der Neustart nur vier Sekunden dauern. Meiner Meinung nach fehlt da so einiges. :conf:

    Eigenartig find ich auch sowas hier:

    Quote

    Linux version 5.15.76-v8+ (dom@buildbot) (aarch64-linux-gnu-gcc-8 (Ubuntu/Linaro 8.4.0-3ubuntu1) 8.4.0, GNU ld (GNU Binutils for Ubuntu) 2.34)

    , aber das kann an der 64bit Version liegen.

  • Das ist nun wirklich seltsam, denn dann würde der Neustart nur vier Sekunden dauern. Meiner Meinung nach fehlt da so einiges. :conf:

    Ich habs schon mal oben vermutender Weise anklingen lassen: Wird ja wohl so sein, dass die Log-Daten nicht sofort auf die SSD geschrieben werden, sondern erstmal in einem RAM-Buffer landen; und erst, wenn dieser gefüllt ist, wird auf den Massenspeicher geschrieben. Und wenn das System einfriert, dann kann ja auch nicht mehr der RAM-Buffer geleert werden. Und mit der Trennung vom Strom sind die Daten dann für immer im Nirvana ......

  • Am Raspi400 musst Du Fn+F10 drüclen, um Aus und Einzuschalten! Sonst passiert mir das bei Überlastunf durch viele Programme gleichzeitig oder Websites. Du kannst aber ZRAM installieren, dann stürtzt der Pi nicht ab, sondern macht langsam weiter, also etwas WARTEN!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!