GPIO wird durch Lautsprecher deaktiviert

  • Ich verwende https://github.com/ts1/PiIR um Infrarotsignale zu senden und zu empfangen.

    Das funktioniert solange gut, wie ich über den Lautsprecher, der an die Pi-eigene Klinkenbuchse angeschlossen ist, nichts abspiele, etwa über aplay.

    Sobald ich nach Abspielen Infrarotsignale sende, werden sie nicht übertragen, stattdessen höre ich 221211_8109.zip aus dem Lautsprecher. Ein Neustart behebt das Problem, bis ich wieder etwas abspiele.

    OS ist Bullseye.

    Woran kann das liegen?

  • Moinsen,

    Ich weiss jetzt nicht, was dich bewegt hat entgegen der Darstellung ( Reedme ) andere Gpio-Pins zu verwenden ?

    Laut der Beschaltungsunterlagen aus deinem Link sieht das erst einmal so aus:

    und so:

    Dann obwohl du das hier in einer Kategorie zu einem Speziellen RasPi Modell gepostet hast, trotzdem die Nachfrage - du hast auf deinem PI-Board eine 3- oder 4 polige 3,5 Klinkenbuchse ?

    Wenn du eine 4-polige Klinkenbuchse auf dem Board hast, welches neben dem beiden Audio-Kanälen auch noch eine Video Composite Signal mit ausgibt, du aber nur einen 3 poligen Klinkenstecker kann es Rückkopplungswirkungen haben...
    Nur mal um diesen Punkt als potentielle Fehlerquelle auszuschließen. Wenn 4-Polige Buchse , dann auch einen 4-Poligen Stecker verwenden. Sollte das Problem bei 3-Poliger Buchse und 3-Poligen Stecker weiter bestehen, würde ich es erst einmal mit der Ausgangskonfiguration der GPIOs wie gemäß der Readme versuchen, und dann mich an den Autor wenden, bzw. dem Hinweis zu "https://abyz.me.uk/rpi/pigpio/" bezüglich der Boardkompatibilitäten folgen.

    Hier der Auszug, der Readme.md aus der letzten Version 0.2.5 vom 10.04.2021 des Autor dieses Beitrags bei Github.

    Hier wird nochmals ausdrücklich darauf hingewiesen, dass der IR-Empfäner an GPIO 22 sich befinden muss. Leider ist deine Aussage 22 uund 24 eher ergebnisoffen ?

    Franky

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!