PI Zero USB-Stick mounten

Heute ist Stammtischzeit:
Jeden Donnerstag 20:30 Uhr hier im Chat.
Wer Lust hat, kann sich gerne beteiligen. ;)
  • Hallo!

    Ich wollte an meinem PI-Zero ein Netzlaufwerk einrichten, dass auf einem USB-Stick abliegt. Sollte ja eigentlich kein Problem sein.

    Angeschlossen habe ich den Stick mit einem Adapter.

    Orientieren wollte ich mich an dieser Anleitung: YOUTUBE

    Leider zeigt sich bei mir bei

    ls /media/

    überhaupt kein USB-Stick und der Stick leuchtet oder blinkt auf nicht.

    Ich habe das jetzt an einen Zero am Netzteil, einem Zero 2 mit und ohne Netzteil und an einem 4 (falls der Adapter kaputt wäre) probiert aber im Prinzip immer das gleiche...

    Muss ich erst noch etwas "einschalten"?

    Vielen Dank!

  • Möglicherweise wird der Stick nicht dorthin gemountet.

    Schreib doch mal hin: lsblk

    Dann solltest du - wenn der Stick überhaupt gemounted wird - den Mount-Point gezeigt bekommen.

    Meine Pis

    Pi B Rev 2 24/7 - DHCP-Server im Heimnetz
    Pi 2B Rev 1.1 Home-Infocenter (Domoticz) - Kamera auf Garten
    Pi 2B Rev 1.1 Testgerät mit USV, Musikplayer, Kodi,
    Pi 3B Rev 1.2 Videos aus Netzwerk (an Rückseite des TV moniert)
    Pi 3B+ Rev 1.3 mit 3.5-TouchDisplay, Peppy-Web-Radio
    Pi 4B - 4GB Rev 1.1 Testgerät - Argon-ONE-Gehäuse

    Pi Zero Testgerät

    Pi Zero W Rev 1.1 Motion-Eye auf Garten

  • Leider zeigt sich bei mir bei

    ls /media/


    überhaupt kein USB-Stick

    Du verwendest keinen Desktop und so wird der Stick auch nicht vom pcmanfm automagisch nach /media gemountet und dann zeigt es auch nichts an. Such Dir eine Anleitung, bei der das Mounten von USB-Laufwerken ohne Desktopumgebung gezeigt wird! ;)

  • Hallo,

    da bietet sich das Wiki von Ubuntusers an, da findet man zum Beispiel sowas:

    https://wiki.ubuntuusers.de/fstab/

    Und da kann man sich schön durchlicken bis man alle Infos hat.

    https://wiki.ubuntuusers.de/UUID/

    https://wiki.ubuntuusers.de/blkid/

    https://wiki.ubuntuusers.de/Externe_Laufwe…isch_einbinden/

    https://wiki.ubuntuusers.de/USB-Datentr%C3…isch_einbinden/

    Und so weiter.

    Grüße

    Dennis

    🎧 Strahlend soll die Zukunft sein, gut wir werden seh'n, ob wir wie ein Strahlemann lächelnd untergeh'n.  🎧

  • Gib zuerst mal den Befehl:

    Code
    $ lsusb

    ein, ggf einmal mit und einmal ohne angeschlossenem Stick. Ist der Stick dabei? Wenn nicht hast du ein Problem mit der Erkennung des Sticks und mußt dort den Fehler suchen.

    Ansonsten gib folgenden Befehl ein:

    Code
    ls -l /dev/disk/by-uuid/

    Da kommt dann u.a. soetwas:

    Code
    lrwxrwxrwx 1 root root 10 22. Jan 10:51 0123456789ABCDEF -> ../../sda1

    Falls der Stick ntfs formatiert ist füge in der /etc/fstab folgende Zeile ein und verwende die obige UUID:

    Code
    UUID=0123456789ABCDEF <dein mountverzeichnis> ntfs auto,gid=1000,uid=1000,nofail,sync,nousers,rw 0 0

    Das ist vielleicht nicht alles optimal und nur auf NTFS Formatierung beschränkt, es funktioniert aber bei mir mit dem aktuellsten Bullseyeimage. Die Installation weitere Komponenten war, soweit ich mich erinnern kann, dazu nicht notwendig. Dein Video ist offensichtlich hoffnunglos veraltet.

  • Dein Video ist offensichtlich hoffnunglos veraltet.

    Quote

    43,845 views Jan 18, 2013 Raspberry Pi - Fortgeschrittene Tutorials In diesem kleinen Tutorial zeige ich euch, wie ihr einen USB-Stick/-Festplatte auf eurem Raspberry Pi mounten/einbinden könnt.

    Ausführliche Anleitung: https://www.youtube.com/redirect?event…F&v=pcuss4gfdS8

    Mist, 4 Tage zu spät zum 10jährigen Jubiläum. Überraschung, der Link nach karesyk.de geht nicht mehr. Dann eben archive.org

    :rolleyes: sudo !!

  • Möglicherweise wird der Stick nicht dorthin gemountet.

    Schreib doch mal hin: lsblk

    Dann solltest du - wenn der Stick überhaupt gemounted wird - den Mount-Point gezeigt bekommen.

    Das Ergebnis sieht so aus:

    Ich vermute aber, dass ist nur, weil ich vorab auch mal diese Anleitung probiert habe:
    https://www.elektronik-kompendium.de/sites/raspberry-pi/1911271.htm
    Wenn ich das so im Nachhinein richtig verstehe, habe ich damit eine Partition namens "usbstick" erstellt?

    Du verwendest keinen Desktop und so wird der Stick auch nicht vom pcmanfm automagisch nach /media gemountet und dann zeigt es auch nichts an. Such Dir eine Anleitung, bei der das Mounten von USB-Laufwerken ohne Desktopumgebung gezeigt wird! ;)

    Ich kann natürlich falsch liegen aber da ich über vnc zugreife, habe ich doch eine Desktopumgebung - oder?


    lsusb bringt mit und ohne Stick das gleiche Ergebnis:

    pi@garagenpi:~ $ lsusb

    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    pi@garagenpi:~ $ lsusb

    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    Vielen Dank für den Hinweis zum Alter des Videos. Das war mir durchgerutscht.

  • Post by Tastenknecht (January 23, 2023 at 6:00 PM).

    The post was deleted, no further information is available.
  • Dann kontrolliere zuerst den Stick und dann den Adapter an einem anderen Gerät. Wird der Stick erkannt und wenn ja, blinkt er?

  • Ich kann natürlich falsch liegen aber da ich über vnc zugreife, habe ich doch eine Desktopumgebung - oder?

    Sorry, dann habe ich das falsch interpretiert. Die Ausgabe von lsblk sieht trotzdem seltsam aus. Wo ist (/) :conf:

    Was ist die Ausgabe von findmnt?


  • Ich kann natürlich falsch liegen aber da ich über vnc zugreife, habe ich doch eine Desktopumgebung - oder?

    Ja. Bei mir wird ein an RPi 4 ohne Bildschirm, Tastatur und Monitor ein dort eingesteckter Stick auch erkannt und - via VNC-Oberfläche - angeboten, das Verzeichnis zu öffnen. Bei Dir zeigt aber schon lsusb den Stick nicht an, dann gibt es auch nichts zu öffnen.

    Edit: kann man hier nicht in Frieden einen Stick in einem anderen Raum einstecken, die ganzen Meldungen wegklicken (viele Partitionen auf dem Stick) und seinen Beitrag zu Ende schreiben, ohne dass jemand die Frage in der Zwischenzeit beantwortet? ;)

    :rolleyes: sudo !!

  • Also der Stick blinkt nicht und der 2. wird auch nicht erkannt.

    findmnt sieht wie folgt aus:

    Den Adapter zu testen, fällt mir eben schwer, weil ich nichts sonst mit Mini-USB habe, wo ich ihn anstecken könnte.

    Aber wenn ich an den Adapter beispielsweise eine Tastatur anstecke, müsste ich dann P&P schreiben können?

    Ich hab grad nochmal am PI4 probiert (der hat tatsächlich keine Desktopumgebung). Da sieht lsblk so aus:

    Code
    NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
    sda           8:0    1 117.2G  0 disk
    └─sda1        8:1    1 117.2G  0 part
    mmcblk0     179:0    0  29.7G  0 disk
    ├─mmcblk0p1 179:1    0   256M  0 part /boot
    └─mmcblk0p2 179:2    0  29.5G  0 part /

    sda wäre ja der Stick - oder?

  • Also der Stick blinkt nicht und der 2. wird auch nicht erkannt.

    findmnt sieht wie folgt aus:

    Code
    TARGET                                SOURCE         FSTYPE    OPTIONS
    /                                     /dev/mmcblk0p2 ext4      rw,noatime
    ├─/boot                               /dev/mmcblk0p1 vfat      rw,relatime,fmask=0022,dmask=0022,codepag
    └─/media/usbstick                     /dev/mmcblk0p2 ext4      rw,relatime
    Code
    NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
    sda           8:0    1 117.2G  0 disk
    └─sda1        8:1    1 117.2G  0 part

    sda wäre ja der Stick - oder?

    Hat dein Stick 117G?

    Poste mal auch die Ausgabe von:

    Code
    lsblk -fp

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Meine PIs

    PI4B/8GB (border device) OpenBSD 7.4 (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, stunnel-Proxy, Mumble-Server

    PI3B+ FreeBSD 14.0-R-p3 (arm64): SSH-Serv., WireGuard-Serv., ircd-hybrid-Serv., stunnel-Proxy, Mumble-Serv., ddclient

    PI4B/4GB Bullseye-lite (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, stunnel-Proxy, Mumble-Server, botamusique, ample

    PI3B OpenBSD 7.4 (64bit), mit stayauth-Flag 24/7 im Wlan

  • Code
    └─/media/usbstick                     /dev/mmcblk0p2 ext4      rw,relatime

    Wo kommt das denn her? Hast Du einen entsprechenden Eintrag in der /etc/fstab gemacht oder an evtl. auch anderer Stelle? Da wird nämlich versucht die zweite Partition der SD-Karte nach /media/usbstick zu mounten und das kann nicht richtig sein.

    Zeige dann bitte auch mal die Ausgabe von cat /etc/fstab!

    Solange ein Verzeichnis, in dem Fall /media/usbstick, durch einen Mount(versuch) gebunden ist, kann da hinein nichts anderes gemountet werden.

  • Hallo!

    Vielen Dank für eure Hilfe und Hinweise.
    Ich hatte mir basierend auf der letzten Erkenntnis, einen neuen Adapter gekauft, der gestern ankam und siehe da: Plug&Play. Der Stick poppte sogar auf dem Desktop auf und konnte ohne Probleme als Netzlaufwerk eingebunden werden. :)

  • Hallo!

    Vielen Dank für eure Hilfe und Hinweise.
    Ich hatte mir basierend auf der letzten Erkenntnis, einen neuen Adapter gekauft, der gestern ankam und siehe da: Plug&Play. Der Stick poppte sogar auf dem Desktop auf und konnte ohne Probleme als Netzlaufwerk eingebunden werden. :)

    • 2 x Micro-USB-Anschlüsse jeweils einer für Stromversorgung und USB

    vielleicht war das Netzteil am falschen Micro-USB, war bei mir der Fall ...

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!