Emergency mode; Fehlermeldung [112] [107]

  • Hallo zusammen,


    nachdem ich meinen PI ganz normal neustarten wollte, ist dieser nicht mehr hochgefahren, sondern in den emergency mode übergangen. Anbei ein Bild des aktuellen Bildschirms inkl. der Fehlermeldungen:

    [2.742533] systemd-fstab-generator[112]: Failed to create unit file /run/sys

    [2.8202801 systemd[107]: /usr/lib/systemd /system-generators/systemd-fstab-ge



    Hatte diesen Fall schon jemand, bzw. hat jemand eine Idee wie ich das lösen kann? Ich habe auch schon gegoogelt und im Forum gesucht, leider vergeblich.


    Vielen Dank für eure Rückmeldungen.



    LG

    Fatih

    Edited 2 times, last by FatihK ().

  • Hallo Hyle,


    Danke für deine schnelle Rückmeldung.


    Ja ich hatte mal ein USB-Stick dran, habe den aber wieder entfernt. Ich habe nichts da drin gespeichert.


    Jetzt habe ich den Stick, wieder eingesteckt, aber es kommt immernoch die gleiche Fehlermeldung... Ich benötige diesen Stick nicht in meiner RPi, wie kann ich das dem System mitteilen?


    Ich dachte mir damals nichts dabei, USB rein paar Sachen ausprobiert und wieder raus gesteckt.

  • Ich bin mir nicht 100% sicher ob es wirklich an dem Stick liegt. Das wäre nur der Fall, wenn Du diesen in der /etc/fstab zum automatischen Mounten eingetragen hattest.


    Falls Du ein Linuxsystem (*) und einen USB-Cardreader haben solltest, könntest Du auf der SD-Karte mal nachschauen ob ein solcher Eintrag vorhanden ist.


    *) oder eine zweite SD auf die Du z.B. ein Raspberry Pi OS Lite installieren und den RPi damit starten könntest

  • Hallo Hyle,


    ich habe leider kein Linuxsystem, habe mich aber schon bemüht und versucht dieses Problem wie folgt zu lösen.


    Ich habe ganz normal über Windows die Boot Partition der Speicherkarte geöffnet und in die cmdline.txt init=/bin/sh hinzugefügt.


    Über mount -o remount,rw / und nano /etc/fstab bin ich dann in meine fstab gekommen und hätte es bearbeiten können. Ich wollte dennoch nichts machen, weil ich nicht weiß, was ich löschen müsste.


  • Post by framp ().

    This post was deleted by the author themselves: Unfug ().
  • Die Rootpartition wird nicht gefunden :conf: . Kannst Du mal die Ausgabe von lsblk -o +UUID,PARTUUID zeigen? Ausserdem solltest Du schon mal die zwei letzten Zeilen am Anfang mit einem # versehen. Dadurch werden die beiden Zeilen deaktiviert.

    Hast Du schon Deine Raspberries gesichert :fies:

    Bei mir erledigt das raspiBackup vollautomatisch jede Woche :shy: