Laptop schaltet sich nach boot von USB-Stick nicht ganz aus

  • Hallo zusammen,

    ich hätte mal wieder eine Raspberry unabhängige Frage.

    Hin und wieder kommt es mal vor, dass es ganz praktisch ist ein Linux-Live System von einem USB-Stick zu starten. Kürzlich habe ich das gemacht und als ich auf Herunterfahren klickte, fuhr der Laptop nicht vollständig runter. Der Bildschirm war ganz schwarz, aber es leuchtete noch eine LED von meiner "FnLk"-Taste. Ich konnte Stunden warten, der Laptop blieb in diesem Zustand. Es brachte auch nichts den USB-Stick aus zustecken und irgendwelche Tasten zu drücken, ich muss die Powertaste gedrückt halten, anders bekomme ich ihn nicht mehr aus.

    Das lies mir keine Ruhe, also habe ich Linux auf ein Stick installiert, also nicht nur eine Live-Version, sondern anstelle der Festplatte auf den Stick installiert inklusive Bootloader. Das System startete einwandfrei, aber beim herunterfahren das Gleiche wieder. Dabei ist es egal ob Debian oder Ubuntu. Mein nächster Versuch war eine SSD-Platte auf der WIndows drauf ist, die habe ich in ein USB-Gehäuse gesteckt und von der Platte gebootet, herunter gefahren und zack, der Laptop ist ganz aus.

    Anstelle eines USB-Sticks habe ich dann eine SSD genommen, Debian installiert, per USB-Kabel angeschlossen, Laptop fährt nicht ganz runter.

    Kennt das Problem jemand und kann mir jemand helfen?

    Es ist schon etwas her, aber ich meine das letzte mal hatte ich das Problem mit USB-Boot an dem gleichen Laptop(Lenovo ThinkPad Yoga von 2016) nicht. Habe gerade leider keinen anderen zur Verfügung um es weiter testen zu können.

    Vielen Dank schon mal!

    Grüße

    Dennis

    🎧 Strahlend soll die Zukunft sein, gut wir werden seh'n, ob wir wie ein Strahlemann lächelnd untergeh'n.  🎧

  • Laptop schaltet sich nach boot von USB-Stick nicht ganz aus? Schau mal ob du hier fündig wirst!

  • Moinsen,

    auch wenn dir wahrscheinlich diese Aussage wenig helfen wird, dieses Phänomen mit Live-System-Datenträgern, auch Live-DVD wie Knoppix, sind bei I3/I5 basieren Laptops bis 8.Generation auf ASUS Mobilgeräten ( Laptop und Co ) durchaus bekannt. Erst ab der Architektur basierend auf Ice Lake soll nach meinem Kenntnisstand dieses Problem nicht mehr auftreten. Lösung -> Hartes Power-Down.

    Franky

  • Kürzlich habe ich das gemacht und als ich auf Herunterfahren klickte, fuhr der Laptop nicht vollständig runter.

    Teste mal in der Kommandozeile, mit:

    Code
    sudo shutdown -h now

    und mit:

    Code
    sudo shutdown -P now

    (oder gleichwertig, je nach Linux-Distribution/-Version).

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Meine PIs

    PI4B/8GB (border device) OpenBSD 7.4 (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, stunnel-Proxy, Mumble-Server

    PI3B+ FreeBSD 14.0-R-p3 (arm64): SSH-Serv., WireGuard-Serv., ircd-hybrid-Serv., stunnel-Proxy, Mumble-Serv., ddclient

    PI4B/4GB Bullseye-lite (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, stunnel-Proxy, Mumble-Server, botamusique, ample

    PI3B OpenBSD 7.4 (64bit), mit stayauth-Flag 24/7 im Wlan

  • Danke für die Antworten.

    Zum System liefert lscpu:

    Die "shutdown"-Befehle habe ich auf einem Live-USB-Stick getestet und auf einer Festplatte die per USB am Laptop hängt. Auf der Platte ist Linux installiert. Bei beiden Systemen fuhr das System zwar mit beiden Befehlen herunter, aber der Laptop ging nie vollständig aus.

    Grüße

    Dennis

    🎧 Strahlend soll die Zukunft sein, gut wir werden seh'n, ob wir wie ein Strahlemann lächelnd untergeh'n.  🎧

  • Die "shutdown"-Befehle habe ich auf einem Live-USB-Stick getestet und auf einer Festplatte die per USB am Laptop hängt. Auf der Platte ist Linux installiert. Bei beiden Systemen fuhr das System zwar mit beiden Befehlen herunter, aber der Laptop ging nie vollständig aus.

    Wie ist die Ausgabe von:

    Code
    cat /etc/default/halt

    ?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Meine PIs

    PI4B/8GB (border device) OpenBSD 7.4 (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, stunnel-Proxy, Mumble-Server

    PI3B+ FreeBSD 14.0-R-p3 (arm64): SSH-Serv., WireGuard-Serv., ircd-hybrid-Serv., stunnel-Proxy, Mumble-Serv., ddclient

    PI4B/4GB Bullseye-lite (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, stunnel-Proxy, Mumble-Server, botamusique, ample

    PI3B OpenBSD 7.4 (64bit), mit stayauth-Flag 24/7 im Wlan

  • Moinsen

    Lenovo ThinkPad Yoga

    Es scheint wohl auch mit diesem Modell laut Forenmeldungen diese Probleme nicht nur mit Linux zu geben !?

    Und das waren meist i3/i5 Systeme.

    Ergänzende Frage: Wie viele Generationen I-Core i3/ i5 Prozessoren gibt es , oder gab es bis zum Stand, wie von Dennis89 im Eingangspost = 2016 genannt wurde ? Auf welche Hersteller beziehst du dich, und welche Generation der I-Cores CPUs waren oder sind in deinem Testsystem verbaut ?
    Meine Aussage bezog sich ganz klar ein eine Microarchitekturserie nur in Verbindung mit einem Hersteller. Daher solltest du deine Angaben zu deinen Systemen mal etwas spezifizieren, und nicht einfach Aussagen, welche belegbar sind, in Frage stellen.

    Franky

  • Wie ist die Ausgabe von:

    Code
    cat /etc/default/halt

    Diese Datei gibt es bei mir im Live-System nicht:

    Grüße

    Dennis

    🎧 Strahlend soll die Zukunft sein, gut wir werden seh'n, ob wir wie ein Strahlemann lächelnd untergeh'n.  🎧

  • Danke für die Antwort. Die Befehle haben leider die gleiche Auswirkung. Es ändert also nichts.

    BIOS/UEFI Einstellungen können damit nichts zu tun haben? Das wird nur auf den Start Auswirkungen haben?

    Grüße

    Dennis

    🎧 Strahlend soll die Zukunft sein, gut wir werden seh'n, ob wir wie ein Strahlemann lächelnd untergeh'n.  🎧

  • Danke für den Link.

    Ich habe mal auf UEFI only im Boot-Menü gestellt und danach auf Legacy only das Live-System startet zwar beides mal, aber am herunterfahren ändert sich nichts.

    Das Live-System installiere ich ja an sich nicht, das habe ich mit dd auf den Stick geflasht. Und die *.iso ist aktuell.


    Grüße

    Dennis

    🎧 Strahlend soll die Zukunft sein, gut wir werden seh'n, ob wir wie ein Strahlemann lächelnd untergeh'n.  🎧

  • https://genuine-lamps.com/linux/5005-how…t-turn-off.html

    oder noch:

    3. Text von oben.

    Die Lösung war, im Rescue Modus der Debian netinstall zu starten, den Grub neu zu installieren und diesen direkt wie es sich gehören sollte bei meiner Partitionierung in /dev/sda1/boot/efi/ installiert. Klappte, funktioniert seitdem und er bootet und fährt auch weiterhin komplett herunter und es geht alles aus.

  • Hi und danke,

    ich habe auf der internen Platte Fedora installiert und das lässt sich problemlos herunterfahren. Ich denke von daher ist Grub richtig installiert.

    Ich habe nachher wieder einen zweiten Laptop da, dann teste ich den Stick mit dem mal und werde berichten.


    Grüße

    Dennis

    🎧 Strahlend soll die Zukunft sein, gut wir werden seh'n, ob wir wie ein Strahlemann lächelnd untergeh'n.  🎧

  • Guten Morgen,

    das Problem muss mit dem ThinkPad zusammenhängen. Der gleiche Stick an einem Dell Laptop(ähnliches Bj) funktioniert problemlos und er schaltet sich vollständig aus.

    Vielleicht baue ich mal die interne Festplatte aus, dann könnte ich testen ob es rein an der Hardware liegt.

    Grüße

    Dennis

    🎧 Strahlend soll die Zukunft sein, gut wir werden seh'n, ob wir wie ein Strahlemann lächelnd untergeh'n.  🎧

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!