Raspi4 als WLAN Bridge keine Funktion

  • Ich möchte meinen Raspi ua als WLAN Bridge einsetzen um ein eigenes WLAN im Keller aufzuspannen.

    Die Clients sollen sich im gleichen Subnetz befinden.

    Dies habe ich gemäß der Anleitung gemacht:

    Die entspricht weitgehend der Anleitung auf

    Raspberry Pi Documentation - Configuration
    The official documentation for Raspberry Pi computers and microcontrollers
    web.archive.org

    unter dem Kapitel: Setting up a Bridged Wireless Access Point

    Leider funktioniert es nicht wie gewünscht.

    Ich muß zugeben, dass ich es vorher mit RaspAP probiert habe und dabei mir die Netzwerkkonfiguration völlig zerschossen habe.

    Nur mit Hilfe von einigen netten Usern in diesem Forum konnte ich den Raspi wieder ins Inet bringen.

    Daher weiß ich nicht, ob es damit was zu tu hat. Ich vermute nicht, da bis jetzt die WLAN Schnittstelle nie aktiv war.

    Die Installation verlief ohne Fehler, alle Diagnosen zeigen keine Fehler, dennoch wird kein AP aufgespannt.

    Augenscheinlich hat wlan0 auch keine IP-Adresse:

    Code
    pi@raspi4:~ $ networkctl
    IDX LINK  TYPE     OPERATIONAL SETUP
      1 lo    loopback carrier     unmanaged
      2 eth0  ether    routable    configured
      3 br0   bridge   off         unmanaged
      4 wlan0 wlan     degraded    unmanaged

    br0 ist wohl nicht aktiv, das kann ich mir nicht erklären.

    Der Raspi ist headless, daher kein ich beim booten keine Statusmeldungen sehen.

    OMV zeigt mir folgenden Status der #schnittstellen:

    Hat jemand eine Idee?

    Mein Dank im Voraus und schönen Abend noch

  • hostapd läuft,

    Code
    sudo systemctl start hostapd 

    .. wurde ausgeführt

  • Das Interface br0 muss die IP bekommen, nicht das eth0

    Moin.

    OK, an welcher Stelle muss ich was ändern?

    Die eth0 hat ja eine feste IP Adresse damit der Raspi immer erreichbar ist, auch wenn der Router Mal nicht läuft. Das sollte nach Möglichkeit so bleiben. Aber das sollte ja nicht im Wege stehen, der br0 auch eine feste IP zu verpassen.

    Danke dir.

    Bin gerade auf der Arbeit, kann also erst heute Abend weiter machen

  • hoschiking Die von Dir benutzte Anleitung weicht etwas von der "originalen" ab.

    Auf die Schnelle fällt mir auf:

    Hierzu legen wir eine neue Konfigurationsdatei an.

    Code
    sudo nano /etc/systemd/network/br0.network

    In diese Datei tragen wir folgende Zeilen ein:

    Code
    [Match]
    Name=br0
    
    [Network]
    DHCP=yes

    Das finde ich in der Anleitung https://web.archive.org/web/2022121110…ss-access-point , nach der ich es erfolgreich konfiguriert bekommen habe, nicht.

  • Moin.

    OK, an welcher Stelle muss ich was ändern?

    Die eth0 hat ja eine feste IP Adresse damit der Raspi immer erreichbar ist, auch wenn der Router Mal nicht läuft. Das sollte nach Möglichkeit so bleiben. Aber das sollte ja nicht im Wege stehen, der br0 auch eine feste IP zu verpassen.

    Danke dir.

    Bin gerade auf der Arbeit, kann also erst heute Abend weiter machen


    Du hast ein Interface br0 erstellt. Das Bridged das ETH0 und das WLAN0.
    Deswegen musst du die feste IP vom eth0 auf das br0 legen.
    eth0 und wlan0 werden nun von dem br0 gemanaged, einfach ausgedrückt.
    Der Pi ist dann weiterhin unter der ip adresse erreichbar.

    Offizieller Schmier und Schmutzfink des Forum.
    Warum einfach wenn's auch schwer geht ?

    Kein Support per PN !
    Fragen bitte hier im Forum stellen. So hat jeder etwas davon.

  • hoschiking Die von Dir benutzte Anleitung weicht etwas von der "originalen" ab.

    Auf die Schnelle fällt mir auf:

    Das finde ich in der Anleitung https://web.archive.org/web/2022121110…ss-access-point , nach der ich es erfolgreich konfiguriert bekommen habe, nicht.

    Ich habe beide Anleitungen ausprobiert und bei beiden ist der Effekt gleich es funktioniert nicht mit etwas anderem Verhalten.....

  • Alternative wäre, ich setze das System neu auf, was ich ohnehin machen muss, da das jetzige zerschossen ist und einiges nicht mehr geht.

    Habe gestern Abend damit angefangen, das wäre dann mit einem Umstieg von Bullseye auf bookworm verbunden. Auch gut. Die Frage ist nur, wenn ich es auf einem 4er einrichte und hinterher auf den 5er umziehe, würde der 5er von der SSD starten und weiterhin funktionieren oder muss ich dann erneut alles einrichten?

  • Sorry, ich habe den Eindruck, dass Du zu viele Baustellen gleichzeitig bearbeitest...

    Alleine die Umstellung auf Bookworm ist je nach Software nicht ganz ohne.

    Es ist sehr empfehlenswert, erst auf einem Testsystem, insbesondere jeden unbekannten Service etc. isoliert zu installieren und auszuprobieren.

    Und erst wenn es klappt (und am Besten auch verstanden wurde), auf dem Produktivsystem zu installieren.

    Insbesondere, wenn das Produktivsystem so zentral wichtig ist, wie Du es beschrieben hast.

    Und nicht vergessen: Unsere besseren Hälften beobachten unser stundenlanges Gebastel sehr genau!

  • Ja das stimmt und so war es auch gemeint. Ich lasse den jetzigen so laufen und probiere das an einem anderen aus und erst wenn alles läuft ziehe ich damit um. Nur wenn ich beim Umzug auf dem 5er ohnehin alles neu installieren muss, würde ich mir die Arbeit sparen und warten bis der lieferbar ist. Der Punkt ist, bullseye läuft nicht auf dem 5er, daher der zwangsweise Umstieg auf bookworm, um nicht mehr wieder bei 0 anfangen zu müssen. Ich habe noch eine alte 256GB SSD hier liegen mit der kann ich es alles in Ruhe ausprobieren. So muss ich auch keine Zeit mehr in das laufende System investieren und da hab ich noch das Risiko, dass es doch wieder nicht mehr läuft und dann ist das Drama wieder groß. So erschlage ich gleich 3 Fliegen mit einer Klappe. Und ich wüsste, was mir meine zu Weihnachten schenken kann :cool:

  • Wenn Du dann Bookworm als OS hast, kannst Du die Anleitung zum hostapd ad Acta legen.

    Neuerdings macht man das wohl mit dem NetworkManager, siehe aktuelle Anleitung der Foundation.

    Ich mache auf meinen Produktivsystemen noch einen deutlichen Bogen um den Bookworm. Der darf erst noch ein bisschen reifen...

  • Auch da volle Zustimmung, und es gibt ja auch eine Anleitung für bookworm ;) Wurde sogar weiter oben verlinkt. OMV gibt es für bookworm auch nur als Beta, die läuft auch noch nicht stabil, daher alles gut. Das würde ich erst frühestens Februar in Angriff nehmen. Vorher steht Urlaub an.... Daher bleibt die Frage stehen, kann man mit einem System von von 4er auf den 5er einfach umziehen ohne Neuinstallation?

  • Habe heute Mal zum Testen eine neue SD Karte aufgesetzt mit bullseye, bridge laut Anleitung erstellt und Zack, läuft. Dh mein System hat ne Macke, da ist viel nach der Aktion verstrubbelt. Hab Mal versucht die config von eth0 auf DHCP umzustellen, bricht mit einem Fehler ab. Ich kann also nicht Mal mehr die Einstellungen von eth0 ändern. Daher breche ich den Versuch ab, der Fehler ist gefunden. Ich lasse das System so wie es ist und werde es irgendwann neu aufsetzen.

    Danke euch für den Support. :thumbup:

  • Hallo zusammen,

    ich möchte das thema nochmal aufgreifen, da es anscheinend doch nicht erledigt ist.

    Ich bin ja dabei mein System mit OMV neu aufzusetzen, da einiges nicht mehr klappt.

    Ich habe einen zweten Raspi4 genommen und setzte alles Schritt für Schritt neu auf.

    Folgende Beobachtung:

    Richte ich den Access point auf einem frischen System ein, funktioniert alles prima.

    Installiere ich im ersten Schritt OMV6, dann funktioniert auch der Access point nicht.

    Soweit ich weiß, wird bei der Installation von OMV das WLAN soweit deaktiviert, dass man mittels

    WLAN nicht mal eine Verbindung zum Router einrichten kann. raspi-config meldet einen error,

    es ist wohl kein Zugriff mehr auf den Network-Manager möglich.

    das heißt für mich, OMV ist der Übeltäter.

    Wie stelle ich das an, damit WLAN wieder funktioniert und ich den Access point aktivieren kann?

    Ich möchte auf keinen Fall auf OMV verzichten, das ist schon ein praktisches Tool für den Raspi.

    Danke im Voraus

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!