Automatischer Start von Chromium funktioniert nicht

  • Hallo zusammen,

    ja, ich weiss das Thema ist ein "alter Hut" und in diversen Threads wurde dies schon behandelt.

    Aber ..

    Ich habe einen RaspPi 4 nach folgender Anleitung (http://www.raspis-world.de/2020/01/raspbe…iosk-modus.html) dazu gebracht eine Webseite automatisch darzustellen.

    Der Benutzer meldet sich automatisch an und schwupps startet der chromium-browser und die Seite wird angezeigt. Soweit so gut.

    Nun kaufe ich einen RaspPi 4 mit 8GB RAM um diese laufende Konfiguration zu Portieren. Wobei Portieren zu viel gesagt ist.

    Ich installiere den RaspPi mit folgendem Image: 2023-10-10-raspios-bookworm-arm64.img.xz, installiere die von mir nachinstallierte Software (vim und unclutter) und richte die /etc/xdg/lxsession/LXDE-pi/autostart wie auf dem ersten RaspPi ein. Es folgt ein Neustart ...

    ... und was passiert .. nix. :-/

    Ich habe weitere Anleitungen gefunden, die mit einem Service arbeiten. Die finde ich aber nicht so gelungen, wie die über die autostart Datei.

    Bei dieser Methode habe ich die Möglichkeit die gewünschte URL über ein Script automatisch zu ändern.

    .. und diese Variante würde ich auch gerne beibehalten.

    Hat jemand eine Idee, warum es bei dem einen RaPi geht und bei dem anderen nicht ?

    Wo werden die Fehlermeldungen (wenn es welche gibt) hingeschrieben. Unter /var/log finde ich nichts.


    Inhalt autostart:

    Code
    @lxpanel --profile LXDE-pi
    @pcmanfm --desktop --profile LXDE-pi
    #@xscreensaver -no-splash
    @xset s noblank
    @xset s off
    @xset -dpms
    point-rpi
    @chromium-browser --incognito --kiosk https://url.de

    Vielen Dank schonmal für die Unterstützung und Hilfe.. :danke_ATDE:

    ascotlx

  • Automatischer Start von Chromium funktioniert nicht? Schau mal ob du hier fündig wirst!

  • Such mal hier im Forum.
    Mit Bookworm hat sich so einiges geändert.
    lxpanel wurde zu wf-panel-pi , umstieg auf Wayland.

    EDIT :
    Hier ein Link zu einem aktuellen Tutorial unter Bookworm.
    How to use a Raspberry Pi in kiosk mode - Raspberry Pi

    Offizieller Schmier und Schmutzfink des Forum.
    Warum einfach wenn's auch schwer geht ?

    Kein Support per PN !
    Fragen bitte hier im Forum stellen. So hat jeder etwas davon.

    Edited once, last by Der_Imperator (November 22, 2023 at 3:54 PM).

  • mhh weder was zu lxpanel, lxpanel wf-panel-pi oder nur zu wf-panel-pi gefunden (außer meine Frage... und Deine Antwort.

    Ich habe die Anfrage ohne Filter gestellt..

  • Du warst zu schnell :)
    Schau mal oben, ich hab da noch einen Link rein gepackt.

    Offizieller Schmier und Schmutzfink des Forum.
    Warum einfach wenn's auch schwer geht ?

    Kein Support per PN !
    Fragen bitte hier im Forum stellen. So hat jeder etwas davon.

  • *.desktop-Dateien sollten auch mit Wayland funktionieren und nicht nur mit X.

    Versuchs mal mit einer Datei ~/.config/autostart/kiosk.desktop mit folgendem Inhalt:

    Code: kiosk.desktop
    [Desktop Entry]
    Type=Application
    Name=Kiosk-Chromium-Browser
    Exec=sh -c 'chromium-browser --incognito --kiosk https://url.de'
    Terminal=false
  • Ich zitiere mich mal selber aus einem anderen Thread

    Für die Nachwelt....

    Auf dem Desktop ein Terminal Fenster öffnen und echo $XDG_SESSION_TYPE eingeben. Dann erhält man als Ausgabe ob x11 oder wayland läuft.

    Ist die Ausgabe tty, dann habt ihr nicht richtig gelesen was ich im vorherigen Satz schrieb. :S

  • *.desktop-Dateien sollten auch mit Wayland funktionieren und nicht nur mit X.

    Versuchs mal mit einer Datei ~/.config/autostart/kiosk.desktop mit folgendem Inhalt:

    Code: kiosk.desktop
    [Desktop Entry]
    Type=Application
    Name=Kiosk-Chromium-Browser
    Exec=sh -c 'chromium-browser --incognito --kiosk https://url.de'
    Terminal=false

    Moin Hyle

    ja, es scheint zu funktionieren .. aber nur was den Start des Browsers betrifft. Die Webseite wird nicht richtig geladen. Oben rechts dreht ein Kreis im Chromium.

    Zudem wird der Cursor im Browser angezeigt... bekam man das nicht mit unclutter weg ?? Aber das ist erstmal mein kleinstes Problem..

    Ich probiere gleich noch die Methode vom "Imperator" ..

    hat jemand eine Idee warum es auf dem einen RaspPi funktioniert und auf dem anderen nicht ?

    Wie schon gesagt, finde ich diese Methode ziemlich cool. Ich habe mich auf den anderen RaspPi nochmal geschaltet (aber den leider nicht mehr bei mir stehen). Es ist kein 4er sondern ein Raspberry Pi 3 Model B Plus :

    Distributor ID: Debian

    Description: Debian GNU/Linux 12 (bookworm)

    Release: 12.2

    Codename: bookworm

  • Die Webseite wird nicht richtig geladen. Oben rechts dreht ein Kreis im Chromium.

    Da wird das Netzwerk vermutlich noch nicht ganz oben sein. Versuchs mal in der Exec-Zeile mit:

    Code
    Exec=sh -c 'sleep 20 && chromium-browser --incognito --kiosk https://url.de'

    bekam man das nicht mit unclutter weg ??

    Ich glaube ja, damit die Zeile so

    Code
    Exec=sh -c 'sleep 20 && /usr/bin/unclutter && chromium-browser --incognito --kiosk https://url.de'

    /usr/bin/unclutter sollte der richtige Pfad sein, musst Du aber selber mal nach der Installation davon nachsehen mit  which unclutter oder gleichwertig.

  • mhh weder was zu lxpanel, lxpanel wf-panel-pi oder nur zu wf-panel-pi gefunden (außer meine Frage... und Deine Antwort.

    Ich habe die Anfrage ohne Filter gestellt..

    Oben rechts auf die Lupe geklickt und dann nicht von "Dieses Thema" auf "Alles" gewechselt?

    Ich hatte/habe auch Probleme mit Chromium im Kiosk-Modus. Eben hat es (unter 32-bit Bookworm) geholfen --start-maximezed mit anzufügen.

    Auf der Kommandozeile:

    Code
    $ chromium-browser https://www.raspberrypi.com/documentation/computers/os.html#vcgencmd --kiosk --start-maximized

    :rolleyes: sudo !!

  • moin moin :)

    vielen Dank für Eure Unterstützung und Hilfe .. ich werde mir das Ganze nochmal in Ruhe anschauen. :conf:

    Was ich aber jetzt schon sagen kann ist, dass es unter Wayland zu den Problemen mit dem Autostart (in meiner definierten Form) kommt.

    Alle Hinweise laufen schlussendlich auf Fehler, entweder startet der Browser als Strich oder gar nicht. Fehlermeldungen konnte ich leider nicht lokalisieren.

    Zum Schluss war es so, dass der Browser nur die Überschrift der Webseite angezeigt hat, oben rechts drehte sich ein "Ladekreis" vom Chromium. Das wars...

    Ich habe dann einen Beitrag gelesen, dass jemand mit dem Autostart unter Wayland Probleme hatte. Und in einem Zwischensatz stand, dass wenn man auf X wieder umstellt man die

    /etc/xdg/lxsession/LXDE-pi/autostart verwenden kann.

    Kurzerhand habe ich auf X umgestellt, die autostart mit den benötigten Parametern gefüllt .. Neustart .. läuft. :bravo2:

    Ich hatte schonmal Probleme mit Wayland (aber in einem anderen Zusammenhang), konnte mich aber nicht mehr daran erinnern.

    Nun gut..., dass sich Software ändert ist ja nichts Neues, auch neue Parameter sind immer wieder was spannendes..


    Es stellt sich mir "nur" noch die Frage, ob die 32 oder die 64 bit Version des Betriebssystems besser ist. Aber ich habe das Ding jetzt schon sooft zurückgesetzt, da kommt es auf einmal mehr nicht mehr an.

    Also .. .vielen Dank an alle Beteiligten und Helfenden :bravo2: :)

  • Hallo so ähnlich sollte das funktionieren,Desktop Datei im Autostart Ordner. Oder Autostart mit rc.local

    Code
    chromium-browser "https://forum-raspberrypi.de/forum/" --kiosk --noerrdialogs --disable-infobars --no-first-run --ozone-platform=wayland --enable-features=OverlayScrollbar --start-maximized
  • Ich hatte das selbe Problem und entweder war es Desktop Datei in Autostart, oder rc.local jedenfalls ging es danach sowohl im neuen (Bookworm) als auch im alten.

    Oder war es crontab @Reboot

    Jedenfalls macht der Befehl so das ein Kiosk Modus kommt, da war man sich ja auch uneinig.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!