Performance Problem rasp 4 4Gb Bulleseye

  • Hallo,

    seit ein paar Wochen nutze ich meinen Pi jetzt immer über Remote-Desktop an meinem Laptop. Als OS ist Bullseye aufgespielt (siehe Bild ).

    Seit gestern habe ich extreme Performance Probleme. Es hat damit angefangen das ich mich nicht mehr mit meinem Standard Benutzer an XRDP anmelden konnte der Bildschirm blieb einfach Blau und es passierte nichts.

    Nach Recherche im Internet muss man wohl einen zweiten Nutzer anlegen um XRDP zu nutzen?? Stimmt das? Wieso ging es vorher nur mit einem Nutzer?

    Also zweiten Nutzer angelegt und schon geht XRDP wieder, leider bewegt sich die Maus in Zeitlupe alles was ich versuche zu öffnen dauert 30sec. und schreiben geht auch nur extrem langsam.

    Überhitzen ist eigentlich nicht möglich es sitzt ein großer Kühlkörper mit Lüfter drauf der über die Lüftersteuerung auf 60*C steht. (gemessene CPU temp.=53*C)

    Software habe ich mehrmals neu aufgespielt die SD Karte zwei mal getauscht.

    Keine Änderung immer noch gleich langsam wie vorher!

    Es ist außer das LAN Kabel zum Laptop und das Netzteil (65W Laptopnetzteil) nichts angeschlossen.

    Ist er doch überhitzt und dadurch irgendwelche Schäden entstanden?

    Kann man durch falsch anschließen an die GPIO´s so ein Problem hervorrufen (Wägezelle und ein Relais waren angeschlossen)?

    Hat jemand einen Tipp was ich tun kann?

    (Hab das Forum durchsucht aber nichts hilfreiches auf mein Problem gefunden.

    Ich hoffe das es nur ein Bedienerfehler ist und ich es nicht kaputt gemacht hab)

    MfG

    Niklas

  • Welcher RPi ist das? //Edit: Steht ja im Titel.

    Warum nutzt Du RDP statt VNC?

    Kann man durch falsch anschließen an die GPIO´s so ein Problem hervorrufen (Wägezelle und ein Relais waren angeschlossen)?

    War das vorher schon angeschlossen oder trat das Problem damit auf?

  • Offenbar gab es zwischenzeitlich ein Update, bzw. hast Du eins gemacht, denn das mit dem zweiten User für XRDP ist schon länger so.

    Hast Du die Möglichkeit mal einen Monitor anzuschließen um zu sehen, ob der RPi ansich so langsam geworden ist oder das ein RDP-Problem sein könnte, bei dem ein Delay in der Verbindung entsteht?

  • Warum nutzt Du RDP statt VNC?

    RDP ist schon bei Windows dabei und hat auch ganz gut funktioniert.

    VNC schaue ich mir mal an vielleicht ändert das was.


    Als erstes würde ich mit "htop" (in der Konsole) nachsehen, welche Prozesse die meiste CPU ziehen.
    Da sieht man dann auch, wie z.B. die Speicher-Nutzung ist.

    Da kann ich ehrlich gesagt nichts mit anfangen


    Offenbar gab es zwischenzeitlich ein Update, bzw. hast Du eins gemacht, denn das mit dem zweiten User für XRDP ist schon länger so.

    Hast Du die Möglichkeit mal einen Monitor anzuschließen um zu sehen, ob der RPi ansich so langsam geworden ist oder das ein RDP-Problem sein könnte, bei dem ein Delay in der Verbindung entsteht?

    Bewusst habe ich kein UPDATE gemacht.

    Kann man auf die Version zurück mit nur einem Benutzer? Wie komme ich auf die Version?


    SSH über Putty funktioniert interessanter weise ohne stocken oder ähnliches.

  • Offenbar gab es zwischenzeitlich ein Update, bzw. hast Du eins gemacht, denn das mit dem zweiten User für XRDP ist schon länger so.

    ....

    Das wäre mir neu.
    Ich nutze auch unter Bookworm XRDP und wüsste nicht, wozu man einen zweiten Nutzer braucht.

    ;) Gruß Outi :D
    Pis: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Rente) / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 (B. Lite) / 2x Pi Zero 1.3 (B. Lite) / 2x Pi Zero W 1.1 (B. Lite) / 1x Pi Zero 2 (mal so, mal so) / 1x Pi 3 B+ (Tests) / 1x Pi 4 B 4GB (BW Lite (Webserver)) / Pi 400 (BW) / 1x Pi 5 (BW) / 2x Pi Pico / 2x Pi Pico W
    Platinen: Sense HAT / HM-MOD-RPI-PCB / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT / Pi 5 Kühler HAT
    Kameras: orig. Raspberry Pi Camera Module V1 & V3 / PS3 Eye

  • Ich habe es erst vor wenigen Tagen komplett neu eingerichtet und komme nach wie vor mit dem normalen User (pi) rein ....

    ;) Gruß Outi :D
    Pis: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Rente) / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 (B. Lite) / 2x Pi Zero 1.3 (B. Lite) / 2x Pi Zero W 1.1 (B. Lite) / 1x Pi Zero 2 (mal so, mal so) / 1x Pi 3 B+ (Tests) / 1x Pi 4 B 4GB (BW Lite (Webserver)) / Pi 400 (BW) / 1x Pi 5 (BW) / 2x Pi Pico / 2x Pi Pico W
    Platinen: Sense HAT / HM-MOD-RPI-PCB / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT / Pi 5 Kühler HAT
    Kameras: orig. Raspberry Pi Camera Module V1 & V3 / PS3 Eye

  • Das wäre mir neu.
    Ich nutze auch unter Bookworm XRDP und wüsste nicht, wozu man einen zweiten Nutzer braucht.

    xrdp funktioniert auch hier unter Bookworm 64bit, habe ich erst auf Dein Posting hin probiert. Aber sowohl Chromium als auch Firefox werden nur völlig verzerrt angezeigt, da ist nichts lesbar. Dazu gab es auch schon Beiträge hier, bisher habe ich noch keine Lösung gesehen. Tritt das bei Dir nicht auf?

    Edit: per Suchmaschine auch dazu wieder Tips gesehen einen zweiten User anzulegen. Sonst hilft bei Chromium: chromium-browser --disable-gpu.

    :rolleyes: sudo !!

    Edited once, last by DistroEx (December 4, 2023 at 11:14 AM).

  • Also ich habe jetzt VNC installiert und damit hab ich keine Probleme mehr funktioniert viel besser als RDP.

    htop sieht absolut unauffällig aus, also sollte der RPi, bzw. das System stabil laufen, was uns zu RDP vs. VNC oder Deine Netzwerkanbindung bringt.

    Du schreibst oben in #1 von LAN, in htop sieht man aber, dass das WLAN aktiv ist.

    Ich hab das WLAN wieder ausgeschaltet, und gehe davon aus das RDP sich übers WLAN verbunden hatte und das die Übertragung nicht hinbekommen hat. Über nur LAN funktioniert jetzt alles auch RDP ist flüssig. (Trotzdem finde ich VNC besser)

    Danke für die Hilfe

  • xrdp funktioniert auch hier unter Bookworm 64bit, habe ich erst auf Dein Posting hin probiert. Aber sowohl Chromium als auch Firefox werden nur völlig verzerrt angezeigt, da ist nichts lesbar. Dazu gab es auch schon Beiträge hier, bisher habe ich noch keine Lösung gesehen. Tritt das bei Dir nicht auf?

    Hatte das gleiche Problem mit Bookworm. Einfach zurück auf Bulleseye. (Die neuste Verstehe ist nicht unbedingt die beste)

  • Also hier mal ein Weg ohne 2. User:

    Code
    sudo adduser xrdp ssl-cert

    Und danach noch:

    Code
    sudo nano /etc/X11/xrdp/xorg.conf

    Und in der Datei danach suchen und so abändern:

    Code
    Option "DRMDevice" ""

    Dann den Pi neu booten und Chromium funktioniert.

    Den FF habe ich nicht getestet, da ich den nicht nutze.

    ;) Gruß Outi :D
    Pis: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Rente) / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 (B. Lite) / 2x Pi Zero 1.3 (B. Lite) / 2x Pi Zero W 1.1 (B. Lite) / 1x Pi Zero 2 (mal so, mal so) / 1x Pi 3 B+ (Tests) / 1x Pi 4 B 4GB (BW Lite (Webserver)) / Pi 400 (BW) / 1x Pi 5 (BW) / 2x Pi Pico / 2x Pi Pico W
    Platinen: Sense HAT / HM-MOD-RPI-PCB / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT / Pi 5 Kühler HAT
    Kameras: orig. Raspberry Pi Camera Module V1 & V3 / PS3 Eye

  • Habe auch das firefox / chromium Problem der verpixelten Anzeige in Bookworm (64 Bit).

    Bei chromium hilf bei mir, wie bereits von DistroEx erwähnt der Aufruf aus einem Terminal:

    chromium-browser --disable-gpu

    Bei Firefox hat bei mir geholfen:

    Aufruf aus einem Terminal um an die Einstellungen von Firefox zu kommen: "firefox --safe-mode"

    Anschließend in den Einstellungen:

    kein Haken bei : "Performance" -> "Use recomendet performance settings..."

    und kein Haken bei : "Performance"-> "Use hardware acceleration when available"

    Danach lief Firefox bei mir im xrdp, optisch korrekt.

  • McDotter, spontan hätte ich gesagt Wayland, da ich den Pi gestern frisch aus Raspberry Pi OS (64-bit), A port of Debian Bookworm...,

    aufgesetzt habe.

    Nachgeprüft, kommt aber offensichtlich X11 raus:
    echo $XDG_SESSION_TYPE (im xrdp, Remotedesktop von Windows) liefert x11

    "loginctl show-session $(loginctl | grep $(whoami) | awk '{print $1}') -p Type" (im putty terminal) liefert zwei Sessions:

    Type=tty (das ist die putty session)

    Type=x11 (das ist die xrdp session)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!