Absturz bei HDMI

  • Hallo,

    Ich habe einen Raspi 4 mit Bookworm 32 Bit, ioBroker inkl Node Red laufen. Sobald ich einen HDMI Eingang belege, stürzt das System ab und ist nicht mehr erreichbar, auch nicht unter SSH. Auch wenn ich den HDMI Eingang vor dem Start belege und starte, startet er zwar kurz ist dann aber wieder abgestürzt.

    Netzteil ist mit 3 A. Auch schon mal getauscht.

    HDMI Kabel wurde auch getauscht.

    Rasp Pi 4 Model B Rev 1.1

    RAM 1GB

    Woran könnte dies liegen? Ist es ein Ressourcenproblem?

    Gruß, Johny

  • Ich möchte einen Stream über eine DoorBird auf einen Fernseher ausgeben, wenn es klingelt. Mit einem Raspi 3 hat es super funktioniert. Jetzt habe ich jedoch ioBroker installiert und alle paar Tage keinen Zugriff mehr auf den Raspi gehabt, so dass ich auf einen Raspi 4 umgestiegen bin. Nun habe ich das Problem mit dem HDMI Ausgang. Hoffe ein neues Netzteil wird es beheben.

  • Pfff! :conf:

    Da scheint irgendetwas an dem RPi 4 mächtig im Argen zu sein. Normal ist das jedenfalls nicht.

    Auch das Verhalten des RPi 3, das Du alle paar Tage keinen Zugriff mehr darauf hast ist seltsam und sollte ggf. in einem anderen Thema mal angefragt werden, wobei ioBroker dann auch schon wieder ziemlich "speziell" sei könnte.

  • Da du deinen Thread noch nicht auf gelöst gestellt hast, ne Anmerkung zum Anschließen von HDMI-Devices im laufenden Betrieb:

    Es gibt hotplug-fähige und -unfähige Monitore. Ersteres kannst du im laufenden Betrieb unter Strom vielleicht anschließen, ohne dass es zu Störungen kommt, letztere sollte man nur im stromlosen Zustand anschließen.

    Und da du Probleme hattest, lautet die generelle Empfehlung an Laien (=> so ein IT'ler zu mir):

    "Wenn man schon einen Monitor an einen laufenden PC(/Raspi) anschließt, ist der Monitor vorher vom Strom getrennt (Schalter aus & Stecker raus) und dann wird zuerst die Verbindung zum PC(/Raspi) hergestellt, danach der Monitor an den Strom angeschlossen und zuletzt der Monitor angeschaltet.

    Bei hotplugfähigen Monitoren kann man das auch anders machen, aber wenn was schief geht, ist man selber schuld.

    Leider ist das Grillen von Raspi's zum Volkssport geworden."

    Der IT'ler trug ein T-Shirt mit der Aufschrift: "So viele Idioten und nur eine Sense"

    Diese prägende Anekdote musste ich mal loswerden...

    ---

    Kein Backup? Kein Mitleid :evil:
    [we all live in a yellow subroutine...]

  • Danke für die Anekdote. Es war nur so, dass das Problem auftrat, auch wenn nur das HDMI Kabel an den Raspi angeschlossen wurde und am andern Ende gar nichts dran hing, und das sowohl im stromlosen als auch im angeschalteten Modus des Raspi. Es lag wohl am Betriebssystem.

  • in diversen Konstellationen hab ich erfahren müssen, dass wenn erst mal ein OS abgeschossen wurde und ich dann noch weiter mit dem gearbeitet habe (weil es eben nicht offensichtlich war, dass das OS davon nen Schlag ab hatte), sich unerwartete Fehler einschleichen und dann in bizarre Probleme enden.

    In deinem Fall wäre die fast schon OT-Frage (mehr aus Neugierde - schließlich läuft dein System ja mittlerweile :thumbup: ) ob die Probleme mit Kabel, aber ohne Device erst im Laufe der Zeit auftraten?

    ---

    Kein Backup? Kein Mitleid :evil:
    [we all live in a yellow subroutine...]

  • Die Probleme traten sofort nach Umstieg auf einen Raspi 4 auf, von einem Raspi 3. in diesem Zuge war ich von bullseye auf bookworm gewechselt. Jetzt habe ich einfach die SD-Karte des Raspi 3 in den Raspi 4 gesteckt und es ging.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!