LCD Display zeigt den Backslash nicht an

  • Hallo zusammen,

    ich möchte auf dem LCD 1602, angeschlossen per I2C, einen Backslash anzeigen und rufe dazu die Funktion lcd.putstr('\\') auf.

    Es wird aber kein Backslash, sondern das Zeichen ¥ dargestellt. Sieht jedenfalls so ähnlich aus.

    Hat irgend jemand eine Idee, wie ich das hinbekomme?

    Vielen Dank für eure Unterstützung.

    Viele Grüße, Rainer

  • Moin rte_2806,

    oha, seit 2012 Mitglied im Forum und nun der erste Post!!
    Egal: Willkommen im Forum!

    Also, der "/" ist Teil des Zeichensatzes eine LCD 1602. Und zwar 0010 1111. Du must nun den entsprechenden Code erzeugen.

    73 de Bernd

    Alles Falsch. Wer lesen kann ist im Vorteil

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"
    Vielleicht trifft man sich in der RPi-Plauderecke.
    Linux ist zum Lernen da, je mehr man lernt um so besser versteht man es.

    Edited once, last by Bernd666 (February 9, 2024 at 11:04 PM).

  • Moinsen,

    Also, der "/" ist Teil des Zeichensatzes eine LCD 1602.

    Würdest du bitte deine Aussage mit dem Titelthema vergleichen. Danke
    Der TO sprach von einem "Backslash" und keinem einfachen "Slash".
    Dieser muss manuell in den freien Speicherbereich der frei Programmierbaren Sonderzeichen erst geschrieben werden, damit er mit einer Adress-Nummer ( Zuordnung ähnlich des ASCII Zeichensatzes ) mittels chr() aufgerufen werden kann um als CHAR in einen String eingebunden zu werden.

    Franky

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!