HDMI Hotplug - /boot/config.txt nicht mehr aktuell auf Bookworm

  • Hallo

    Ich habe einen neuen Raspberry Pi 5 (mit 8 GB RAM), da hab ich natürlich Bookworm (Debian 12) drauf gespielt und hatte mich gewundert, dass der Monitor scheinbar nicht ging.
    Tatsächlich muss der Rasp vorher an sein, also bevor ein aktiver HDMI Ausgang angeschlossen wird, habe ich gelesen. Man könne das aber umstellen, indem man in die /boot/config.txt reinschriebe:
    hdmi_force_hotplug=1

    Allein, die Datei enthält eine Warnung:

    The file you are looking for has moved to /boot/firmware/config.txt

    Dort bin ich etwas unsicher, etwas dazu zu schreiben, kommt das überhaupt dort rein? Dann unter Sektion [all]?

    Oder wie macht man es in Bookworm, dass man den HDMI Ausgang hotplug-fähig macht?
    Danke.

    Gruß franc

    PS.: noch eine kleine Zusatzfrage, die mit dem Thema nur am Rande zu tun hat: läuft Kodi auf Bookworm (64-Bit) auf dem Rasp5 gar nicht? Ich hatte es insterliert, aber es startet einfach nicht.

    Raspberry Pi 3 B Plus mit Buster im Heimnetz als Pi-Hole, Raspberry Pi 5 (8 GB) mit Bookworm für Medien (ab Feb. 24 löst der den Sony SVF1421A4E mit W10 Pro ab).

  • HDMI Hotplug - /boot/config.txt nicht mehr aktuell auf Bookworm? Schau mal ob du hier fündig wirst!


  • Tatsächlich muss der Rasp vorher an sein, also bevor ein aktiver HDMI Ausgang angeschlossen wird, habe ich gelesen. Man könne das aber umstellen, indem man in die /boot/config.txt reinschriebe:
    hdmi_force_hotplug=1

    Ich habe in der RaspberryPi Dokumentation gelesen, dass es am Pi 5, bzw. Bookworm, hdmi_force_hotplug nicht mehr gibt. Die legacy config.txt options gelten für alle OS, ausser Bookworm.

    Raspberry Pi Documentation - Computers
    The official documentation for Raspberry Pi computers and microcontrollers
    www.raspberrypi.com


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Das, was Dir die Datei anzeigt, ist korrekt.
    Mach Deine Einträge halt dort, wohin Dich die Info hinschickt.

    Ob das Dein Problem löst, kann ich nicht sagen, ich nutze den Pi nur headless.

    ;) Gruß Outi :D
    Pis: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Rente) / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 (B. Lite) / 2x Pi Zero 1.3 (B. Lite) / 2x Pi Zero W 1.1 (B. Lite) / 1x Pi Zero 2 (mal so, mal so) / 1x Pi 3 B+ (Tests) / 1x Pi 4 B 4GB (BW Lite (Webserver)) / Pi 400 (BW) / 1x Pi 5 (BW) / 2x Pi Pico / 2x Pi Pico W
    Platinen: Sense HAT / HM-MOD-RPI-PCB / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT / Pi 5 Kühler HAT
    Kameras: orig. Raspberry Pi Camera Module V1 & V3 / PS3 Eye

  • Tatsächlich, das bringt in /boot/firmware/config.txt gar nichts. Ich muss den Rasp5 ganz vom Strom nehmen, nachdem ich den Beamer anschalte, wo der Rasp5 dran hängt, damit der er was anzeigt. Ich will den aber als Medien-PC nehmen, das wäre dann allerdings nicht sehr geschmeidig.

    Ist der zu neu, dass man dazu eine Lösung dafür findet? Die Suche danach verweist ja immer auf die alte config und nie auf einen 5 oder Bookworm, oder auf die selbe ungelöste Frage.

    Raspberry Pi 3 B Plus mit Buster im Heimnetz als Pi-Hole, Raspberry Pi 5 (8 GB) mit Bookworm für Medien (ab Feb. 24 löst der den Sony SVF1421A4E mit W10 Pro ab).

  • Tja, mit bookworm und dem RPi5 sind gefühlt so viele unkompatible Änderungen gekommen wie nie zuvor! Leider ist auch die Videoausgabe über HDMI ein großes Thema darunter. Auffällig ist, dass auch in dem oben verlinkten Thread im englischen RPi-Forum keine Lösung angeboten werden kann.

    Tut mir leid, dass ich Dir keine bessere Info liefern kann.

  • Besteht denn Hoffnung, dass das eines Tages, nicht allzu viel später, noch rund wird?
    Ansonsten wäre es ja vielleicht klüger einfach neu zu machen und dann auf Deb 11 (aka Bullseye) zu setzen.

    Dann würd ich die MicroSD einfach wechseln, neue 64er rein mit Raspbian Bully drauf...

    Raspberry Pi 3 B Plus mit Buster im Heimnetz als Pi-Hole, Raspberry Pi 5 (8 GB) mit Bookworm für Medien (ab Feb. 24 löst der den Sony SVF1421A4E mit W10 Pro ab).

  • Bis einschließlich RPi4 ist das Vorgängerrelease RaspiOS Buster wohl durchaus eine Möglichkeit. Ich weiß aber nicht, ob der RPi5 damit booten kann, denn ich meine gehört zu haben, dass der erst mit Bookworm arbeitet...

    Am besten einfach mal ausprobieren.

  • Ich mache jetzt mit dem rpi-imager Ubuntu Desktop 23 drauf, das wird angeboten. Ubuntu habe ich auch auf dem PC und auf meinem Server (dort ohne Desktop).

    Buster habe ich auf meinem alten Rasp3B+, da habe ich keine Probleme, aber das ist ja schon älter.

    Raspberry Pi 3 B Plus mit Buster im Heimnetz als Pi-Hole, Raspberry Pi 5 (8 GB) mit Bookworm für Medien (ab Feb. 24 löst der den Sony SVF1421A4E mit W10 Pro ab).

  • Der RPi 5 läuft erst ab Debian 12 (Bookworm).

    Ich habe gerade an meinem Standard-Installations-(Desktop 64Bit Bookworm) RPi 5 erst nach dem Hochfahren des Raspi den HDMI-Monitor eingestöpselt.
    Das hat problemlos funktioniert, es wird der Desktop angezeigt.
    Also ist "Hotplug" wohl standardmäßig aktiv (und es gibt evtl. deshalb keine Config-Option mehr dafür).

    Tatsächlich muss der Rasp vorher an sein, also bevor ein aktiver HDMI Ausgang angeschlossen wird, habe ich gelesen.

    Soweit ich weiß, war es genau umgekehrt!

  • Soweit ich weiß, war es genau umgekehrt!

    stimmt!

  • Der RPi 5 läuft erst ab Debian 12 (Bookworm).

    Ich habe gerade an meinem Standard-Installations-(Desktop 64Bit Bookworm) RPi 5 erst nach dem Hochfahren des Raspi den HDMI-Monitor eingestöpselt.
    Das hat problemlos funktioniert, es wird der Desktop angezeigt.
    Also ist "Hotplug" wohl standardmäßig aktiv (und es gibt evtl. deshalb keine Config-Option mehr dafür).

    Soweit ich weiß, war es genau umgekehrt!

    Stimmt natürlich, habe ich verwechselt.
    Ja, der Rasp braucht (ohne Hotplug) einen angeschlossenen Monitor wenn man ihn hochfährt, klar.
    Aber das Hotplug hatte bei mir bei Bookworm definitiv nicht funktioniert. Der Beamer ist über einen 3er Verteiler angeschlossen. Schalte ich den Beamer an, Rasp5 lauft schon, kommt kein Bild. Deswegen ja überhaupt dieser Thread.

    Also jetzt habe ich auf eine andere SD das Ubuntu 23.10 drauf (mit dem von apt installierten rpi-imager, Version 1.7.2) und habe den Nachmittag lang damit gekämpft, eine Fernsteuerung drauf zu kriegen, also RDP oder VNC.
    Ich hab schließlich das ein eingebaute RDP (in den Einstellungen > Freigaben) genommen, xrdp ging nicht und tightvnc hab ich auf die Schnelle auch nicht zum Laufen gekriegt, nicht mal RealVNC (der Installer wurde nicht erkannt).
    Schließlich habe ich auch festgestellt, dass ich überhaupt nur mit RDP drauf komme, wenn der Beamer an ist (also der HDMI Ausgang aktiv angeschlossen).
    Aber das findet man auch anderswo: Headless Ubuntu 23.10 on Raspberry Pi 5
    Das ist beim Rasbian Stretch anders. Jedenfalls damit habe ich kein HDMI Problem, da kann ich den Beamer an machen, R5 lauft längst, Bild kommt.

    Der Rasp5 Prozessor wird übrigens auf Ubuntu ständig gekühlt, also der Ventilator lauft dauerhaft. Das war bei Bookworm nicht so. EDIT: wohl nur wenn die Ausgabe aktiv ist. Im Moment bin ich per ssh drauf, da macht er keinen Lüfter an.

    Also bisher noch einiges nicht optimal mit dem R5.

    Raspberry Pi 3 B Plus mit Buster im Heimnetz als Pi-Hole, Raspberry Pi 5 (8 GB) mit Bookworm für Medien (ab Feb. 24 löst der den Sony SVF1421A4E mit W10 Pro ab).

    Edited 3 times, last by franc (February 13, 2024 at 10:48 AM).

  • Richtig, natürlich bis Bullseye. Fängt alles mit B an, da kann man schon durcheinander kommen...

  • Hallo franc,

    da du Ubuntu 23.10 auf dem Raspi 5 verwendest, sollte bei dir der Displayserver Wayland laufen, und mit dem kommst du derzeit per Fernzugriff nur mittels TigerVNC auf den RPi5.
    Dazu wurde hier im Forum schon ein paar Zeilen geschrieben, also lohnt es sich, da etwas zu stöbern ;)

    Wenn du den Displayserver auf X11 umstellst (was all die Jahre der Standard war), funktionieren viele "lieb gewonnene" Anleitungen aus dem Netz, auch die EInstellungen für die Auflösung mit Headless.

    ---

    Kein Backup? Kein Mitleid :evil:
    [we all live in a yellow subroutine...]

  • Ah, danke! Das hab ich bei meinem U22 (das ich vor einem halben Jahr eingerichtet hatte, da war das Wayland auch schon im Weg) ja auch längst umgestellt, ebenso längst wieder vergessen :)

    In: /etc/gdm3/custom.conf

    Das entkommentiert, also Wayland nicht aktivieren:

    WaylandEnable=false

    Raspberry Pi 3 B Plus mit Buster im Heimnetz als Pi-Hole, Raspberry Pi 5 (8 GB) mit Bookworm für Medien (ab Feb. 24 löst der den Sony SVF1421A4E mit W10 Pro ab).

  • Und jetzt bin ich doch wieder auf Bookworm :(

    Das U23 ist nicht mehr hoch gefahren. Beim Starten (was mühsam zu sehen war, weil ich dann extra einen Monitor anschließen muss oder den Beamer anwerfen und die Leinwand runter) blieb es gleich hängen mit so einer Nachricht:

    Aber da hat sich dann auch nichts geändert, hat nur geflackert im Sekundentakt, ohne dass was hoch gezählt würde o.ä.

    Das war vorher schon mal, dann ging es aber immer wieder wenn man Strom raus und dran gemacht hatte. Jetzt nicht mehr.
    Hab die MicroSD schon geprüft (mit badblocks, zwar nur die ersten 10%) aber keinen Fehler gefunden. Schicksal.
    Also jetzt doch wieder Bookworm.

    Raspberry Pi 3 B Plus mit Buster im Heimnetz als Pi-Hole, Raspberry Pi 5 (8 GB) mit Bookworm für Medien (ab Feb. 24 löst der den Sony SVF1421A4E mit W10 Pro ab).

  • Sonderbar. Seit ich wieder zurück auf Bookworm bin geht das Hotplug anscheinend. Also Rasp5 lauft dauerhaft, ich schalte der Beamer ein und das Bild ist da.
    VNC und RDP gehen auch, wenn man von dem RDP Bug (Firefox and Chromium not working via xrdp) absieht. VNC geht einmal über TigerVNC (auf 5901, Anleitung vom Ubuntu Wiki) und einmal über den WayVNC auf 5900 (aber nur mit dem RealVNC Viewer, wegen der Verschlüsselung sei das).

    Vielleicht hat das laufende VNC ja mit dem plötzlich funktionierenden HDMI-Hotplug zu tun, also weil dauerhaft ein Display läuft, zwar nur virtuell. Keine Ahnung. Aber VNC/RDP hatte ich unbedingt gebraucht, das war viel zu unbequem die Sachen an einem extra Monitor (den ich immer wieder aufbauen musste) einzurichten, die auch den Desktop brauchten (also was nicht über SSH ging).

    EDIT: leider geht es doch nicht. Ich habe mich getäuscht bzw weiß nicht warum es davor ging. Jetzt jedenfalls nicht mehr. Schalte ich den Beamer an, kommt kein Bild, erst wenn ich den rasp5 neu starte und den Beamer angeschlossen lasse. Zudem bin ich mit dem Sound (mit BT-Adapter) auch noch nicht glücklich, siehe: Sound über Bluetooth - lautes Knacksen wenn Beamer angeschlossen ist.

    Raspberry Pi 3 B Plus mit Buster im Heimnetz als Pi-Hole, Raspberry Pi 5 (8 GB) mit Bookworm für Medien (ab Feb. 24 löst der den Sony SVF1421A4E mit W10 Pro ab).

    Edited 3 times, last by franc (February 19, 2024 at 11:02 AM).

  • Hat jemand eine Idee, wie ich sozusagen nur das HDMI neu boote? Damit ich den Beamer nutzen kann, ohne den Rasp5 neu starten zu müssen?

    Ich würde nämlich gerne den Rasp5 auch gelegentlich als Downloader benutzen (habe JDownloader2 installiert dafür) und das ist dann etwas ungünstig, wenn ich, um Film über den Beamer schauen zu können, jedes Mal rebooten muss, was dann Downloads killt (dann starten sie nämlich wieder komplett neu, selten klappt Download-Wiederaufnahme).

    Besteht vielleicht Hoffnung, dass das scheints noch etwas unausgegorene Raspbian Bookworm da per Update HDMI-Hotplug zuverlässig repariert?

    Raspberry Pi 3 B Plus mit Buster im Heimnetz als Pi-Hole, Raspberry Pi 5 (8 GB) mit Bookworm für Medien (ab Feb. 24 löst der den Sony SVF1421A4E mit W10 Pro ab).

  • Hat jemand eine Idee, wie ich sozusagen nur das HDMI neu boote?

    Versuchs mal mit

    Code
    WAYLAND_DISPLAY="wayland-1" wlr-randr --output HDMI-A-1 --off
    # bzw.
    WAYLAND_DISPLAY="wayland-1" wlr-randr --output HDMI-A-1 --on

    Das HDMI-A-1 ist natürlich abhängig, an welchem der beiden HDMI-Ports der Beamer hängt.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!