FreeCAD exportiert die Datei nicht ins STL Format (ink Prusa Installation)

  • Beim RPi4B unter Bookworm brauche ich kein Passwort.
    Auf meinem AMD64 allerdings schon.

    Ist wohl von Distri zu Distri unterschiedlich.

    Sorry das der Unterstrich da reingerutscht ist, habe ich oben korrigiert.

    Kannst Du mal den Befehl df -h in die Konsole eingeben und hier das Ergebnis mitteilen?

    MfG

    Jürgen

  • FreeCAD exportiert die Datei nicht ins STL Format (ink Prusa Installation)? Schau mal ob du hier fündig wirst!

  • Guten Morgen

    Code
    Dateisystem    Größe Benutzt Verf. Verw% Eingehängt auf
    udev            3,6G       0  3,6G    0% /dev
    tmpfs           782M    1,4M  780M    1% /run
    /dev/mmcblk0p2  117G     20G   91G   19% /
    tmpfs           3,9G    420K  3,9G    1% /dev/shm
    tmpfs           5,0M     16K  5,0M    1% /run/lock
    /dev/mmcblk0p1  510M     73M  438M   15% /boot/firmware
    tmpfs           782M     44K  782M    1% /run/user/1000

    MFG

  • Update:

    hab mir auf eine andere SD Karte ein Image erstellt mit Raspbian OS (bookworm). Mit dieser konnte ich die Appimager Datei von FreeCad nicht ausführen und keinen Screenshot machen.

    hab auf die nächste SD Karte mit dem Imager das Rasbian Bullseye installiert. Da konnte ich dann wie oben von Jürgen Böhm beschrieben die Appimage kopieren, ausführbar machen und mit der App "Ausführen" starten.

    Bei mir läuft jetzt FreeCad 0.21.2 mit dem kann ich jetzt auch STL Dateien exportieren.

    Warum ich noch immer keine Screenshots machen kann ist ja eine andere Geschichte...


    Bernd666 muss ich noch irgendwas ergänzen?


    MFG iL Lupo

  • hab auf die nächste SD Karte mit dem Imager das Rasbian Bullseye installiert

    Merkwürdig, bei mir läuft das auf einem RPi5 unter Bookworm64.
    Ich habe jetzt mal meine Anweisungen nachvollzogen, es geht einwandfrei.

    Der einzigste Unterschied ist, das ich das Remote (ssh -X User@raspi) gemacht habe,
    da ich noch keinen großen Bildschirm am RPi5 habe.

    Und ließ sich auch so speichern:

    MfG

    Jürgen

  • Moin!

    So, habe heute mal eine Raspberry Pi OS bookworm with Desktop (64bit) auf einem Stick gebaut. Von der Webseite das FreeCAD-0.21.2-Linux-aarch64.AppImage geladen. Kopiert und die Rechte angepasst. Sieht nun so aus:

    sudo ls -l /usr/local/bin/FreeCAD-0.21.2-Linux-aarch64.AppImage 
    -rwxr-xr-x 1 root root 774738304 12. Mär 22:03 /usr/local/bin/FreeCAD-0.21.2-Linux-aarch64.AppImage

    Beim ersten Start gabe es eine Meldung, das FUSE vermisst wird. Ein sudo apt install fuse hat das Problem beseitigt.
    Es kommt noch eine Fehlermeldung bezüglich wayland, aber es funkt alles.

    Nun geht Alles!! Unter Bookworm!!
    Das Ganze auf einem Raspberry Pi 4 Model B Rev 1.4 mit 2GB Speicher.

    Bernd666 muss ich noch irgendwas ergänzen?

    Noe, wenn es für dich OK ist?!?.

    Danke für deine Lösung.

    Achja, bitte, als erledigt markieren. Geht oben bei "Thema bearbeiten"

    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"
    Vielleicht trifft man sich in der RPi-Plauderecke.
    Linux ist zum Lernen da, je mehr man lernt um so besser versteht man es.

  • Beim ersten Start gabe es eine Meldung, das FUSE vermisst wird. Ein sudo apt install fuse hat das Problem beseitigt.

    Fuse musste ich nicht installieren. Merkwürdig.

    MfG

    Jürgen

    Edit: Nicht mehr merkwürdig: https://wiki.ubuntuusers.de/FUSE/ -> Konfiguration

  • Moin Jürgen Böhm,

    ich habe die kleinere Version von den beiden Desktop-Versionen genommen.

    Und da fehlte es.
    Achja, natürlich habe ich das System aktualisiert. Waren nur 250 Änderungen..

    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"
    Vielleicht trifft man sich in der RPi-Plauderecke.
    Linux ist zum Lernen da, je mehr man lernt um so besser versteht man es.

  • ich habe die kleinere Version von den beiden Desktop-Versionen genommen.

    Bei mir wars "Lite" mit nachträglich installierten Mate.

    Code
    fuse/stable 2.9.9-6+b1 arm64
      Filesystem in Userspace

    Und es ist nicht installiert.

    Aber damit sind wir hier ein kleines bißchen OT.

    MfG

    Jürgen

  • Jürgen Böhm Bei bookworm64 war ich nicht im Stande die appimage von der 0.21.2 Version von FreeCad zu starten. Mit der secure shell hab ich mich noch nicht auseinandergesetzt.

    wird mit sudo chmod 0755 das gleiche erzielt wie bei Eigenschaften der Datei, Berechtigungen Ausführen Jeder ?

    Bernd666 Moin! Ich werde deine Lösung für Bookworm64 morgen testen und dann berichten. Hoffentlich brennt bei mir morgen die Fuse nicht durch! 8o

    MFG iL Lupo

  • Update: Bei dem Image mit Bullseye konnte ich FreeCad 0.21.2 installieren aber die Programme (zB Cura und Prusa Slicer) im Paketmanager sind veraltet.


    Bei Bookworm habe ich die Datei nach /usr/local/bin/ kopiert und in der Konsole sudo chmod 0755 /usr/local/bin/FreeCAD-0.21.2-Linux-aarch64.AppImage eingegeben, und dann sowie von Bernd666 beschrieben, die Befehle

    sudo ls -l /usr/local/bin/FreeCAD-0.21.2-Linux-aarch64.AppImage

    -rwxr-xr-x 1 root root 774738304 12. Mär 22:03 /usr/local/bin/FreeCAD-0.21.2-Linux-aarch64.AppImage

    sudo apt install fuse

    Über "Ausführen" starte ich dann FreeCAD-0.21.2-Linux-aarch64.AppImage

    Jetzt kann ich die STL Dateien erstellen und Cura erzeugt mir einen schönen GCode. :love:

    Bei Prusa gibt es noch Probleme wegen der Ländereinstellung aber das ist eine andere Baustelle.


    Danke Bernd666 und Jürgen Böhm für eure Hilfe!!!


    MFG iL Lupo

  • Bei dem Image mit Bullseye konnte ich FreeCad 0.21.2 installieren aber die Programme (zB Cura und Prusa Slicer) im Paketmanager sind veraltet.

    Release PrusaSlicer-2.7.2 ARM AppImages · davidk/PrusaSlicer-ARM.AppImage
    Prusa Research has released their own AppImages for ARM. It is advisable to switch to these official builds for the best experience when/if available for your…
    github.com

    MfG

    Jürgen

  • Gerade getestet, läuft nicht, Sorry.

    Läuft doch, hatte aus einem anderen Grund nicht funktioniert.

    Tja, wenn da die Meldung:

    nicht wäre. Aufrufen kann man den Slicer, aber das Fenster mit dem Bauteil bleibt weiss.

    MfG

    Jürgen

  • Moin il_Lupo,

    freut mich das es geklappt hat. Danke auch für deine Rückmeldung!

    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"
    Vielleicht trifft man sich in der RPi-Plauderecke.
    Linux ist zum Lernen da, je mehr man lernt um so besser versteht man es.

  • Hallo. Jürgen Böhm Mit welcher Version von PrusaSlicer hast du auf deinem RPi4B gearbeitet?

    Gerade die 2.7.1 auf Bullseye64 installiert.
    Scheint zu laufen.

    Die 2.7.2 zeigt nur ein leeres Fenster für die Bauteile.
    Den SSL-Fehler hatte ich mit der 2.7.2 auch, auch die Meldung der fehlenden OpGL-Libs.

    MfG

    Jürgen

    Edit: Es ist nicht Buster, sondern Bullseye

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!