Seltsames Verhalten nach Umstieg von WLAN auf Kabel

  • Hallo zusammen,

    irgendwie verhält sich mein Raspi 4 komisch. Ich habe einen Cups installiert, der als Print Server dient. Da am Aufstellort die WLAN Abdeckung etwas schlecht ist, hab ich den Raspi mit Kabel angebunden. Mehr hat sich nicht geändert.

    Nun kann ich von einen PC aus, den Raspi noch pingen und auch ausdrucken, vom Raspi aus komme ich aber nicht mehr ins Netz. Ich kann weder das Internet, noch etwas anderes im LAN erreichen. Ich habe ein einfaches Layher 2 Netz, ohne VLANs oder ähnliches. Der Raspi bekommt seine IP/DNS/Gateway per DHCP. DHCP scheint auch zu funktionieren. Ich habe dem Raspi auch mal eine statische IP gegeben. Das Fehlerbild bleibt aber gleich.

    Der Cups ist mit einem Powerline Adapter angebunden. Könnte das damit zu tun haben? Wobei die Verbindung hier stabil ist.

    Ich kann den Cups auch nicht mehr via AirPrint vom Handy aus erreichen. Sobald ich das Kabel abziehe und auf WLAN umstelle, geht es wieder wie vorher. Die Netzabindung ist zwar schlecht, die Funktionen gehen aber grundsätzlich.

    Bin ein wenig mit meinem Latein am Ende.

  • Seltsames Verhalten nach Umstieg von WLAN auf Kabel? Schau mal ob du hier fündig wirst!

  • Hatte ich geschaut. Ich habe DHCP seitig die MAC des WLAN Adapters geändert auf die MAC des LAN Anschlusses.

    Dieser bekommt auch alle Parameter (IP/DNS/Gateway) richtig zugewiesen. Auf dem DHCP habe ich auch vorher die aktiven Leases für diese IP gelöscht.

    Ich kann aber nicht mal den DHCP Server pingen, von dem ich vorher die IP bekommen habe. Übrigens auch nicht, wenn ich die IP feste vergebe. Einen IP Adresskonflikt habe ich habe nicht. Ich habe den Raspi auch mal neu gestartet, um den ARP Cache zu löschen.

  • Quote

    Nun kann ich von einen PC aus, den Raspi noch pingen und auch ausdrucken

    ok, Ethernet funktioniert

    Quote

    vom Raspi aus komme ich aber nicht mehr ins Netz.

    Wie sieht den die Defaultroute aus? Ist WLan deaktiviert oder läuft das noch?

    Quote

    Der Raspi bekommt seine IP/DNS/Gateway per DHCP. DHCP scheint auch zu funktionieren.

    Scheint ist ein bischen ungenau.

    Quote

    Der Cups ist mit einem Powerline Adapter angebunden. Könnte das damit zu tun haben?

    Du meinst damit, daß der Pi, auf dem CUPS läuft, per Powerline Adapter angebunden ist, oder? Von den Dingern habe ich keine Ahnung - da spielt mir zuviel der Elektriker rein.

    Quote

    Ich kann den Cups auch nicht mehr via AirPrint vom Handy aus erreichen. Sobald ich das Kabel abziehe und auf WLAN umstelle, geht es wieder wie vorher.

    Ein Zeichen, daß das mit DHCPd nicht klappt. Scheint zumindest so. ;) Sonst würde ja zum CUPS geroutet werden.

    Wenn Du drucken kannst, kannst Du Dich doch sicherlich mit ssh einloggen. Einfach mal im Betrieb die Netzwerkgeräte, Routen, etc. checken. Evtl. bekommst Du von CUPS ein paar Informationen. Aber wie das geht, habe ich vergessen.

  • Dieser bekommt auch alle Parameter (IP/DNS/Gateway) richtig zugewiesen.

    Poste mal nur mit Lan (ohne Wlan) und nur mit Wlan, die Ausgaben von:

    Code
    ip a
    ip r
    ip n s
    ip r g 1.1.1.1

    EDIT:

    In Linux gibt es "bonded interfaces" nur für Lan-devices.
    In OpenBSD kann man auch Lan und Wlan benutzen:

    Code
    trunk: trunkproto failover
    		urtwn0 port active
    		re0 port master

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden
    "Das dauert plötzlich ½ Sekunde länger. Das muss ich mir anschauen!" - Andres Freund

    Meine PIs

    PI4B/8GB (border device) OpenBSD 7.5 (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, Mumble-Server

    PI3B+ FreeBSD 14.0-R-p6 (arm64): SSH-Serv., WireGuard-Serv., ircd-hybrid-Serv., Mumble-Serv., ddclient

    PI4B/4GB Bullseye-lite (64bit; modifiziert): SSH-Server, WireGuard-Server, ircd-hybrid-Server, Mumble-Server, botamusique, ample

    Edited 2 times, last by rpi444 (March 25, 2024 at 11:08 PM).

  • Ich habe hier eine WLAN-Bridge eingerichtet:

    Derzeit arbeitet der RPi nur als Bridge, aber der könnte auch noch andere Aufgaben übernehmen.

    MfG

    Jürgen

  • Hatte ich geschaut. Ich habe DHCP seitig die MAC des WLAN Adapters geändert auf die MAC des LAN Anschlusses.

    ....

    Vermutlich sieht Dein Router die MAC jetzt 2x ....

    ;) Gruß Outi :D
    Pis: 2x Pi B, 1x Pi B+, 1x Pi 2 B in Rente / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 / 2x Pi Zero 1.3 / 2x Pi Zero W 1.1 / 1x Pi Zero 2 (BW+CUPS/SANE) / 1x Pi 3 B+ (Tests) / 1x Pi 4 B 4GB (Tests) / Pi 400 (BW) / 1x Pi 5 (BW) / 2x Pi Pico / 2x Pi Pico W
    HATs: Sense HAT / HM-MOD-RPI-PCB / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT / Pi 5 Kühler HAT / Pimoroni NVMe BASE
    Cams: orig. Raspberry Pi Camera Module V1 & V3 / PS3 Eye

  • Wenn man irgendwas mit Powerline macht, und es gibt Probleme - na dann ist doch klar, dass das Powerline nicht (durchgehend) funktioniert. Und falls man meinst, Powerline hat mal funktioniert, aks es eingerichtet wurde: "auch ein blindes Huhn trinkt mal ein Korn".

    warum?
    Läuft im Stromnetz ein starker Verbraucher, stört der so sehr, dass Powerline einbricht. Geht die Verbindung über ne Sicherung, ist auch "Ende Gelände" - seit die Spez. für Powerline geändert (die Leistung gedrossekt) wurde.

    Ein Beleg dafür: mit WLan ("schlechte Abdeckung") geht's.

    Ein weiterer: Raspi bekommt hin und wieder rudimentäre Kommunikation hin, die vorgaugelt, es ginge - und dann geht es doch nicht...

    Meine Erfahrung & Fazit: Powerline ist in vielen Fällen mehr eine moderne Art von Glücksspiel geworden. Von der Idee her großartig, aber in der Praxis allein vom elektrischen Aufbau vor Ort abhängig. Wenn es Probleme gibt: Finger weg!

    Quote

    Der Cups ist mit einem Powerline Adapter angebunden. Könnte das damit zu tun haben? Wobei die Verbindung hier stabil ist.

    ---

    Alles ist relativ - ob in dieser oder deiner Welt

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!