7 Zoll Raspberry Pi Display flackert mit Bookworm

  • Hallo zusammen,

    ich habe echt viele Versuche hinter mir, aber bekomme das 7 Zoll Display mit Bookworm einfach nicht zum laufen. Mit Bullseye klappt alles hervorragend, somit kann ich einen Hardware defekt ausschließen. Wenn ich einen zusätzlichen Monitor anschließe funktioniert es auch, nur alleine ohne zusätzlichem Monitor sieht das Bild unscharf aus und es Flackert.

    Ich habe 32bit und 64 bit versucht, keine Änderung des Problems, in der cmdline.txt mal die video angaben eingetragen (video=DSI-1:800x480@60D) leider ohne Erfolg.

    sudo apt update -----> alles auf neuestem Stand

    Vielleicht kann mir ja einer von euch einen Tipp geben was ich noch versuchen kann. Jetzt hab ich schon extra das "Original" gekauft um Probleme zu umgehen...


    Hier meine Hardware

    Raspberry Pi 4 4GB

    7 Zoll Touch (https://www.berrybase.de/offizielles-ra…ven-touchscreen)

    32 GB SD Karte


    Vielen Dank schon mal im Voraus

    Dirk

  • Danke für die Antwort.

    Ich könnte Dir auch ein Display zum Testen schicken, falls das helfen würde.


    Ist mit beiden Einstellungen das selbe. Wayland oder X11 und das Bild ist irgendwie verzerrt..

    mit ner anderen SD Karte mit Bullseye ist aber alles ok.

    Edited once, last by samaha73 (March 25, 2024 at 3:21 PM).

  • in der cmdline.txt mal die video angaben eingetragen (video=DSI-1:800x480@60D)

    Wofür steht das "D" eigentlich? In der offiziellen Doku steht das nicht. https://www.raspberrypi.com/documentation/…es/display.html :)

    Versuchs mal mit: video=DSI-1:800x480@60,rotate=0 in der einen Zeile der boot/firmware/cmdline.txt! Der Pfad ist ja auch ein anderer als er bei Bullseye war.

  • Hey, vielen Dank für die Vorschläge.

    also ich hab jetzt auto detect aus und die Treiber geladen:

    # Enable DRM VC4 V3D driver
    dtoverlay=vc4-kms-v3d
    dtoverlay=vc4-kms-dsi-7inch

    Das Bild flackert zumindest mal nicht mehr aber es ist immer noch zu unklar wie auf meinem vorherigen Bild. Ich hab gestern mal das Display mit Bookworm auf meinem Raspi 5 getestet und da läuft aller super. Muss also irgendwie am Raspberry Pi 4 liegen..


    hier die cmdline.txt:

    console=serial0,115200 console=tty1 root=PARTUUID=866397a0-02 rootfstype=ext4 fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles, video=DSI-1:800x480@60,rotate=0


    und meine config.txt

    # Enable audio (loads snd_bcm2835)
    dtparam=audio=on

    # Additional overlays and parameters are documented
    # /boot/firmware/overlays/README

    # Automatically load overlays for detected cameras
    camera_auto_detect=0

    # Automatically load overlays for detected DSI displays
    display_auto_detect=0

    # Automatically load initramfs files, if found
    auto_initramfs=1

    # Enable DRM VC4 V3D driver
    dtoverlay=vc4-kms-v3d
    dtoverlay=vc4-kms-dsi-7inch
    max_framebuffers=2

    # Don't have the firmware create an initial video= setting in cmdline.txt.
    # Use the kernel's default instead.
    disable_fw_kms_setup=1

    # Disable compensation for displays with overscan
    disable_overscan=1

    # Run as fast as firmware / board allows
    arm_boost=1

    [cm4]
    # Enable host mode on the 2711 built-in XHCI USB controller.
    # This line should be removed if the legacy DWC2 controller is required
    # (e.g. for USB device mode) or if USB support is not required.
    otg_mode=1

    [all]

  • Hab beides ausprobiert. Denke inzwischen auch dass es an der Kombination liegt. Dann werd ich einfach Bullseye installieren.

    Vielen Dank für euer Mitdenken und Helfen..

  • Nach meiner README in /boot/overlays sollte das mit einem pi4/pi5 Filter tn der config.txt funktionieren:

    [cm4]

    ....

    [pi4]

    dtoverlay=vc4-kms-v3d-pi4
    dtoverlay=vc4-kms-dsi-7inch
    max_framebuffers=2

    [pi5]

    dtoverlay=vc4-kms-v3d-pi5
    dtoverlay=vc4-kms-dsi-7inch
    max_framebuffers=2

    [all]


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Hi,

    mit diesen Einstellungen wird das Display komplett weiß. Des Splash Screen ist super dann kommt der Cursor und danach wird alles weiß.

    Ein weiterer Versuch wie es nicht klappt. :) Aber daraus lernt man bekanntlich am meisten..


    Update...

    mit diesen Einstellungen klappt es :) <------------------------------ allerdings nur mit der 32 bit Version!
    dtoverlay=vc4-kms-v3d,nohdmi,noaudio
    dtoverlay=vc4-kms-dsi-7inch
    max_framebuffers=2


    sehr genial!!!

    Vielen Dank euch allen!!

    Hab die Dateien hier nochmal angehängt, vielleicht hat ja außer mir noch jemand das Problem.

  • ....

    sudo apt update -----> alles auf neuestem Stand

    ....

    Damit ist nichts auf dem neustem Stand.

    Wenn dann:

    Code
    sudo apt update && sudo apt full-upgrade -y

    hyle
    Ich habe den ganzen Thread gelesen und auch gesehen, dass es jetzt mit der 32Bit Version klappt.
    Aber der Irrglaube mit "apt update" wäre alles aktuell musste ausgeräumt werden. :shy::-/

    ;) Gruß Outi :D
    Pis: 2x Pi B, 1x Pi B+, 1x Pi 2 B in Rente / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 / 2x Pi Zero 1.3 / 2x Pi Zero W 1.1 / 1x Pi Zero 2 (BW+CUPS/SANE) / 1x Pi 3 B+ (Tests) / 1x Pi 4 B 4GB (Tests) / Pi 400 (BW) / 1x Pi 5 (BW) / 2x Pi Pico / 2x Pi Pico W
    HATs: Sense HAT / HM-MOD-RPI-PCB / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT / Pi 5 Kühler HAT / Pimoroni NVMe BASE
    Cams: orig. Raspberry Pi Camera Module V1 & V3 / PS3 Eye

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!