Festplatte wird nicht mehr automatsich "gemounted"

  • Hallo,

    folgend kurze Frage: könnte mir bitte jemand sagen, warum eine an meinem Raspi hängende Festplatte anfangs noch einwandfrei automatisch eingebunden wurde, in letzter Zeit dies aber nicht mehr geschieht ?

    Grundsturktur: Raspi 64 lite nur mit nginx als Proxy um Inhalte der Festplatte im Heimnetz verfügbar zu machen.

    In der fstab habe ich folgenden Eintrag (den ich vorher sicherlich anders eingestellt hatte, an den ichx mich aber leider nicht mehr erinnere ?() exfat auto,nofail,sync,umask=0037,nls=utf8 0 0

    Der Gag ist, dass wenn ich den Pfad manuell mounte, die Festplatte angesprochen wird und hochfährt. Ich denke daher, dass "auto" oder ??? zu schnell abgegeben werden beim starten, sodass die Festplatte nicht starten kann und der Raspi zur Tagesordnung einfach weiter geht. Änderungen auf "default" haben aber auch keine Wirkung gezeigt.

    Mit "mount -a" klappts auch nicht. Dann kommt folgende Meldung:

    mount: /home/pi/volume1: wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage or helper program, or other error.

    Was muss ich bitte ändern ?:/

  • Festplatte wird nicht mehr automatsich "gemounted"? Schau mal ob du hier fündig wirst!

  • Hier sollte auch umask=0037 imho betrachtet/geändert werden.

    umask=0037 ist das oktale Komplement zu chmod=7750, wobei ich über die erst 0 (7) nichts sagen kann.

    Aber 037 würde 750 (rwx r-x ---) entsprechen und das Windows Filesystem würde nur vom User root und Gruppe root erreichbar sein. Alle Dateien werden mMn dem User root mit dem Eigentümer pi, bzw uid=1000 angezeigt.


    Ich kanns aber weder testen noch kann ich aus der exfat Manpage vorlesen, ich verwende exFat nicht.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Ich persönlich würde umask (erstmal) ganz weglassen und testen ob die HDD so überhaupt automatisch gemountet wird. Die Option defaults beinhaltet ja auto bereits und damit solle auch ein sudo mount -a im Nachhinein funktionieren.

    Warten wir mal ab was beim TO raus kommt.

    BTW Gestern vergessen: Mit sync als Option tut man sich übrigens keinen Gefallen. Das klingt zwar vermeintlich irgendwie logisch, aber da muss man viiiel Zeit fürs schreiben auf das Laufwerk einplanen.

  • Ich persönlich würde umask (erstmal) ganz weglassen

    Dann wird laut man-page default "0", also umask=000 [chmod 777 - rwx rwx rwx] angenommen, und die Windows Welt ist gerettet.

    Neben den Optionen von < man mount.exfat >

    sind auch die FILESYSTEM-INDEPENDENT MOUNT OPTIONS von < man mount > zu beachten.

    Der TO sollte sich die man-pages erstmal durchlesen.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Dann wird laut man-page default "0", also umask=000 [chmod 777 - rwx rwx rwx] angenommen, und die Windows Welt ist gerettet

    Wenn ich umask weglasse, wird 777 gemountet? :-/ Das halte ich für nicht sehr wahrscheinlich, denn dann könnte ich mir die Angabe von gid und uid auch schenken, damit die Welt für den dort angegebenen User in Ordnung ist. Ich kann das natürlich auch gerade nicht testen.

  • Ich kann das natürlich auch gerade nicht testen.

    Ich habe mir mal die Mühe gemacht.
    SSD (exfat formatiert) Zum Testen mit Windows ein paar Fotos reingeschoben.

    Eintrag in der /etc/fstab
    PARTUUID=f736000c-01  /home/franjo64/exfat         exfat   defaults,noatime,nofail,uid=1000,gid=1000  0     0

    Die Platte wird beim Booten wie in der fstab definiert gemountet.

    Code
    NAME          SIZE TYPE FSTYPE MOUNTPOINT           UUID                                 PARTUUID
    sda         111.8G disk
    └─sda1      111.8G part exfat  /home/franjo64/exfat 1044-F427                            f736000c-01


    Berechtigungen, Owner........ ok

  • Guten Abend,

    und vielen Dank für die vielen Hinweise.

    hyle #13 : Sorry Ihr Los hat leider nicht gewonnen .;(

    RTFM #14: Ist das nicht vielleicht ein kleinen Verprecher von Dir ? 037 = rwx,rw-,--- ( so war es jedenfalls von mir angedacht gewesen ;))

    hyle #15: alles rausgenommen - Leider nicht gewonnen ( trotz reboot) 8|

    Franjo G #18: genau so hatte ich es zu beginn auch. Alles klappte einwandfrei. Dann hab ich wohl irgenwo einen Fehler eingebaut und nun ist "Aus die Maus" ||

    Ich weiss auch nicht genau was ich da in der fstab so alles löschen kann und dann wieder hinzufügen ??? Ich hab halt eigentlich auch nicht recht Lust das System neu komplett aufzusetzten, sehe aber diese Schwert schon an meinen wenigen Haarzipfeln kratzen :cursing:.

    Das Problem ist ja auch, dass es auf einem zweiten raspi, auf dem PiHole läuft, ebenfalls zu den gleichen Problemen kommt. ( Weil ich ein ordentlicher Mensch bin und wenn, dann den Fehler auch konsequent wiederhole. ) Da kenn ich ja nix.

    Interessant ist auch, dass ich bei "blkid" die sda1 FP nicht angezeigt bekomme. Diese mir aber unter "lsblk" angezeigt wird.

    Ausserdem hatte ich einen Root / bei "lsblk" mittig unter der letzten Zeile X/

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!