Backup-Läufe optimieren bzw. genauer konfigurieren

  • Guten Abend,

    im Dezember habe ich auf meinem Zero mit Forenhilfe raspiBackup eingerichtet.

    Zum Testen der regelmäßigen Backups habe ich sowohl im raspiBackup die Option mit Smart Recycle benutzt als auch manuell per Cronjob was eingestellt.

    Die Optionen im raspiBackup sind:

    In meiner crontab-Datei habe ich eingetragen:

    Code
    # Backup jeden 1. des Monats um 4:00 Uhr
    0 4 1 * * sudo raspiBackup -m detailed
    
    #Backup jeden Montag um 5:00 Uhr
    0 5 * * 1 sudo raspiBackup -m detailed

    Ich habe das nun 3 Monate beobachtet und es scheinen beide Methoden parallel zu funktionieren. Ich erhalte entsprechende Mail-Benachrichtigungen.

    Doppelte Backup-Serien sind natürlich Unfug, daher möchte ich das Ganze nun optimieren.

    - An der raspiBackup-Methode stört mich, dass das Backup zum falschen Zeitpunkt startet. Morgens kurz nach 11 Uhr geht gar nicht!
    Ich hätte das gerne in der Nacht um 4 Uhr oder so.

    - Bei der Cronjob-Methode fehlt mir die Möglichkeit, die Gesamtzahl der Backups auf 10 oder 12 zu begrenzen (so wie beim Smart_Recycle)

    Könnt Ihr mir einen Tipp geben, wie ich einen der beiden Punkte hinbekomme? Die andere Methode würde ich dann abschalten.

  • Backup-Läufe optimieren bzw. genauer konfigurieren? Schau mal ob du hier fündig wirst!

  • An der raspiBackup-Methode stört mich, dass das Backup zum falschen Zeitpunkt startet. Morgens kurz nach 11 Uhr geht gar nicht!
    Ich hätte das gerne in der Nacht um 4 Uhr oder so.

    Mit dem Installer (ich sollte den vielleicht mal umbenennen denn es ist auch ein raspiBackup Konfigurator) kannst Du definieren wann raspiBackup laeuft. Ich habe keine Ahnung wieso das um 11 Uhr bei Dir passiert :conf: Sieh mal nach was in /etc/cron.d/raspiBackup steht. Jedenfalls kannst Du das mit dem Installer aendern.

    Bei der Cronjob-Methode fehlt mir die Möglichkeit, die Gesamtzahl der Backups auf 10 oder 12 zu begrenzen (so wie beim Smart_Recycle)

    Auf dieser Seite sind alle Optionen beschrieben und da kannst Du auch beim raspiBackup Aufruf die Smartrecycle Optionen mitgeben die Du dann in Deine crontab zufuegen kannst. Allerdings werden defaultmaessig immer die Optionen aus /usr/local/etc/raspiBackup.conf genutzt. Deshalb verstehe ich nicht ganz wieso in diesem Falle die dort definierten SmartRecycle Optionen nicht genutzt werden :conf:

    Ich wuerde Dir empfehlen Deine eigenen raspiBackup crontab Aufrufe zu loeschen bzw auszukommentieren und ueber den Installer die Zeit in /etc/cron.d/raspiBackup entsprechend anzupassen.

  • Viele Leerzeilen plus das da:

  • hilft das evtl. auch weiter?

    Ich hab' doch keine Ahnung von Linux ;)

  • Ich hab' doch keine Ahnung von Linux

    Ich denke ich habe ein wenig davon - aber diese Ausgabe habe ich noch nie gesehen. Bei mir sieht es so aus:

    Code
    framp@asterix:~ $ systemctl status raspiBackup.timer
    ● raspiBackup.timer - Timer for raspiBackup.service to start backup
         Loaded: loaded (/etc/systemd/system/raspiBackup.timer; enabled; preset: enabled)
         Active: active (waiting) since Fri 2024-03-29 18:44:43 CET; 4 days ago
        Trigger: Wed 2024-04-03 03:00:42 CEST; 4h 51min left
       Triggers: ● raspiBackup.service
    
    Mar 29 18:44:43 asterix systemd[1]: Started raspiBackup.timer - Timer for raspiBackup.service to start backup.

    Da sieht man also dass mein Backup von asterix morgen um 3 Uhr gestartet wird. Aehnlich mit anderen Zeiten sieht es bei meinen anderen Raspberries aus.

    Ich bin auch noch nicht so fit mit systemd. Aber irgendwie sieht es mir aus als wenn was an Deinem System nicht so ganz koscher ist. Diese skipping Meldungen weisen meiner Meinung darauf hin dass irgendwas mit dem Filesystem nicht OK ist. Vielleicht kann jemand der mehr erfahren ist mit systemd diese skipping Meldungen beurteilen :)

  • :love:

    M3->C9->R3 zeigt mir 10:55 Uhr

    die Datei /etc/systemd/system/raspiBackup.timer enthält:

    Code
    [Unit]
    Description=Timer for raspiBackup.service to start backup
    
    [Timer]
    OnCalendar=Sun *-*-* 10:55:42
    # Create a backup once a week on Sunday morning at 5 am (default)
    Unit=raspiBackup.service
    
    [Install]
    WantedBy=multi-user.target

    So langsam dämmert mir, wo die Zeitangabe herkommen könnte.
    Es kann sein, dass ich die Einrichtung an einem Sonntagvormittag vorgenommen habe und dabei mit kurzem Abstand direkt einen Probelauf anstoßen wollte. Daher vermutlich die krumme Uhrzeit.

    Wenn ich das alles richtig interpretiere, sollte ich jetzt am besten im Installer meine Wunschzeit einstellen (03:30 Uhr) und dann meine beiden Cron-Einträge auskommentieren – oder?!

  • Wenn ich das alles richtig interpretiere, sollte ich jetzt am besten im Installer meine Wunschzeit einstellen (03:30 Uhr) u

    Du hast doch die Timer Unit vor Dir. Warum nicht gleich dort die Zeit anpassen? > https://wiki.ubuntuusers.de/systemd/Timer_Units/


    //Edit

    framp oder ist da noch eine Konfigurationsdatei im Weg? :conf:

  • Diese Antwort hatte ich auch im Hinterkopf ^^ aber der Installer kann Probleme beim Aendern der Tage und Zeiten bekommen wenn das Format in der Systemd Datei nicht wie erwartet eingegeben wird. Wenn man ausser Tag und Uhrzeit noch was anderes definiert oder gewisse repititive Definitionen vornimmt - was ja moeglich ist - steigt der Installer an der Stelle defintiv aus.

    Es ist also besser den Installer zu nehmen um den Tag und die Zeit zu konfigurieren. Geht vermutlich auch schneller.

  • Also startet jetzt sonntags früh das Backup, und über die Smart-Optionen wird die wöchentliche und monatliche Rotation geregelt …

    Wenn Du eine der Notificationfeatures wie eMail, Slack, Pushover oder Telegram konfiguriert hast bekommst Du regelmaessig eine Benachrichtigung wenn ein Backuplauf stattfand sowie das Ergebnis ;)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!