Autostart von LXTerminal in Bookworm: Terminal werden immer kleiner ;-)

  • Autostart von LXTerminal in Bookworm: Terminal werden immer kleiner ;-)? Schau mal ob du hier fündig wirst!

  • Wie gesagt, ab und zu fliegt mein Desktop aus der Kurve und alle Fenster sind weg.

    Habe jetzt mal im Syslog nachgeguckt.... auf den Gedanken hätte ich auch mal eher kommen können.

    Ich sehe öfters:

    Code
    Mai 18 11:05:18 raspberrypi sh[868]: Warning: ../src/main.c: 319: Selected output HDMI-A-1 went away
    Mai 18 11:05:18 raspberrypi sh[868]: Warning: ../src/main.c: 330: No fallback outputs left. Detaching...
    Mai 18 11:05:19 raspberrypi sh[868]: Warning: ../src/main.c: 319: Selected output NOOP-1 went away

    und merke nichts davon.

    Aber dann gibt es irgendwann einmal:


    ...und die letzte Zeile sagt mir dass in dem Moment die terminals weg sind.

    Helfen diese Meldungen weiter ?

  • Was ist NOOP ?

    Bis jetzt dachte ich das NOOP die Einstellung ist, wenn kein Monitor dranhängt.

    Ich nutze 2 Dinge: einen HDMI-Umschalter (dessen Raspi-Eingang meist beim Booten aktiv und durchgeschaltet zu einem Monitor ist, aber ansonst meist entweder stromlos oder aber auf einem anderen Eingang geschaltet ist), und ich nutze ab und zu RealVNC, also VNC auf dem Raspi aktiviert und RealVNC auf dem Windowsrechner.

    Wie gesagt, meist beides nicht aktiv, und ich dachte dass es meist zum Absturz kommt wenn ich einen der Möglichkeiten mal kurz genutzt habe. Aber der Aussteiger am 18. den ich oben in der syslog gefunden hatte war ohne Nutzung von HDMI-Ausgang oder VNC. Allerdings kann es sein dass ich den HDMI-Umschalter zu der Zeit vielleicht ein- oder aus- oder um-geschaltet habe, aber nicht auf den Raspi.

  • Das wird immer wilder hier....

    Am Samstag habe ich update / upgrade gemacht auf 2 Raspi4. Schien erst einmal alles gut gegangen zu sein.

    Aber dann neuer Effekt:

    Wenn irgendetwas am HDMI kitzelt (z.B. heute morgen einfach Strom auf die Peripheriegeräte eingeschaltet, also auch den HDMI-Umschalter "aktiviert", aber nicht auf den Raspi-HDMI-Eingang geschaltet), dann geht "pcmanfm" im Taskmanager auf 25% und die Temperatur steigt hoch. Das hört nicht mehr von alleine auf, einen Dateimanager bekommt man jetzt nicht mehr auf, der Desktop-Hintergrund wird dann irgendwann einmal nicht mehr dargestellt.

    Erst ein "Abbrechen" im Taskmanager behebt das Problemchen.

    Edited once, last by NoPlayBack (June 4, 2024 at 12:29 PM).

  • Nur als Feedback gedacht.... falls jemand vor einem ähnlichen Problem steht:

    Seit 5 Tagen habe ich nun physikalisch das HDMI-Kabel von den Raspis getrennt und arbeite nur noch mit RealVNC.

    Die Terminals bleiben in Ihrer Größe, es gibt kein Durchdrehen von pcmanfm mehr wenn ich mal hingucke...

  • Nur als Feedback gedacht.... falls jemand vor einem ähnlichen Problem steht:

    Seit 5 Tagen habe ich nun physikalisch das HDMI-Kabel von den Raspis getrennt und arbeite nur noch mit RealVNC.

    Die Terminals bleiben in Ihrer Größe, es gibt kein Durchdrehen von pcmanfm mehr wenn ich mal hingucke...

    Also jetzt so angeschlossen wie bei mir, nur dass ich TigerVNC benutze. Der Effekt aus #14 geht bei Dir aber immer noch?

    :rolleyes: sudo !!

  • Hilft zwar nicht weiter, aber goobay ist auch eine von diesen China-Billigheimer-Marken, deren Produkte/Spezifikationen sich gut anhören, aber deren technische Umsetzung zu wünschen übrig lässt.

    Für mich sieht es so aus, dass beim Umschalten der HDMI-Ausgangsports eine (zu) lange Pause entsteht und die HDMI-Quelle "meint", das Ausgabegerät sei abgesteckt worden, wie aus den Logfiles ersichtlich. Dann beginnt die HDMI-Initialisierung per EDID von Neuem.

    Und der RPi ist diesbezüglich ebenfalls eine Diva! Denn beim Einschalten des RPi sollte der HDMI-Bildschirm bereits dranhängen... Ansonsten bleibt der Bildschirm gerne mal schwarz.

    Helfen würden da feste Bildschirmeinstellungen inkl. EDID-Disabling am RPi in der config.txt, aber das ist ja seit Bookworm (und ich glaube bereits seit Bullseye) auch nicht mehr so einfach (" legacy video settings")

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!