Mount nfs Share nach Update auf Bookworm

Heute ist Stammtischzeit:
Jeden Donnerstag 20:30 Uhr hier im Chat.
Wer Lust hat, kann sich gerne beteiligen. ;)
  • Hallo,


    ich habe auf einen Pi Zero WH bookworm komplett neu mit dem Imager installiert. Soweit läuft dieser und erkennt auch den angeschlossenen USB Stick, welcher mit der fstab gemountet wird. Nun aber mein Problem. Auf mein NFS VErzeichnis auf dem Synology NAS habe ich keinen zugriff mehr nach einen Neustart. Die fstab hat bis bullseye einwandfrei funktioniert. Diese habe ich (nur die Einträge) auf das neue System übernommen.

    192.168.178.2:/volume1/52_raspi2_backup /mnt/winas1 nfs rw,_netdev,user 0 0

    Der Eintrag scheint nicht falsch zu sein. Erstens lief er im alten System und auch noch aktuell auf einen RPI4 mit bullseye und zweitens kann ich mit sudo mount -a den Ordner Mounten. Nur nach einen Neustart ist der Ordner nicht gemountet. Woran kann das liegen? Wo ist der unterschied zu bullseye?

  • Woran kann das liegen?

    Wenn sich eine Netzwerhfreigabe manuell mounten lässt, aber nicht automatisch beim Booten, liegt das in der Regel daran, dass zu dem Zeitpunkt wenn die fstab abgearbeitet wird, das Netzwerk noch nicht bereit ist.

    Versuchs mal mit einer systemd-mount-unit.

    Hofei
    August 26, 2018 at 5:13 PM
  • Das hatte ich dies auch schon versucht, jedoch ohne erfolg. Übersehe ich was?

    .mount Datei erstllt

    Code
    sudo nano /etc/systemd/system/mnt-winas1.mount

    mit folgenden Inhalt

    Danach systemctl neu geladen und neu gestartet

    Code
    sudo systemctl daemon-reload
    sudo reboot now

    Netzlaufwerk wird nicht eingebunden

    nfs ist installiert

    Code
    sudo apt update
    sudo apt install nfs-common
    nfs-common is already the newest version (1:2.6.2-4).

    und nun? ||

  • Noch die Ausgabe von sudo journalctl -xe


  • miwi1706 May 7, 2024 at 6:15 PM

    Added the Label Debian 12 (Bookworm)
  • miwi1706 May 7, 2024 at 6:15 PM

    Added the Label RasPi OS Lite
  • 192.168.178.2:/volume1/52_raspi2_backup /mnt/winas1 nfs rw,_netdev,user 0 0

    Nur geraten: Könnte es sein, dass das ein Problem mit unterschiedlichen NFS-Versionen ist?

    Häng mal nach dem _netdev,user ein ,vers=3 an

    Meine Pis

    Pi B Rev 2 24/7 - DHCP-Server im Heimnetz
    Pi 2B Rev 1.1 Home-Infocenter (Domoticz) - Kamera auf Garten
    Pi 2B Rev 1.1 Testgerät mit USV, Musikplayer, Kodi,
    Pi 3B Rev 1.2 Videos aus Netzwerk (an Rückseite des TV moniert)
    Pi 3B+ Rev 1.3 mit 3.5-TouchDisplay, Peppy-Web-Radio
    Pi 4B - 4GB Rev 1.1 Testgerät - Argon-ONE-Gehäuse

    Pi Zero Testgerät

    Pi Zero W Rev 1.1 Motion-Eye auf Garten

  • Uhh ja, es funktioniert normal mit der fstab.

    sudo systemctl enable systemd-networkd-wait-online.service muss aktiviert sein. Nachdem die fstab bearbeitet worden ist müssen jetzt mit systemctl daemon-reload die Änderungen übernommen werden. ,vers=3 muss nich angehangen werden

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!