Browser im Kiosk Mode Mauszeiger verstecken

Heute ist Stammtischzeit:
Jeden Donnerstag 20:30 Uhr hier im Chat.
Wer Lust hat, kann sich gerne beteiligen. ;)
  • Hallo liebes Forum,

    ich habe mehrere Kiosksysteme seit ein paar Jahren laufen. Jetzt mit der neuen OS Version vom Raspberry gab es ja einige Änderungen. Wayland statt x11 und wo weiter...

    Ich habe mittlerweile eigentlich alles was ich will, nur eine Kleinigkeit kriege ich bisher leider nicht hin und finde auch keine Lösung hier oder bei Google. Selbst ChatGPT will mir hier keine anständige Lösung bieten.

    Um den Kioskmode zu starten, habe ich die Wayfire.ini unter ~/.config/ wie folgt angepasst.

    Code
    [autostart]
    background = wfrespawn pcmanfm --desktop --profile LXDE-pi
    xdg-autostart = lxsession-xdg-autostart
    chromium = chromium-browser "meine URL" --kiosk --noerrdialogs --disable-infobars --no-first-run --ozone-platform=wayland --enable-features=OverlayScrollbar --start-maximized
    screensaver = false
    dpms = false

    Quelle: RE: Automatischer Start von Chromium funktioniert nicht

    Damit startet der Browser dann auch wurderbar und alles sieht so aus wie es soll. Nun kommt das große ABER

    Unter X11 habe ich nun mit unclutter das schöne Tool gehabt, mit dem ich dann einfach den Mauszeiger verschwinden lassen konnte. Unter Wayland läuft das aber leider nicht so. Es würde mir schon helfen, wenn man den Zeiger einfach ganz unten in die Ecke verschieben könnte oder so, aber ich finde da leider keine Anleitung.

    Wäre super, wenn hier noch irgendjemand eine Idee hätte.

    Achja. Ich möchte eigentlich nicht zu x11 zurück. Ich weiß, dass es damit funktioniert, aber ich hätte schon gerne eine Variante, die dann auch unter Wayland funktioniert. Auch super wäre, wenn ich keine externen Pakete hinzufügen müsste. Das macht die ganze Geschichte etwas zu kompliziert für mich.

    Edited once, last by samiam21 (May 8, 2024 at 10:42 AM).

  • Ich habe mehrere Kiosk unter wayland laufen, unclutter funktioniert out of the box.

    Das wäre ja erwähnenswert gewesen. ;) Du bist auch der Erste von dem ich lese das es doch gehen soll. Wie rufst Du denn auf, und in welcher OS-Version?

    Bei mir funktioniert unclutter unter Bookwom 64bit mit wayland nach Installation durch einfachen Aufruf mit unclutter oder unclutter -display :0  nicht.

    :rolleyes: sudo !!

  • Wow, da hast du mich erwischt.

    Nutze Bookworm 32bit.

    Da ich die Kiosks automatisiert installiere hab ich grade im Script mal nachgesehen.

    Statt unclutter nutze ich bei Wayland folgendes :

    Code
    mv /usr/share/icons/PiXflat/cursors/left_ptr /usr/share/icons/PiXflat/cursors/left_ptr.bak

    Danach ein Reboot und der Mauszeiger ist weg.

    Hatte ich gar nicht mehr auf dem Schirm....

    Asche auf mein Haupt.

    Wieder anzeigen :

    Code
    mv /usr/share/icons/PiXflat/cursors/left_ptr.bak /usr/share/icons/PiXflat/cursors/left_ptr

    Offizieller Schmier und Schmutzfink des Forum.

  • Danach ein Reboot und der Mauszeiger ist weg.

    Funktioniert prima. Bei Verbindung mit TigerVNC reicht erwartungsgemäß ausloggen und wieder einloggen. Der Cursor bleibt sichtbar, aber ist so klein dass er im Bild völlig untergeht.

    Der kleine schwarze Punkt rechts neben dem grauen Bereich um "Shutdown Options" ist der Cursor:

    Maus ist aber weiter benutzbar, wenn man die richtigen Stellen trifft, es wird also nicht die Mausbentzung deaktiviert.

    :rolleyes: sudo !!

  • Danke an Der_Imperator für die Lösung. Danke auch an alle anderen für die Beiträge. Das ist zwar sicher nicht die sauberste Lösung, aber es tut was es soll und das soll mir nun dann auch erstmal reichen! :)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!