Hdmi-Auflösung nach Update auf Bookworm zu niedrig

Heute ist Stammtischzeit:
Jeden Donnerstag 20:30 Uhr hier im Chat.
Wer Lust hat, kann sich gerne beteiligen. ;)
  • Mein Raspi 4 (8 GB) ist über den ersten Hdmi-Ausgang mit dem Dell Monitor 3008 WFP verbunden, der eine max. Auflösung am Hdmi-Eingang von 1920 x 1200 (16:10) bietet. Diese Auflösung wurde vor Bookworm von allen Raspi-Os Versionen automatisch erkannt und zutreffend eingestellt.

    Mit dem Wechsel zur Bookwormversion von Raspi-Os wird bei ansonsten gleicher Gerätekombination aber nur mehr eine Auflösung von 1024 x 768 (4:3) eingestellt. Unter Screen Configuration wird mir auf der Bedienoberfläche auch keine höhere Auflösung zur manuellen Einstellung angeboten.

    Um irgendeinen Defekt am Raspi und/oder Dell 3008 WFP auszuschließen, habe ich auf einer anderen (neuen) SD-Karte mit Hilfe des Raspberry-Imager Raspi-Os in der Bullseye-Version neu eingerichtet und gegen die SD-Karte mit der Bookworm-Version getauscht. Bereits beim Installationsablauf war zu erkennen, dass jetzt wieder die höhere Auflösung von 1920 x 1200 von meinem Raspi dargestellt wird. Was sich nach Abschluß der Ersteinrichtung auch bestätigt hat!

    Also kann es nur an irgendwelchen Änderungen innerhalb der Bookworm-Version liegen. Das gleiche Verhalten zeigt sich übrigens auch unter Ubuntu/Bookworm.

    Meine sehr laienhaften Versuche, die Auflösung durch Änderungen in der config.txt zu erhöhen, waren erfolglos. Von Bullseye zu Bookworm hat sich hier anscheinend auch einiges geändert, weshalb ich resignierend aufgegeben habe.

    Vielleicht kann mir aus dem Forum heraus eine Lösung dargestellt werden, die ich als Anfänger auch nachvollziehen kann?


    Josl

  • Hdmi-Auflösung nach Update auf Bookworm zu niedrig? Schau mal ob du hier fündig wirst!

  • Du kannst versuchen die Auflösung manuell in die Konfigurationsdatei einzutragen. Dazu öffnest Du im Editor Deiner Wahl die Datei ~/.config/wayfire.ini und trägst ganz unten folgende Zeilen ein:

    Code
    [output:HDMI-A-1]
    mode = 1920x1200@60

    (Das @60 ist die Blidwiederholfrequenz. Die musst Du ggf. anpassen!)

    Der Moni muss dann natürlich auch am HDMI 1 Port angeschlossen sein.

  • Du kannst versuchen die Auflösung manuell in die Konfigurationsdatei einzutragen. Dazu öffnest Du im Editor Deiner Wahl die Datei ~/.config/wayfire.ini und trägst ganz unten folgende Zeilen ein:

    Code
    [output:HDMI-A-1]
    mode = 1920x1200@60

    (Das @60 ist die Blidwiederholfrequenz. Die musst Du ggf. anpassen!)

    Der Moni muss dann natürlich auch am HDMI 1 Port angeschlossen sein.

    Du warst schneller :thumbsup1:

    ---

    Alles ist relativ - ob in dieser oder deiner Welt

  • Hi hyle+McDotter,

    danke für die rasche Hilfestellung. Leider kann ich mich erst morgen an die Umsetzung machen. Hoffentlich kann ich dann Erfolg vermelden. Wayland ist, glaube ich, bereits in meiner alten 64bit Bullseye-Version als Displayserver aktiviert.
    Ihr hört jedenfalls von mir - jetzt schon mal ein herzliches Dankeschööön!!

    Josl

  • Wayland ist, glaube ich, bereits in meiner alten 64bit Bullseye-Version als Displayserver aktiviert.

    Wayland kam ziemlich sicher erst mit Bookworm. Das kannst Du aber leicht überprüfen, indem Du Dir auf dem Desktop im Terminal die Ausgabe von

    Code
    echo $XDG_SESSION_TYPE 

    ansiehst. :wink1:

    //Edit

    Oh, fast übersehen... Willkommen im Forum! :green_smile:

  • Meine Bullseye-Version von RaspiOs läuft - frisch installiert - mit X11; ich hatte dort anscheinend über die Systemkonfiguration auf Wayland umgestellt. Die Absicht dabei war zu sehen, ob dann auch das gleiche Verhalten (Auflösung) wie unter Bookworm eintritt. Ergebnis: keine Veränderung zum bisherigen Verhalten. Die Datei .config/wayfire.ini ist dabei aber leer!

    Unter Bookworm habe ich zwischenzeitlich die von hyle dargestellten Programmzeilen in die wayfire.ini mit nano eingetragen, gespeichert und den Raspi neu gestartet: leider verbleibt es bei der bisherigen geringeren Auflösung.

    Ich habe den Eindruck, dass mit der Umstellung von X11 auf Wayland mehr Änderungen vorgenommen wurden. Ich werde das aktive System deshalb weiter in der Bullseye-Version nutzen und mit meinem Bookwormsystem weiterhin versuchen, meinen Wissenstand zu Wayland zu verbessern.

    Für Hilfe dabei bin ich sehr dankbar.

    Josl

  • Probiere einmal, schon mit der Kernel Command Line (cmdline.txt) die gewünschte Videoauflösung einzustellen. Dein Monitor muss dabei die Auflösung unterstützen und darf nicht "verstellt" sein..

    https://www.raspberrypi.com/documentation/computers/configuration.html#the-kernel-command-line

    Die Ausgabe von < sudo vclog -m > könnte auch einen Fehlerhinweis enthalten.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Ich habe die cmdline.txt wie im Link dargestellt um die Videoeinstellungen für 1920x1200M@60 ergänzt, gespeichert und neu gestartet: Videoauflösung blieb bei 1064x768.

    Die vclog-Abfrage ergab für mich keine Hinweise, die das eingangs beschriebene Auflösungsproblem erklären könnten.

    An meinem Dell 3008 WFP habe ich für keinen Eingang irgendwelche Auflösungseinstellungen vorgenommen. Dessen native Auflösung beträgt für den HDMI-Eingang 1920x1200@60Hz, am Displayport 2560x1600@60Hz. Und wie schon gesagt, die maximale HDMI-Auflösung wird unter Bullseye automatisch eingestellt.

    Josl

  • Bei mir kam ab Bookworm ein "HDMI1:EDID error reading EDID block 0 attempt 0" und danach ein giving up, was ich mit dem video= Eintrag in der cmdline.txt umgehen konnte (am Pi 4).

    Mit < kmsprint -m > bekommst Du alle unterstützte Videomodi angezeigt.


    Wenn 'Dein gewünschter Modus nicht dabei ist, dann musst Du vermutlich bis zu einem passenden Update warten.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Hallo,

    ähnliches Problem bei mir: Ich habe schon seit dem Kauf meines Raspi 5 im März Bookworm, und anfangs hatte ich eine brauchbare Auflösung (ich muss zu meiner Schande gestehen, daß ich nicht weiß welche, ich glaube aber 1600 * 1200).

    Ich weiß nicht, ob es an einem Systemupdate lag, aber irgendwann fing der Raspi an, immer nur noch auf 1024 x 768 zu booten. Mehr wird unter Einstellungen -> Screen Configuration auch nicht angeboten.

    "sudo vclog -m" liefert:

    005055.987: Initial voltage 800000 temp 54316
    005253.423: avs_2712: AVS pred 8867 886700 temp 54316
    005253.434: vpred 886 mV +0
    005875.829: FB framebuffer_swap 1
    005893.358: Select resolution HDMI0/2 hotplug 1 max_mode 2
    005893.548: BSC_A no ACK
    005893.733: BSC_A no ACK
    005893.744: HDMI0: Unable to read EDID block 0
    005893.757: Select resolution HDMI1/2 hotplug 0 max_mode 2
    006685.003: dtb_file 'bcm2712-rpi-5-b.dtb'
    009977.161: Starting OS 9977 ms
    009979.794: 00000040: -> 00000480
    009979.811: 00000030: -> 00100080
    009979.826: 00000034: -> 00100080
    009979.842: 00000038: -> 00100080
    009979.857: 0000003c: -> 00100080
    010081.921: sdram: sdram refresh 2081->4162 (2)

    "kmsprint -m" liefert:

    0 1024x768@60.00 65.000 1024/24/136/160/- 768/3/6/29/- 60 (60.00) D
    1 800x600@60.32 40.000 800/40/128/88/+ 600/1/4/23/+ 60 (60.32) D
    2 800x600@56.25 36.000 800/24/72/128/+ 600/1/2/22/+ 56 (56.25) D
    3 848x480@60.00 33.750 848/16/112/112/+ 480/6/8/23/+ 60 (60.00) D
    4 640x480@59.94 25.175 640/16/96/48/- 480/10/2/33/- 60 (59.94) D

    Es sei erwähnt, daß ich als Monitor einen alten 4:3-Monitor verwende, der keinen HDMI-, sondern nur einen DVI-Eingang hat. Dieser ist über ein HDMI-zu-DVI-Adapterkabel plus einen Micro-HDMI-auf-HDMI-Adapter angeschlossen. Klingt wild, aber wie gesagt: Es hat mal mit einer vernünftigen Auflösung funktioniert.

    Hat jemand eine Idee, wie man der Sache beikommen kann?

    Danke und Gruß,

    Timo

  • Hi Timo,

    einerseits bedauere ich Deine Probleme mit der Monitorauflösung, andererseits bin ich auch wieder froh, dass ich offensichtlich damit nicht alleine bin. Die mir zugedachten Unterstützungen aus dem Forum haben bisher keine Lösung gebracht.
    Ich habe den Eindruck, dass unsere Probleme mit dem unter Bookworm vollzogenen Wechsel des Displayservers (nunmehr Wayland) zusammenhängen. Manuelle Konfigurationen der Auflösung erfordern nach meinen bisherigen Eindrücken andere Maßnahmen als unter X 22.

    Dazu fehlen mir aber die notwendigen Linux-Kenntnisse. Sollte nicht ein weiterer Forum-User den entscheidenden Lösungsweg finden, bleibe ich bei meinem Pi4 zunächst bei der Vorgängerversio Bullseye, in der Hoffnung, dass bald ein Update erscheint, mit dem wir dann auch innerhalb der Bedienoberfläche höhere Auflösungen als 1024x768 einstellen können.

    Vielleicht versuche ich testhalber auch noch Ubuntu in der kürzlich erschienen Form 24.04; die Vorgänger-Bookwormversion hatte die gleichen Auflösungsprobleme wie RaspberryOS.

    Sollten sich positive Erkenntnisse ergeben, melde ich mich wieder!

    Josl

  • Ich habe den Eindruck, dass unsere Probleme mit dem unter Bookworm vollzogenen Wechsel des Displayservers (nunmehr Wayland) zusammenhängen.

    Den Gedanken hatte ich auch schon. So wie ich es verstehe, müsste man aber doch über raspi-config (6 Advanced Options -> A6 Wayland -> W1 X11) wieder von Wayland auf X zurückwechseln können. Ändert in meinem Fall aber leider überhaupt nichts. Danach erfolgt die Meldung "Openbox on X11 is active", aber die maximale Auflösung (auch nach Neustart) bleibt 1024 x 768.

  • Diesen Wechsel hatte auch ich bereits mit dem selben negativen Erlebnis durchgeführt. Aufgefallen ist mir auch, daß sich die Konfigurationsdateien für die Grafikeinstellungen von Bullseye (X11) zu Bookworm (Wayland) unterscheiden. Aber wie schon gesagt, mir fehlen einfach die dazu notwendigen Linuxkentnisse, um dem genauer und nachvollziehbar nachzugehen.

    Ich glaube zwischenzeitlich insoweit immer mehr an einen Bug innerhalb von Bookworm bei der Umstellung von X11 auf Wayland. Für mich ist das weniger tragisch, da mein Pi4 - im Gegensatz zum Pi5 - auch unter Bullseye mit X11 ideal läuft. Mich wundert eigentlich nur, dass noch nicht mehr User diesen Fehler melden, da eine max. Displayauflösung von 1024x768 in den wenigsten Fällen bei einem externen Monitor die zutreffende Auflösung sein dürfte.


    Josl

  • Vermutlich kann der Kernel die edid Angaben aus dem Monitor nicht lesen oder es werden keine "geliefert". In welcher Reihenfolge schaltet ihr den RPi und den Moni an? Ändert sich etwas bei der Ausgabe von kmsprint -m, wenn der Moni zuerst angeschaltet wird und dann der RPi?

  • Bei mir ist der Einschaltvorgang stets gleich: es ist immer der Monitor an (und der HDMI Eingang aktiviert) bevor ich den Raspi starte.

    An diesem Vorgang oder meinem Monitor (Dell 3008 WFP) kann es nicht liegen, da ja unter Bullseye (X11) die native Monitorauflösung von 1980x1200 automatisch erkannt und eingestellt wird. Der gleiche Vorgang unter Bookworm führt zu einer Auflösung von max. 1024x768.

    Mein Monitor stellt somit sicher die notwendigen Informationen zur Auflösungserkennung zur Verfügung; Bookworm (Wayland) scheint damit aber nichts abfangen zu können; Bullseye (X11) dagegen schon!

    kmsprint -m muß ich noch testen.

    Josl

  • In welcher Reihenfolge schaltet ihr den RPi und den Moni an? Ändert sich etwas bei der Ausgabe von kmsprint -m, wenn der Moni zuerst angeschaltet wird und dann der RPi?

    Theoretisch gleichzeitig, weil sie zusammen an einer schaltbaren Steckdosenleiste hängen. :) Ich kann aber morgen mal probieren, sie nacheinander einzuschalten.

    So gesehen müsste man ja dann den Monitor zuerst einschalten...?

  • kmsprint -m: identische Anzeige wie bei timo73, egal in welcher Reihenfolge Raspi und Monitor eingeschaltet werden

    wlr-randr zeigt:

    HDMI-A-1 „(null) (null) (HDMI-A-1)“

    Enabled: yes

    Modes:

    640x480 px, 59.939999 Hz

    848x480 px, 60.000000 Hz

    800x600 px, 56.250000 Hz

    800x600 px, 60.317001 Hz

    1024x768 px, 60.004002 Hz

    Position: 0,0

    Transform: normal

    Scale: 1.000000

    Auch hier spielt es keine Rolle. In welcher Reihenfolge mein Pi4 und/oder Monitor eingeschaltet wird!


    Josl

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!