Raspberry Pi 5 mit Waveshare 7 inch dsi LCD 800x480

Heute ist Stammtischzeit:
Jeden Donnerstag 20:30 Uhr hier im Chat.
Wer Lust hat, kann sich gerne beteiligen. ;)
  • Hey

    ich probier gerade einen Raspberry pi 5 mit einem Wavesahre 7 inch DSI LCD 800x480 Display zum Laufen zu kriegen. Die SD Karte mit Raspberry Pi OS habe bereits in den RPi eingelegt und mit Stromversorgung leuchtet auch die stat LED Grün. Ich habe den Display auch mit dem offiziellen Raspberry Pi 15 to 22 Pin verbunden und auch auf die richtige Orientierung geachtet. Den Lüfter den ich über PIn 2 und Ground 9 angeschlossen habe läuft auch, jedoch bleibt das Display schwarz. Die Stromversorgung vom Display ist über Depont Setcker auf PIn 4 und Ground 6. Ich habe auch wie in dem https://www.waveshare.com/wiki/7inch_DSI_LCD in die config.txt den Codeteil am Ende eingefügt, jedoch immer noch schwarzes Bild.

    Ich bin leider ein Anfänger mit Raspberrys benötige aber den RPi 5 für ein projekt in der Uni.

    Danki

  • Raspberry Pi 5 mit Waveshare 7 inch dsi LCD 800x480? Schau mal ob du hier fündig wirst!

  • Hallo oefean,

    willkommen im Forum! :green_smile:

    Ich habe den Display auch mit dem offiziellen Raspberry Pi 15 to 22 Pin verbunden und auch auf die richtige Orientierung geachtet.

    Ich weiß nicht was Du mit 15 to 22 Pin meinst. Falls der DSI-Port gemeint ist, dann achte darauf, dass Du CAM/DSI 1 verwendest und dass beim RPi 5 der Displayport nicht wie beim RPi 4 gegenüber der USB und LAN Ports ist! ... nur zur Sicherheit.

  • hey hyle,

    sorry hab damit das DSI Kabel gemeint. Ja das Kabel ist mit dem CAM/DSI 1 verbunden, trotzdem bleibt das Bild schwarz. Mittlerweile weiß ich dass der Raspberry pi sicher funktioniert, da ich diesen über ssh im Netzwerk ansprechen kann. Laut Waveshare benötige ich keinen Driver. Irgendwelche Ideen wie ich das Display zum Laufen bekomme?

  • Wenn Du das Display an DSI-1 (richtig) verkabelt hast, musst Du in config.txt "dtoverlay=vc4-kms-dsi-7inch" an tauglicher Stelle eintragen, und nicht dtoverlay=vc4-kms-dsi-7inch,dsi1.

    Welches Netzteil verwendest Du, welche Stromverbraucher sind (neben dem Lüfter) angesteckt/eingeschaltet ?

    Steck mal testweise den Lüfter ab.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Hey 👋


    Jupp hab in config.txt „dtoverlay=vc4-kms-dsi-7inch“ eingetragen. Was ist denn die taugliche Stelle ? Waveshare schriebt nur am Ende, also hab ich das nach [All] eingetragen

  • Hey :)

    mittlerweile bekomm ich über dmesg folgende Medlungen

    [ 4.643529] i2c_designware 1f00080000.i2c: controller timed out
    [ 4.643550] rpi_touchscreen_attiny 4-0045: Failed to read REG_ID reg: -5
    [ 4.643560] rpi_touchscreen_attiny: probe of 4-0045 failed with error -5

    Ich weiß leider absolut nicht was das jetzt bedeutet. Ich schätze, dass vielleicht der Display obwohl angegeben von waveshare doch nicht kompatibel ist? Oder gibt es eine Lösung dafür? Treiber benötige ich laut Waveshare für das Display eigentlich nicht aber könnte das helfen oder macht das mehr kaputt?

    Danke

  • Das Netzteil wär das offizielle von Raspberry mit 5V und 5A. Und den Küfter hab ich bereits abgemacht und trotzdem ist es nicht angegangen. Ich hab auch das Versorgungs Kabel zwischen Display und Pins ausgetauscht, trotzdem keine Reaktion von Display

  • Oki Update:

    Der Display funktioniert, danke für die Hilfsbereitschaft!

    Waveshare schreibt auf ihrer Website dass man

    Code
    dtoverlay=vc4-kms-v3d
    #DSI1 Use
    dtoverlay=vc4-kms-dsi-7inch
    #DSI0 Use
    #dtoverlay=vc4-kms-dsi-7inch,dsi0

    in die config.txt hinzufügen musste. Bei mir ging es jetzt nachdem ich zusätzlich noch

    dtoverlay=waveshare-7dsi

    hinzugefügt habe. Sowohl Touch als auch Display funktionieren jetzt gleichzeitig mit Lüfter.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!