Anfaenger braucht hilfe bei nachinstalltion

Heute ist Stammtischzeit:
Jeden Donnerstag 20:30 Uhr hier im Chat.
Wer Lust hat, kann sich gerne beteiligen. ;)
  • Ergebniss ist, die anzeige am Monitor ist die gleiche wie bei vnc.

    Das schrieb ich ja auch schon:

    mit (Real)VNC bist Du auf DISPLAY 0, also siehst Du das, was auf einem angeschlossenen Monitor auch angezeigt würde.


    BTW: Wenn VNC funktioniert, wozu willst Du dann noch RDP?

  • Hallo hole

    Der Grund ist ganz einfach, ich habe bis jetzt alle zugriffe auf alle Rechner mit rdp gemacht, habe dazu extra einen Sprung server auf denen die verbinden abgelegt sind ( zur zeit ca. 34 sessions ). Da dies nicht gerade wenige sind, war vnc hier nur der test ob ich etwas angezeigt bekomme.

    Ziel war fuer mich immer eine rdp zu bekommen.

    Da fuer mich die Konfiguration zwischen den 3 raspi Rechnern an der Stelle gleich ist, 2 richtig arbeiten und nur einer die Probleme mit der Anzeige ( Desktop) hat frage ich mich, wo muss ich was aendern um dies gerade zu ziehen.

    Der Unterschied ist fuer die meldung mit der keymap, da der connect ja bestaetigt wir und ich( wie gesagt ich ) keine einstellungsmoeglichkeit sehe.

    Danke

    Balu

  • hallo und guten morgen zusammn

    hier ein update zu meinen problemen.:

    alle probleme sind fuer mich erledigt !!!

    zur info fuer euch hier ein paar zeilen.

    VNC Problem.:
    =============
    nach installtion, anpassung der autostart waren nicht alle funktion in "sudo raspi-config" freigegeben.
    mit diesen daten konnte ich die funktion IMMER sauber hinbekommen.
    test / nachgestellt auf einem 4 ten raspi !!!!!

    sudo raspi-config

    Display Options => Resolution => "dmt mode 82"
    Display Options => VNC Resolution => aufloesung 1920 x 1080
    System Options => BOOT Autologin => B3 Desktop => anmeldung mit passwd
    Interface Options => VNC => Enable/disable graphical remote access using RealVNC

    alle sessions werden sauber angezeigt.

    XRDP / RDP zugriff.:
    ====================
    einige user hatten mich immer wieder auf display 0 / 10 hingewiesen.
    dies war leider nicht sooooo ganz richtig.

    auf 2 rechner konnte ich immer mit display 10 zugreifen ( via RDP ), nur von einem ging es nicht.
    die loesung ( workaround fuer mich ) ist hier recht simple.

    ich habe mich via RDP nicht mit "pi" sondern mit meinem "samba" user angemeldet.
    dann wurde die RTP session sauber aufgebaut, zwar musste ich mich dann mit pi erneut anmelden, aber egal.
    warum es mit dem user "pi" nicht geht, keine ahnung......

    aber auch in diesem fall mit display 10 !!! .
    test / nachgestellt auf einem 4 ten raspi !!!!!

    Danke an alle
    balu

  • Ich verstehe Dein damaliges Problem mit XRDP immer noch nicht, da man eben XRDP auf dem Pi installiert und vom PC aus mit dem windowseigenen Client darauf zugreift.

    Aber seit TigerVNC bin ich nun auch weg vom XRDP, da ich das Gefühl habe, das TigerVNC hier deutlich schneller läuft.
    Tiger VNC nutze ich, da ich zum einen Wayland und zum anderen darauf obendrauf auch noch mit labwc rumspiele.

    Einzig Chromium läuft noch nicht, dafür der Firefox ohne jegliche Spiränzchen.

    Das normale VNC mochte ich nie und ich weiß auch nicht, ob die Wayland inzwischen endlich im Griff haben.

    ;) Gruß Outi :D
    Pis: 2x Pi B, 1x Pi B+, 1x Pi 2 B in Rente / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 / 2x Pi Zero 1.3 / 2x Pi Zero W 1.1 / 1x Pi Zero 2 (BW+CUPS/SANE) / 1x Pi 3 B+ (Tests) / 1x Pi 4 B 4GB (Tests) / Pi 400 (BW) / 1x Pi 5 8GB (BW) / 2x Pi Pico / 2x Pi Pico W
    HATs: Sense HAT / HM-MOD-RPI-PCB / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT / Pi 5 Kühler HAT / Pimoroni NVMe BASE
    Cams: orig. Raspberry Pi Camera Module V1 & V3 / PS3 Eye

  • hallo outlaw

    das ist richtig,

    anforderung / ursprung war, xrdp auf den pi*s installiert und von windows drauf zugreifen ( sprung server ).

    dies ging bei 2 von 3 raspberrys, einer hatte probleme ( erklaerung oben )

    daraufhin vnc installiert / aktiviert, dies ging auch bei 2 von 3 raspberrys. problem raspberry war jedoch ein anderer. ( erklaerung oben )

    es wurde drauf hingewiesen display 10 , ist das problem, leider nicht ganz ok....... ( war fehlender parameter in rasp-config / erklaerung oben )

    problem mit dem rdp windows zugriff ist der user "pi". nach windows anmeldung mit dem "samba" user und umschalten auf user "pi" ist alles ok ( workaround der mir reicht )

    warum der user pi an dieser stelle nicht richtig arbeitet, weiss ich nicht

    gruss

    balu

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!