Bildschirm schaltet sich aus

Heute ist Stammtischzeit:
Jeden Donnerstag 20:30 Uhr hier im Chat.
Wer Lust hat, kann sich gerne beteiligen. ;)
  • Ich habe ein ein Programm auf meinem Raspberry Pi laufen, welches nach dem Start automatisch eine Website öffnen soll im Kiosk Modus. Leider geht der Bildschirm alle 20 Sekunden aus, wenn ich die Maus bewege, und geht danach automatisch wieder an. An dem Bildschirm liegt es nicht, da es mit anderen Bildschirmen genauso ist. Wisst ihr wodran es liegen könnte ?

  • Wisst ihr wodran es liegen könnte ?

    Erst einmal Willkommen hier im Forum.

    Um die Frage überhaupt beantworten zu können, solltest du zunächst einige Informationen preisgeben.

    • Welchen Pi hast du?
    • Welches "Netzteil" nutzt du? Am besten mit Foto oder Link.
    • Was ist alles am Pi angeschlossen?
  • Ich habe den pi 4 mit dem mitgelieferten Standart Netzteil.

    Hast du ein Foto davon, oder eienn Link zu dem Netzteil?
    Ein mitgeliefertes "Standard-Netzteil" ist nicht immer ein kompatibles Netzteil, oder schlimmstenfalls ein Ladegerät. Das mag ein Pi gar nicht.
    Viele Händler verkaufen im Bundle ein angebliches "original Netzteil", was es aber nicht ist.

  • Seltsam! Dann nimmt es dieser Hersteller wohl nicht so genau mit seinen Angaben.

    Wie auch immer! Das ist trotzdem nicht geeignet für einen RPi4, denn der will 5,1V und das stabil.

    Wir empfehlen hier immer die offiziellen Netzteile für das jeweilige RPi Modell. Im Fall eines RPi 4 wäre das dieses hier: https://www.raspberrypi.com/products/type-c-power-supply/ (Achte dabei auf EU, wegen des richtigen Netzsteckers, falls Du eins kaufen willst!)

    //Edit

    Im Lexikon-Eintrag für Netzteil ist auch ein passendes verlinkt.

  • Vermutlich ist nur etwas bei deinen DPMS Einstellungen für den Monitor falsch konfiguriert. Entweder schaut man mal in den Einstellungen fürs Energiemanagement nach, bzw. falls die Abfrage im Terminal mit

    xset -q

    plausible Werte für DPMS anzeigt, könnte man das DPMS auch testweise mal deaktivieren mit

    sudo xset s off -dpms

    Edited once, last by Fliegenhals (June 9, 2024 at 7:46 PM).

  • hyle
    Der Pi will nicht immer 5,1V.
    Bitte nicht immer dieses Foundationmärchen wiederholen.

    Ich habe mir zum Test mal den Spannungsbereich bis zu 4,5V "runtergedreht", mit folgendem Ergebnis:
    Der Pi 5 lief mit einigem angeschlossenem Zubehör bis runter zu 4,8V dauerhaft ohne Probleme.
    Ob das nun Glück war, wage ich zu bezweifeln, denn diese Tests mache ich immer, wenn ich neue Pis rein bekomme.
    Lass es auch mal 4,9V sein aber dieses strickte Bestehen auf 5,1V hat andere Gründe, die auch nachvollziehbar sind.

    Treten aber Probleme mit Chinaböllern und/oder Handyladegräten auf, liegt das garantiert nicht an den gelieferten "nur 5,0V", sondern diese sind nicht laststabil.
    Tritt der Pi dabei auch nur leicht aus dem IDLE heraus, fangen die NoNames an zu schwitzen und zu schwanken.

    Nehmen wir an, es gäbe NoName 5,1V Kracher, ich wette mit Dir, der Pi 5 würde genauso abkacken, 100%ig.

    Deine Aussage würde ich eher dahingehend bestätigen, dass der Pi ein unter Last stabiles Netzteil will, das mit den 0,1V kannste ruhig streichen.

    Jetzt kommt aber der trotzdem auch mein Rat zum originalen 5,1V Netzteil, aber nicht wegen der 0,1V mehr Spannung:
    Das Ding ist qualitativ hochwertig UND preislich so attraktiv, dass sich Ladegeräte oder "Mitgeliefertenetzteile" einfach nicht mehr lohnen.

    Ok, mir fiel vor Kurzem auch die Kinnlade herunter, als ich sah, dass manche Shops bis zu 22€ für das Teil verlangen aber vorhin habe ich es bei einem Preisvergleicher im Schnitt für 14€ gesehen, bei einem sogar für um die 10€.
    Meins habe ich noch für 8€ bekommen, hatte wohl Glück.

    Daher lasst uns die Aussage 5,1V nicht als Heilmittel argumentieren, sondern generell das originale Foundation Netzteil, das auch mit 5,0V einwandfrei funktionieren würde.
    Die früheren originalen Netzteile hatten auch nur 5,0V und die Foundation hat die 0,1V nur deshalb drauf gepackt, weil diverse Poweruser halt alles mögliche angeklemmt haben, was eigentlich ein eigenes Netzteil benötigt hätte aber gerade noch so (mit Abstrichen) funktioniert hat.
    Der weitere weniger wichtige Punkt für die 0,1V mehr ist halt auch ein wenig Eigennutz der Foundation, denn keiner der NoNames traut sich 5,1V Netzteile nur für den Pi herzustellen, da sie Angst haben, sie könnten alle anderen Geräte killen und/oder in Regress genommen werden, wenn sie nicht darauf hinweisen, dass nur 5,1V Geräte angeschlossen werden dürfen und die Probleme eigentlich am beschi**enen Design des vermurksten Ladegeräts liegen.

    So, habe fertig. 8o:D

    PS: Die Foundation schreibt im eigenen Product Brief sogar nur von 5,V/5A ....
    (Die 0,1V kann man als nützliche Reserve verbuchen, weniger als Muss.)

    Nachtrag:
    Für einige Tests habe ich den Pi 5 sogar an meinem Mainboard (USB-C-Ausgang mit 3A) angeklemmt.
    Erst war es nur für meine Anleitungen zum direkten Flashen aufgesteckter NVMes mit dem Imager.
    Das lief aber so gut, dass ich den Pi für viele Aktionen nur noch an diesem "Lade-/Datenport" betreibe, da der Weg zur Steckdosenleiste kürzer ist.
    Selbst bei stundenlangen Aktionen auf selbigem, lief er mit 4,9V bis 5,0V bei 3A ohne irgendwelche Probleme.

    So, jetzt habe ich wirklich fertig.

    ;) Gruß Outi :D
    Pis: 2x Pi B, 1x Pi B+, 1x Pi 2 B in Rente / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 / 2x Pi Zero 1.3 / 2x Pi Zero W 1.1 / 1x Pi Zero 2 (BW+CUPS/SANE) / 1x Pi 3 B+ (Tests) / 1x Pi 4 B 4GB (Tests) / Pi 400 (BW) / 1x Pi 5 8GB (BW) / 2x Pi Pico / 2x Pi Pico W
    HATs: Sense HAT / HM-MOD-RPI-PCB / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT / Pi 5 Kühler HAT / Pimoroni NVMe BASE
    Cams: orig. Raspberry Pi Camera Module V1 & V3 / PS3 Eye

    Edited once, last by Outlaw: Nachtrag (June 10, 2024 at 1:07 AM).

  • Der Pi 5 lief mit einigem angeschlossenem Zubehör bis runter zu 4,8V dauerhaft ohne Probleme.

    Und genau das ist der Grund für die 5,1V

    Das offizielle Netzteil der Foundation hat eine Lastregelung von +- 5%

    Quelle Produktbrief auf raspberrypi.com

    Das heißt, bei 5V wären das Schwankungen zwischen 4,75 - 5,25V, was im unteren Bereich unter deinen getesteten 4,8V liegt.
    Somit sind die 0,1V mehr als Sicherheit gedacht.

    Bei 5.1V liegt die Spanne immerhin zwischen 4,85 und 5,35V


    //EDIT

    denn keiner der NoNames traut sich 5,1V Netzteile nur für den Pi herzustellen,

    Wie kommst du darauf?

    hier Pi5 [Anzeige]

    hier Pi3 / Pi4 mit praktischem Ausschalter und USB-Adapter [Anzeige]

    hier Pi5 [Anzeige]

  • Leider ist diese Formulierung durch die Kommasetzung zweideutig.

    ... Leider geht der Bildschirm alle 20 Sekunden aus, wenn ich die Maus bewege, und geht danach automatisch wieder an. ...

    Geht der Bildschirm immer alle 20 Sekunden aus und wenn Du die Maus bewegst wieder an? ( -> Energiemanagement )

    Oder geht der Bildschirm alle 20 Sekunden aus wenn du die Maus bewegst? ( -> evtl. Netzteil ungeeignet )

  • Franjo G

    Quote

    Und genau das ist der Grund für die 5,1V

    Nein, ist es nicht, jedenfalls nicht direkt.
    Ob das Netzteil nun 5,0V oder 5,1V oder 6,0V liefert, ist egal, wenn der Pi nachher unter Last mit 4,8V oder 4,9V oder 5,0V läuft.

    Ich stimme Deinen Aussagen ja auch zu, meine gehen in die gleiche Richtung.
    Mich stört nur das immer wieder auftauchende Runtergebete, der Pi braucht 5,1V, was eben nicht stimmt, steht auch im Product Brief des Pi 5, welches den Eingang mit 5V angibt. PB => raspberry-pi-5-product-brief.pdf (raspberrypi.com)

    Mein Mainboard liefert auch "nur 5V" und der Pi kommt da unter Last auch oft auch 4,9V bis 4,8V (ist halt ein aus technischer Sicht gesehen ein "mieses Ladeteil") aber diese leichte Unterspannung wird dann auch dauerhaft gehalten, heißt: geht unter Last nicht noch weiter runter.

    Fazit: Es wird 5V geliefert, bricht manschmal bis auf 4,8V ein und der Pi läuft trotzdem dauerhaft an diesem Port.

    Wie Du sehe ich die 5,1V auch als nützliche Reserve aber auch als KEIN Muss ....
    Der Pi läuft auch an 5V sehr stabil, wenn das Netzteil eine gescheite Elektronik hat, was man ja so gut wie bei fast allen NoNames verneinen kann.

    ;) Gruß Outi :D
    Pis: 2x Pi B, 1x Pi B+, 1x Pi 2 B in Rente / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 / 2x Pi Zero 1.3 / 2x Pi Zero W 1.1 / 1x Pi Zero 2 (BW+CUPS/SANE) / 1x Pi 3 B+ (Tests) / 1x Pi 4 B 4GB (Tests) / Pi 400 (BW) / 1x Pi 5 8GB (BW) / 2x Pi Pico / 2x Pi Pico W
    HATs: Sense HAT / HM-MOD-RPI-PCB / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT / Pi 5 Kühler HAT / Pimoroni NVMe BASE
    Cams: orig. Raspberry Pi Camera Module V1 & V3 / PS3 Eye

  • Eben Upton schrieb hatte hier mal auf eine Frage zum RPi 3B+ folgendes geantwortet:

    Quote

    That’s useful feedback. Informally, what matters is the supply’s minimum voltage under high, and rapidly varying load. Limits:

    – our voltage throttle cuts in and drops the CPU speed at 4.6V
    – many USB devices need at least 4.5V
    – our PMIC shuts down at 4V

    So a very stable 4.75V supply is preferable to a poorly regulated 5.2V. The official power supply is “special” because it has a slightly boosted zero-load voltage, good regulation under varying load, and thick wire (I kid you not) to minimise cable losses.

    Hier die Frage + Antwort: https://www.raspberrypi.com/news/raspberry…comment-1415149

    Aber dies Diskussion bringt hier keinen weiter, also bitte BTT!

  • hyle
    Dann behaupte bitte auch nicht weiter, dass 5,1V vom Pi verlangt werden, dann entstehen solche Diskussionen nicht.

    Quote

    denn der will 5,1V und das stabil.

    Der will laut Spezifikation 5V und die Aussage von Eben bezieht sich eben darauf, dass er gescheite Elektronik verwendet.

    Er zieht laut Deinem Zitat sogar eine stabile 4,75V Versorgung einer schlechten 5,2V Versorgung vor.
    Das Besondere seiner Netzteile ist eben die Garantie der stabilen Unterversorgung und auf den Grund der Verwendung der 5,1V wird überhaupt nicht eingegangen.

    ;) Gruß Outi :D
    Pis: 2x Pi B, 1x Pi B+, 1x Pi 2 B in Rente / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 / 2x Pi Zero 1.3 / 2x Pi Zero W 1.1 / 1x Pi Zero 2 (BW+CUPS/SANE) / 1x Pi 3 B+ (Tests) / 1x Pi 4 B 4GB (Tests) / Pi 400 (BW) / 1x Pi 5 8GB (BW) / 2x Pi Pico / 2x Pi Pico W
    HATs: Sense HAT / HM-MOD-RPI-PCB / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT / Pi 5 Kühler HAT / Pimoroni NVMe BASE
    Cams: orig. Raspberry Pi Camera Module V1 & V3 / PS3 Eye

  • Ich behaupte, dass sich die Entwickler etwas bei den 5,1V gedacht haben.

    Die früheren originalen Netzteile hatten auch nur 5,0V

    ... bis man den RPi 3B entwickelte.

    die Foundation hat die 0,1V nur deshalb drauf gepackt, weil diverse Poweruser halt alles mögliche angeklemmt haben, was eigentlich ein eigenes Netzteil benötigt hätte aber gerade noch so (mit Abstrichen) funktioniert hat.

    Da würde mich die Quelle interessieren. Wenn das wirklich der Grund sein sollte, warum hat man da nicht noch ein Pfund drauf gelegt und auf 5,5V erhöht oder gleich auf 12V mit Hohlstecker? :conf:

    //Edi

    Sorry, hatte ich vergessen:

    auf den Grund der Verwendung der 5,1V wird überhaupt nicht eingegangen.

    Quote

    it has a slightly boosted zero-load voltage

    Vielleicht verstehe oder übersetze ich "zero-load voltage" auch falsch, aber ich verstehe darunter "Leerlaufspannung".

  • Das mit dem originalen NT ist wohl auch eine Art "Glaubensfrage" sowie der Eine oder andere der Meinung ist, das z.B. sein Auto nur mit dem org. Motoröl des Herstellers gut fährt. Die 0,1V Spannungsunterschied könnten evtl. so manchen davon abhalten, einfach irgendein passendes NT am RPI zu verwenden. Der RPi läuft prima auch unter Last mit stabilen 5V, wobei der Vergleich mit dem PC Netzteil etwas hinkt, da auf einem gutem Mainboard u.U. viele Kondensatoren verbaut sind, welche Spannungsschwankungen ausgleichen. Der RPi ist halt materialtechnisch auf ein Minimum an HW reduziert, so das eine unzureichende SV unmittelbare Auswirkungen auf die Stabilität des Systems hat.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!