Updateserver Debian nicht erreichbar

Heute ist Stammtischzeit:
Jeden Donnerstag 20:30 Uhr hier im Chat.
Wer Lust hat, kann sich gerne beteiligen. ;)
  • Vielleicht eine dumme Frage eines Raspi-Anfängers.

    Ich habe einen Raspi 4 und benutze diesen mit AdGuard an einer Fritzbox 6690 als Werbeblocker. Das läuft schon seit gut 6 Monaten und klappt auch vorzüglich. Jedoch klappt seit einiger Zeit die manuell angestoßene Updateprüfung des Debian/Linux nicht mehr. Ich habe keine bewusste Änderung gemacht.
    Ich logge mich über die Windows Poweershell mit ssh 192... ein, passwort... ein. Dann sudo apt update. Es folgt:

    ****@RasPi-AdGuard:~ $ sudo apt update
    Ign:1 http://deb.debian.org/debian bookworm InRelease
    Ign:2 http://archive.raspberrypi.com/debian bookworm InRelease
    Ign:3 http://deb.debian.org/debian-security bookworm-security InRelease
    Ign:2 http://archive.raspberrypi.com/debian bookworm InRelease
    Ign:4 http://deb.debian.org/debian bookworm-updates InRelease
    Ign:2 http://archive.raspberrypi.com/debian bookworm InRelease
    Ign:1 http://deb.debian.org/debian bookworm InRelease
    Err:2 http://archive.raspberrypi.com/debian bookworm InRelease
    Temporary failure resolving 'archive.raspberrypi.com'
    Ign:3 http://deb.debian.org/debian-security bookworm-security InRelease
    Ign:4 http://deb.debian.org/debian bookworm-updates InRelease
    Ign:1 http://deb.debian.org/debian bookworm InRelease
    Ign:3 http://deb.debian.org/debian-security bookworm-security InRelease
    Ign:4 http://deb.debian.org/debian bookworm-updates InRelease
    Err:1 http://deb.debian.org/debian bookworm InRelease
    Temporary failure resolving 'deb.debian.org'
    Err:3 http://deb.debian.org/debian-security bookworm-security InRelease
    Temporary failure resolving 'deb.debian.org'
    Err:4 http://deb.debian.org/debian bookworm-updates InRelease
    Temporary failure resolving 'deb.debian.org'

    Diese "temporäre" Störung liegt nun schon seit mehr als 4 Wochen an. Komischerweise läuft das bei meinem Bruder, der allerdings wo anders wohnt.
    Wo liegt der Fehler, bzw. was mache ich falsch? Vor ein paar Monaten hat das aber funktioniert.

    Vielen Dank für Hilfe!

  • Temporary failure resolving 'deb.debian.org'

    Diese "temporäre" Störung liegt nun schon seit mehr als 4 Wochen an.

    Wie sind die Ausgabe von:

    Code
    cat /etc/resolv.conf
    host -v -t a ulm.de
    host -t a berlin.de 1.1.1.1
    host -t A -T koeln.de 1.1.1.1
    nc -zv 1.1.1.1 53
    ip r g 1.1.1.1

    ?

    EDIT:

    Evtl. auch ein dnsleaktest (... wegen apt, via Kommandozeile und nicht via Browser) machen und das Ergebnis (richtig anonymisiert) hier posten. Z. B.:

    Code
    :~$ ./dnsleaktest.sh
    Your IP:
    109.###.###.### [Germany, AS3209 Vodafone GmbH]
    
    You use 2 DNS servers:
    2a05:fc84:0:5::119 [Switzerland, Swiss Confederation, AS57118 CommunityRack.org Verein]
    185.95.216.119 [Switzerland, Swiss Confederation, AS57118 CommunityRack.org Verein]
    
    Conclusion:
    DNS may be leaking.

    Wi-Fi_Signal_Strength  txpower
    iptables chains order scheme iptables-diagram
    nftables-diagram

    Meine PIs

    PI4B/8GB (border device) OpenBSD 7.5 (64bit): SSH-Server, WireGuard-Server, ircd-hybrid-Server, Mumble-Server

    PI3B+ FreeBSD 14.0-R-p7 (arm64): SSH-Serv., WireGuard-Serv., ircd-hybrid-Serv., Mumble-Serv., ddclient

    PI4B/4GB Bullseye-lite (64bit; modifiziert): SSH-Server, WireGuard-Server, ircd-hybrid-Server, Mumble-Server, botamusique, ample

    Edited 2 times, last by rpi444 (June 21, 2024 at 4:23 PM).

  • Ja, diesen benutze ich. Wenn jemand was besseres oder gleichwertiges hat bzw. kennt, dann evtl. hier zeigen/posten.

  • Wie sind die Ausgabe von:

    root@RasPi-AdGuard:~# cat /etc/resolv.conf

    # Generated by NetworkManager

    search fritz.box

    nameserver 192.168.178.29

    nameserver fd00::49b:60a8:e7ab:xxxx

    nameserver fd00::1eed:6fff:fe76:xxxx


    root@RasPi-AdGuard:~# host -v -t a ulm.de

    -bash: host: command not found

    ...


    root@RasPi-AdGuard:~# nc -zv 1.1.1.1 53

    -bash: nc: command not found

    ...


    root@RasPi-AdGuard:~# ip r g 1.1.1.1

    1.1.1.1 via 192.168.178.1 dev eth0 src 192.168.178.9 uid 0

    cache


    PS: Ich habe mit der Einrichtung eine laufende SD geklont und diese auch getestet. Nun habe ich diese SD (nach poweroff) gewechselt und auch nach Neustart der Fritzbox meldet AdGuard - keine Verbindung ins Internet. Obwohl feste IP des Raspi vergeben.

  • PS: Ich habe mit der Einrichtung eine laufende SD geklont und diese auch getestet. Nun habe ich diese SD (nach poweroff) gewechselt und auch nach Neustart der Fritzbox meldet AdGuard - keine Verbindung ins Internet. Obwohl feste IP des Raspi vergeben.

    Evtl. ist AdGuard nicht richtig konfiguriert.
    Wie ist die Ausgabe von:

    Code
    ping -c 3 1.1.1.1

    ? Versuch mal Folgendes:

    Code
    sudo rm /etc/resolv.conf
    Code
    sudo nano /etc/resolv.conf

    Inhalt:

    Code
    domain fritz.box
    search fritz.box
    options ndots:1 edns0 single-request single-request-reopen rotate
    nameserver 192.168.178.1

    Nach dem speichern von /etc/resolv.conf und nach dem schließen von nano:

    Code
    sudo chattr +i /etc/resolv.conf
    lsattr /etc/resolv.conf

    Danach:

    Code
    sudo apt update
    sudo apt full-upgrade
    sudo dpkg --configure -a
    sudo apt autoremove
    sudo apt install bind9-dnsutils netcat-traditional
    sudo dpkg --configure -a
    sudo apt -f install
  • Sorry für langes Nichtmelden, aber krankheitsbedingt war ich nicht so oft online.

    Ich habe nun einfach mehrere neue SD-Karten neu konfiguriert. Das ist einfacher, als diese Fehlersuche, zumal ich mich mit Linux nicht auskenne.

    Eine Frage sei mir vielleicht noch gestattet:

    Bislang hatte ich dem Raspi manuell eine feste IP vergeben, damit bei evtl. Routerwechsel die IP-Konfiguration unberücksichtigt bleiben kann, sofern man bei Fritzbox bleibt. (Also feste IP < .... 20). So habe ich das auch mit meinen Druckern und anderen Netzwerkkram gemacht.

    Was mich ein bisschen verwundert sind Anleitungen zum Einrichten eines Raspi mit PiHole bzw. AdGuard, die allesamt den Raspi eine IP per DHCP nehmen, und diese dann im Router fixen. (Diesem Gerät immer diese IP zuweisen...).

    Hat das einen besonderen Grund, denn dieses Verfahren halte ich für nachteilig? Denn wenn der Router getauscht oder zurückgesetzt wird, muss man daran denken und kümmern.

  • Hat das einen besonderen Grund, denn dieses Verfahren halte ich für nachteilig? Denn wenn der Router getauscht oder zurückgesetzt wird, muss man daran denken und kümmern.

    Naja, man muss dann daran denken bzw. berücksichtigen, dass diese Geräte/DHCP-Clients (... die bzgl. zuzuweisende IP-Adresse einen "Wunsch äußern"), als erste bzw. in einer bestimmten Reihenfolge an den neuen oder an den zurückgesetzten Router, angeschlossen werden. Das Subnetz des neuen/zurückgesetzten Router sollte sich auch nicht ändern.

  • Mir ist auch unverständlich, warum nicht schon mit der Installation über den Pi-Imager die Möglichkeit der Wahl zwischen DHCP und wählbarer IP fehlt, da ansonsten ja einiges vorwählbar ist.

    Es dürfte eigentlich Standard sein, wenn man feste Netzwerkgeräte, wie Drucker, Scanner, NAS usw. eine feste IP vergibt und die PC, sowie alles was über WLan reinkommt, auf DHCP belässt.

  • Es dürfte eigentlich Standard sein, wenn man feste Netzwerkgeräte, wie Drucker, Scanner, NAS usw. eine feste IP vergibt und die PC, sowie alles was über WLan reinkommt, auf DHCP belässt.

    In manchen Foren wird das "DHCP oder nicht DHCP" sehr emotional diskutiert. Ich denke wichtig ist, dass man weiß was man tut.

  • Wenn DNS funktioniert kann man alles per DHCP machen.

    Sicher läuft das, aber wenn man die Geräte per Webinterface ansprechen will, muss man die IP wissen. Dann müsste man immer erst im Router nachschauen, welche IP zugeteilt wurde.

    Es ist ja auch die Frage, ob zugehörige Treiber bei wechselnde IP klarkommen, habe ich nicht getestet. Das insbesondere bei Netzwerkdruckern und Scannern.

    Ich finde es besser den Geräten eine feste zuzuweisen. Die ist dann immer gültig, selbst wenn der Router gewechselt oder rückgesetzt wird, zumal bei allen Fritzboxen der DHCP-Bereich immer gleich ist. Der ist bekanntlich von ... 20 bis 200 definiert.

  • Was mich ein bisschen verwundert sind Anleitungen zum Einrichten eines Raspi mit PiHole bzw. AdGuard, die allesamt den Raspi eine IP per DHCP nehmen, und diese dann im Router fixen. (Diesem Gerät immer diese IP zuweisen...).

    Die feste IP Vergabe im Router stellt sicher, dass alle Clients automatisch die gleichen Parameter erhalten. Wenn du deine Geräte von Hand konfigurierst, schleichen sich schnell mal Fehler ein. Außerdem werden gerade die Netzwerkmanager umgestellt. Wärend auf dem neuesten Raspi Image mit GUI noch der DHCPCD läuft, kommen die Lite-Versionen schon mit dem Networkmanager daher. Beide funktionieren völlig unterschiedlich und die dhcpcd.conf ist mit dem Networkmanager nicht kompatibel. Wenn du also von einem alten Buster oder Bullseye auf Bookworm upgradet hast, dann kann das schon die Ursache für dein Problem sein.

    01000001011011000110110001100101 01110011011010010110111001100100 0110010001101111011011110110011000101100 011000010111010111000011100111110110010101110010 0100110101110101011101000111010001101001 :saint:

  • Wenn du also von einem alten Buster oder Bullseye auf Bookworm upgradet hast, dann kann das schon die Ursache für dein Problem sein.

    Danke für den Hinweis.

    Das wird es wohl sein. Ich habe im Dez 2023 erstmals mit dem Raspi und PiHole experimentiert. Irgendwann Jan/Feb 2024 die SD neu eingerichtet und AdGuard installiert. Dann hat das manuelle Update des Debian auch einige Zeit funktioniert. Und tatsächlich, wie die Videos für die AdGuard-Installation auch immer empfehlen, habe ich die Lite-Version installiert, da ich meinen Raspi 4 für nichts anderes benutze.

  • Ich habe nun einfach mehrere neue SD-Karten neu konfiguriert. Das ist einfacher, als diese Fehlersuche, ...

    Installiere auch die Tools netcat, host, dig, nslookup, ..., für den Fall, dass nach Fehler gesucht werden muss bzw. wieder Probleme auftreten.

  • Wenn DNS funktioniert kann man alles per DHCP machen.

    Sicher läuft das, aber wenn man die Geräte per Webinterface ansprechen will, muss man die IP wissen. Dann müsste man immer erst im Router nachschauen, welche IP zugeteilt wurde.

    Du schaust also immer nach der IP wenn du hier das Forum öffnest ?

    Sorry, aber zu deiner Aussage fällt mir jetzt nix mehr ein.

    Offizieller Schmier und Schmutzfink des Forum.

  • ... ansprechen will, muss man die IP wissen. Dann müsste man immer erst im Router nachschauen, welche IP zugeteilt wurde.

    Nicht jeder hat Zugang zum Web-IF vom Router. IP-Adressen bzw. hostnamen der Geräte im Subnetz (W/LAN) des Routers, kann man auch mal schnell mit z. B.:

    Code
    arp-scan -I <Interface> -l; arp -av

    (oder gleichwertig) feststellen/bekommen.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!