Nach Android Update kein Zugriff auf Apache 2

Heute ist Stammtischzeit:
Jeden Donnerstag 20:30 Uhr hier im Chat.
Wer Lust hat, kann sich gerne beteiligen. ;)


  • http wird in der /etc/apache2/site-available/000-default.conf konfiguriert.
    https in der /etc/apache2/site-available/000-ssl-default.conf

    Quote

    AH00526: Syntax error on line 11 of /etc/apache2/sites-enabled/000-default.conf:
    Invalid command 'SSLEngine', perhaps misspelled or defined by a module not included in the server configuration
    Action 'configtest' failed.
    The Apache error log may have more information.

    SSLEngine wird also in der 000-ssl-default.conf konfiguriert und nicht in der 000-default.

    Offizieller Schmier und Schmutzfink des Forum.

  • Ich möchte mich bei euch allen ganz herzlich bedanken.
    Und ganz besonders Bergwichtel für seine Geduld mit mir.
    Aber dadurch habe ich wieder einiges gelernt.

    Aber das interessante ist, das die anderen Raspy die ich noch habe, wo ich auch nicht mehr drauf kam., ab heute wieder funktionieren.
    Anscheind hat mein Handy heute Nacht ein Update bekommen und irgend etwas haben die wieder verändert.

    Aber so bin ich auf der sicheren Seite wenn die wieder etwas verändern.

  • http wird in der /etc/apache2/site-available/000-default.conf konfiguriert.
    https in der /etc/apache2/site-available/000-ssl-default.conf

    Kann man so machen, muß man aber nicht. Da die Ausgabe für http und https gleich sein soll, kann man das mit einem kleinen Trick anders handhaben, was den Vorteil hat, das jede Änderung sich auf http und https auswirkt.
    Siehe dazu #14.

    Wenns ner net G'wittern tun tut.

  • Kann man so machen, muß man aber nicht. Da die Ausgabe für http und https gleich sein soll, kann man das mit einem kleinen Trick anders handhaben, was den Vorteil hat, das jede Änderung sich auf http und https auswirkt.
    Siehe dazu #14.

    Und dann hast du die SSL Config auf einmal 2x , einmal in der .inc und einmal in der .conf , was den Fehler in #17 geworfen hat.

    Offizieller Schmier und Schmutzfink des Forum.

  • Und dann hast du die SSL Config auf einmal 2x , einmal in der .inc und einmal in der .conf

    Nein, denn in der mit der Installation mitgebrachten Beispiel-Konfig sind alle SSL-Einstellungen inaktiv. Sie wurde nicht relevant editiert, nur die Dateierweiterung wurde umbenannt. In der selbst erstellten 000-default.conf wurden für http und https die gleiche Konfiguration (000-default.inc) als Include eingebunden. Diese Include-Datei enthält keinerlei SSL-Konfiguration. Es wird nur in der 000-default.conf beim Virtuellen Host für Port 443 SSL konfiguriert.

    Quote from Der_Imperator

    was den Fehler in #17 geworfen hat.

    Nein. Da zu dem Zeitpunkt das SSL-Modul noch nicht aktiviert war, wurde die Fehlermeldung [AH00526:] erzeugt.
    Das erkannte der OP ja auch selbst und hat es aktiviert, wodurch diese Fehlermeldung nicht mehr erzeugt wurde.
    Die letzte Fehlermeldung [AH00558:] habe ich ja in #14 bereits vorhergesagt, habe deren Beseitigung aber bewußt auf später verschoben.

    Wenns ner net G'wittern tun tut.

  • Dann schau mal in #13 genau nach.
    In beiden Files "SSLEngine on"

    Das ist zwar richtig, aber die default-ssl.conf ist nicht enabled.
    Hinzukommt, das der OP mich mißverstanden hat. Ich hatte darauf hingewiesen, das man mit verschiedenen Include-Configs völlig verschiedene Inhalte zwischen Port 80 und 443 ausgeben kann. Das er die Demo-Konfig für SSL includiert, habe ich nicht vorausgesehen.
    In #14 habe ich das erkannt und auch die Includierung von der 000-default.inc (was die umbenannte 000-default.conf mit als auf Kommentar geänderten Virtual-Host-Tags) für Port 80 und Port 443 vorgeschlagen.

    Die von Dir angesprochene Fehlermeldung entstand danach, nachdem der OP die 000-defaultconf entsprechend meinem Vorschlag angepaßt hat (#17). Und das beruhte eindeutig darauf, daß das SSL-Modul noch nicht aktiviert war. Ich hatte vorher schlicht vergessen, die Aktivierung zu erwähnen. Das ist in #17 gut nachzuvollziehen.

    Wenns ner net G'wittern tun tut.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!