sh Script startet nicht bei Autostart

Heute ist Stammtischzeit:
Jeden Donnerstag 20:30 Uhr hier im Chat.
Wer Lust hat, kann sich gerne beteiligen. ;)
  • Hallo zusammen,

    ich hänge hier an einem digitalen Bilderrahmen für den Kindergarten.

    Ich habe ein simples Script welches beim Autostart starten soll und die Bilder des Vortags von einem USB Stick aus starten soll:

    Bash: slideshow.sh
    #!/bin/bash
    DISPLAY=:0.0 XAUTHORITY=home/Kindergarten/.Xauthority /usr/bin/fehl -q -p -Z -F -R 60 -Y -D 10.0 /media/Kindergarten/USB-STICK/


    die rc.local habe ich mit nano folgendermaßen bearbeitet:

    Über bash lässt sich das Script starten.

    Wenn ich mich auslogge und wieder einlogge funktioniert es ebenfalls.

    Kann mir hier jemand weiterhelfen?

  • Ich würde es einmal so probieren ...

    Code
    DISPLAY=:0.0 XAUTHORITY=/home/Kindergarten/.Xauthority /usr/bin/feh -q -p -Z -F -R 60 -Y -D 10.0 /media/Kindergarten/USB-STICK/

    1. die XAUTHORITY Variable braucht einen / Am Anfang sonst wird das File im aktuellen Verzeichnisbaum gesucht.

    2. das Anzeigeprogramm lautet feh und nicht fehl

    3. Der Befehl darf erst dann ausgeführt werden wenn das X-System schon läuft. Hast du kein X am Laufen bekommst du die Meldung
    "feh ERROR: Can't open X display. It *is* running, yeah?"
    Diese siehst du aber u.U. nicht.


    viel Spass ich hoffe es hilft Dir

    Meine Antwort ist 21 und nicht 42. Oder anders gesagt: 0001 0101 statt 0010 1010

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!