[Waiting for Headers] Problem

  • Hallo!


    Ich habe den Raspberry Pi erst seit Weihnachten und komme bei der Einrichtung der Internetverbindung einfach nicht weiter.


    Auf dem Raspberry läuft das Raspian Wheezy, das hat alles geklappt. Mein Laptop geht über W-Lan ins Internet, mittels einer Netzwerkbrücke kann ich das Internet auch auf den Raspberry übertragen. (Laptop und Raspberry sind über LAN-Kabel verbunden)


    Das verrückte ist: ich kann mit dem Midori Browser im Internet surfen. Aber ich schaff es nicht neue Software zu installieren! Immer wenn ich:

    sudo apt-get update
    sudo apt-get upgrade
    etc.


    eingebe, kommt:


    "0% [Waiting for Headers] [Waiting for Headers]"


    und dabei bleibt es dann, bis ich abbreche. Da mein Schreibtisch in einem anderen Zimmer ist als der Router kann ich nicht direkt über den Router ins Internet. Ich habe vorher noch nie Linux benutzt! Evtl. gibt es noch einen anderen Weg den ich nicht kenne?!?


    Danke!

  • Wie hast du denn die Netzwerkbrücke eingerichtet? apt nutzt http aber auch teilweise ftp zur Übertragung der Daten. Hast du eventuell nur eine Webproxy installiert?


    Ggf kannst du ja auch mai deine Netwerk-Konfig posten...


    Mit den aktuellen Informationen ist es mehr raten als Fehlersuchen. ;)


    VG,
    S-E-A

    "The best way to predict your future is to create it!"

  • Wäre super wenn du mal die Config vom Pi und die deines Rechnes Postest also auch die der Netzwerkbrücke.


    evtl hast du ja da ein filter drin oder so...
    oder oder oder oder....

  • Danke für die Antworten! :rolleyes:


    Entschuldigt das superdoofe fragen, aber:


    Wie komme ich den an die beiden 'config'???


    (Die Netzwerkbrücke habe ich nur über die Systemsteuerung von windows eingerichtet.)

  • Auf dem RPI:


    Code
    sudo ifconfig
    sudu route
    sudo cat /etc/networking/interfaces
    sudo cat /etc/resolv.conf


    Auf dem Windows Rechner:


    Start >> Ausführen >> cmd


    Code
    ipconfig /all


    Und mal die Ausgaben hier posten... ;)

    "The best way to predict your future is to create it!"

    Edited once, last by s-e-a ().

  • Alles Klar! Habe ich gemacht. Die Ausgaben sehen wie folgt aus:


    ..................................................................WINDOWS:


    Windows-IP-Konfiguration


    Hostname. . . . . . . . . . . . . : user-oq58nakdnx
    Primäres DNS-Suffix . . . . . . . :
    Knotentyp . . . . . . . . . . . . : Hybrid
    IP-Routing aktiviert. . . . . . . : Ja
    WINS-Proxy aktiviert. . . . . . . : Nein
    DNS-Suffixsuchliste . . . . . . . : Speedport_W_700V


    Ethernetadapter Drahtlose Netzwerkverbindung:


    Verbindungsspezifisches DNS-Suffix: Speedport_W_700V
    Beschreibung. . . . . . . . . . . : Intel(R) PRO/Wireless 3945ABG Network
    k Connection
    Physikalische Adresse . . . . . . : 00-19-D2-26-FB-3B
    DHCP aktiviert. . . . . . . . . . : Ja
    Autokonfiguration aktiviert . . . : Ja
    IP-Adresse. . . . . . . . . . . . : 192.168.2.102
    Subnetzmaske. . . . . . . . . . . : 255.255.255.0
    Standardgateway . . . . . . . . . : 192.168.2.1
    DHCP-Server . . . . . . . . . . . : 192.168.2.1
    DNS-Server. . . . . . . . . . . . : 192.168.2.1
    Lease erhalten. . . . . . . . . . : Samstag, 5. Januar 2013 10:03:16
    Lease läuft ab. . . . . . . . . . : Mittwoch, 9. Januar 2013 10:03:16


    Ethernetadapter Hamachi:


    Verbindungsspezifisches DNS-Suffix:
    Beschreibung. . . . . . . . . . . : Hamachi Network Interface
    Physikalische Adresse . . . . . . : 7A-79-19-50-28-AE
    DHCP aktiviert. . . . . . . . . . : Ja
    Autokonfiguration aktiviert . . . : Nein
    IP-Adresse. . . . . . . . . . . . : 25.80.40.174
    Subnetzmaske. . . . . . . . . . . : 255.0.0.0
    Standardgateway . . . . . . . . . :
    DHCP-Server . . . . . . . . . . . : 25.0.0.1
    Lease erhalten. . . . . . . . . . : Samstag, 5. Januar 2013 10:03:10
    Lease läuft ab. . . . . . . . . . : Sonntag, 5. Januar 2014 10:03:10


    Ethernetadapter Netzwerkbrücke:


    Verbindungsspezifisches DNS-Suffix:
    Beschreibung. . . . . . . . . . . : MAC-Brückenminiport
    Physikalische Adresse . . . . . . : 02-17-08-4C-A4-27
    DHCP aktiviert. . . . . . . . . . : Nein
    IP-Adresse. . . . . . . . . . . . : 192.168.0.1
    Subnetzmaske. . . . . . . . . . . : 255.255.255.0
    Standardgateway . . . . . . . . . :



    ..................................................................Raspberry Pi:


    pi@raspberrypi ~ $ sudo ifconfig
    eth0 Link encap:Ethernet Hardware Adresse b8:27:eb:8a:20:95
    inet Adresse:192.168.0.212 Bcast:192.168.0.255 Maske:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
    RX packets:719 errors:0 dropped:0 overruns:0 frame:0
    TX packets:344 errors:0 dropped:0 overruns:0 carrier:0
    Kollisionen:0 Sendewarteschlangenlänge:1000
    RX bytes:432161 (422.0 KiB) TX bytes:39907 (38.9 KiB)


    lo Link encap:Lokale Schleife
    inet Adresse:127.0.0.1 Maske:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metrik:1
    RX packets:8 errors:0 dropped:0 overruns:0 frame:0
    TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
    Kollisionen:0 Sendewarteschlangenlänge:0
    RX bytes:1104 (1.0 KiB) TX bytes:1104 (1.0 KiB)


    pi@raspberrypi ~ $ sudo route
    Kernel-IP-Routentabelle
    Ziel Router Genmask Flags Metric Ref Use Iface
    default user-oq58nakdnx 0.0.0.0 UG 0 0 0 eth0
    192.168.0.0 * 255.255.255.0 U 0 0 0 eth0
    pi@raspberrypi ~ $ sudo cat /etc/networking/interfaces
    cat: /etc/networking/interfaces: Datei oder Verzeichnis nicht gefunden
    pi@raspberrypi ~ $ sudo cat /etc/resolv.conf
    domain mshome.net
    search mshome.net
    nameserver 192.168.0.1



    Ich hoffe das hilft das Problem zu finden. Ich verstehe nähmlich nur zu einem geringen Teil was da eigentlich steht! :-/

  • Sorry... da war in Fehler drin...


    Der Path ist:


    Code
    /etc/network/interfaces


    Kannst du bitte noch mal die Augabe von:


    Code
    nslookup www.google.de
    ping www.google.de -c 5


    posten?

    "The best way to predict your future is to create it!"

  • Ok!Hier nochmal:


    ..........................................................WINDOWS:


    C:\Dokumente und Einstellungen\User>nslookup http://www.google.de
    Server: speedport.ip
    Address: 192.168.2.1


    Nicht autorisierte Antwort:
    Name: http://www.google.de
    Addresses: 173.194.44.56, 173.194.44.63, 173.194.44.55



    C:\Dokumente und Einstellungen\User>ping http://www.google.de -c 5
    Ungültige Option -c.



    Syntax: ping [-t] [-a] [-n Anzahl] [-l Größe] [-f] [-i Gültigkeitsdauer]
    [-v Diensttyp] [-r Anzahl] [-s Anzahl] [[-j Hostliste] |
    [-k Hostliste]] [-w Zeitlimit] Zielname


    Optionen:
    -t Sendet fortlaufend Ping-Signale zum angegebenen Host.
    Geben Sie STRG-UNTRBR ein, um die Statistik anzuzeigen.
    Geben Sie STRG-C ein, um den Vorgang abzubrechen.
    -a Löst Adressen in Hostnamen auf.
    -n n Anzahl Anzahl zu sendender Echoanforderungen
    -l Länge Pufferlänge senden
    -f Setzt Flag für "Don't Fragment".
    -i TTL Gültigkeitsdauer (Time To Live)
    -v TOS Diensttyp (Type Of Service)
    -r Anzahl Route für Anzahl der Abschnitte aufzeichnen
    -s Anzahl Zeiteintrag für Anzahl Abschnitte
    -j Hostliste "Loose Source Route" gemäß Hostliste
    -k Hostliste "Strict Source Route" gemäß Hostliste
    -w Zeitlimit Zeitlimit in Millisekunden für eine Rückmeldung




    ..............................................................Raspberry:



    pi@raspberrypi ~ $ sudo ifconfig
    eth0 Link encap:Ethernet Hardware Adresse b8:27:eb:8a:20:95
    inet Adresse:192.168.0.212 Bcast:192.168.0.255 Maske:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
    RX packets:72 errors:0 dropped:0 overruns:0 frame:0
    TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
    Kollisionen:0 Sendewarteschlangenlänge:1000
    RX bytes:6920 (6.7 KiB) TX bytes:5448 (5.3 KiB)


    lo Link encap:Lokale Schleife
    inet Adresse:127.0.0.1 Maske:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metrik:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    Kollisionen:0 Sendewarteschlangenlänge:0
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


    pi@raspberrypi ~ $ sudo route
    Kernel-IP-Routentabelle
    Ziel Router Genmask Flags Metric Ref Use Iface
    default user-oq58nakdnx 0.0.0.0 UG 0 0 0 eth0
    192.168.0.0 * 255.255.255.0 U 0 0 0 eth0


    pi@raspberrypi ~ $ sudo cat /etc/network/interfaces
    auto lo


    iface lo inet loopback
    iface eth0 inet dhcp


    allow-hotplug wlan0
    iface wlan0 inet manual
    wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
    iface default inet dhcp


    pi@raspberrypi ~ $ sudo cat /etc/resolv.conf
    domain mshome.net
    search mshome.net
    nameserver 192.168.0.1



    Diesmal keine Fehlermeldung! :)

  • Ich dachte du meintes Windows, weil mein RPI den einen Befehl irgendwie nicht kennt!?!:-/


    pi@raspberrypi ~ $ nslookup http://www.google.de
    bash: nslookup: Kommando nicht gefunden.


    pi@raspberrypi ~ $ ping http://www.google.de -c 5
    PING http://www.google.de (173.194.35.191) 56(84) bytes of data.
    64 bytes from muc03s02-in-f31.1e100.net (173.194.35.191): icmp_req=1 ttl=56 time=20.4 ms
    64 bytes from muc03s02-in-f31.1e100.net (173.194.35.191): icmp_req=2 ttl=56 time=21.5 ms
    64 bytes from muc03s02-in-f31.1e100.net (173.194.35.191): icmp_req=3 ttl=56 time=21.4 ms
    ...

  • Dann hast du nslookup nicht installiert. Aber ich denke das sollte auch nicht das Problem sein. Sonst könntest du google nicht pingen...


    Kannst du mal deine apt sourcen posten?


    Code
    cat /etc/apt/sources.list

    "The best way to predict your future is to create it!"

  • Sieht auch gut aus... Kannst du mal versuchen direkt was von dem Mirror herunter zu laden?



    Code
    wget http://mirrordirector.raspbian.org/raspbian/dists/wheezy/main/binary-armhf/Packages.bz2


    Dann solltest du die Datei Packages.bz2 heruntergeladen haben...
    Wenn es geklappt hat, dann kanst du sie wieder löschen...

    "The best way to predict your future is to create it!"

  • :sdas funzt auch irgendwie nicht. Folgende Antwort kommt:


    pi@raspberrypi ~ $ wget http://mirrordirector.raspbian…binary-armhf/Packages.bz2
    --2013-01-06 13:54:25-- http://mirrordirector.raspbian…binary-armhf/Packages.bz2
    Auflösen des Hostnamen »mirrordirector.raspbian.org (mirrordirector.raspbian.org)«... 89.16.177.202, 2001:41c8:10:25a::11
    Verbindungsaufbau zu mirrordirector.raspbian.org (mirrordirector.raspbian.org)|89.16.177.202|:80... verbunden.
    HTTP-Anforderung gesendet, warte auf Antwort...


    und dann passiert ewig einfach nichts.

  • Ich hab noch mal etwas gesucht und bin auf folgenden Artikel gestoßen...


    http://askubuntu.com/questions…ck-on-waiting-for-headers


    Das würde erklären warum es nur teilweise funktioniert... Teste doch mal ob du mit einem proxy weiter kommst... Ich denke da sind die Chance besser als mit der Network-Bridge.


    Möglich wären da zum Beispiel Jana-Server oder Squide for Windows.


    Wenn du es ganz unabhängig von deinem Notebook machen möchtest, dann vielleicht ein WLAN Dongle...


    VG,
    S-E-A

    "The best way to predict your future is to create it!"

  • Habe es gerade mal mit Jana probiert, funktioniert aber auch nicht! :( Ich weiß auch nicht weiter. Das dumme ist, ich habe einen Dongle, aber um die Treiber vom W-Lan Dongle zu installieren bräuchte ich ja wieder Internet auf meinem RPI!


    Ich werde irgendwann mal wo ein riesenlanges Lan-Kabel besorgen und versuchen meinen Raspberry quer durch die ganze Wohnung direkt an den Router zu hängen...


    Danke trotzdem für die viele Hilfe!!!!!
    [hr]
    :)JA, JETZT GEHT ES!


    Allerdings habe ich die Lösung nach wie vor nicht! Ich habe meinen Laptop jetzt über mein Smartphone (Mobiler Hotspot) mit dem Internet verbunden. Und JETZT geht es!


    Das Problem muss irgendwo beim Router liegen!!!

  • Ich denke es liegt ehr an der WLAN / LAN Verbindung... :(


    Wenn du weiter suchen möchtest, dann kannst du ja auf deinem Notebook mal eine Linux Live-CD booten und damit eine Netzwerk-Brücke installieren. :D

    "The best way to predict your future is to create it!"