Hilfe, RasPi bootet nicht mehr

  • [font="verdana, tahoma, arial, helvetica, sans-serif"]Brauche Hilfe, Bin noch Anfänger.[/font]
    [font="verdana, tahoma, arial, helvetica, sans-serif"]Habe zu meinem Problem keine passende Lösung gefunden[/font]
    [font="verdana, tahoma, arial, helvetica, sans-serif"]Problem:[/font]
    [font="verdana, tahoma, arial, helvetica, sans-serif"]Habe auf dem Raspi Raspbmc und xbmc installiert. Hat alles funktioniert. [/font]
    [font="verdana, tahoma, arial, helvetica, sans-serif"]Habe dann noch den Samba-Server und Zugriff eingerichtet.[/font]
    [font="verdana, tahoma, arial, helvetica, sans-serif"]Dann wollte ich noch den Arora Browser installieren (von der xbmc-Oberfläche). [/font]
    [font="verdana, tahoma, arial, helvetica, sans-serif"]Die Programme wurden herunter geladen, aber:[/font]
    [font="verdana, tahoma, arial, helvetica, sans-serif"]Der Neustart bricht immer ab mit folgenden Fehler:[/font]
    [font="verdana, tahoma, arial, helvetica, sans-serif"]RAMDISK: incomplete write (-28 != 262144)[/font]
    [font="verdana, tahoma, arial, helvetica, sans-serif"]Kernel panic - not syncing: VFS: unable to mount root fs on unknown-block(0,0)[/font]
    [font="verdana, tahoma, arial, helvetica, sans-serif"]Was kann ich tun, ohne noch einmal alles komplett neu installieren zu müssen?:helpnew:[/font]

  • Die Fehlerursachen sind in diesem Fall sehr vielfältig - da würde ich doch lieber erst nochmal neu installieren - eine zweite SDcard kann auch nicht schaden. ;)


    Gruß, mmi

  • Die Antwort kommt zwar etwas spät, hatte jedoch gerade das haargenau selbe Problem und konnte es wie folgt beheben:



    [font="Tahoma, Verdana, Arial, sans-serif"]- Raspberry abschalten[/font]
    [font="Tahoma, Verdana, Arial, sans-serif"]- SD Karte in den PC (Linux oder Windows ist egal!)[/font]
    [font="Tahoma, Verdana, Arial, sans-serif"]- config.txt Datei auf den PC speichern (nur zur sicherheit)[/font]
    [font="Tahoma, Verdana, Arial, sans-serif"]- config Datei auf SD Karte öffnen (sollte etwa so wie unten aussehen) und alles löschen was da geschrieben steht[/font]


    [font="Tahoma, Verdana, Arial, sans-serif"]Code: Alles markieren
    [/font]



    [font="Tahoma, Verdana, Arial, sans-serif"]- Nun Koppiert ihr folgendes rein und speichert es ab:[/font]


    [font="Tahoma, Verdana, Arial, sans-serif"]Code: Alles markieren
    [/font]

    Code
    start_file=start_x.elf
    fixup_file=fixup_x.dat




    [font="Tahoma, Verdana, Arial, sans-serif"]- SD Karte zurück in den Raspberry und er sollte wieder normal starten[/font]
    [font="Tahoma, Verdana, Arial, sans-serif"]- Nun müsst ihr noch die das "Raspbmc Settings" Programm starten und einfach unten auf "Ok" drücken[/font]
    [font="Tahoma, Verdana, Arial, sans-serif"]- Raspbmc neu starten und alles sollte wider einwandfrei funktionieren.[/font][Blocked Image: http://www.forum-raspberrypi.de/images/smilies_green/icon_bravo2.gif][Blocked Image: http://www.forum-raspberrypi.de/images/smilies_green/icon_thumbs1.gif]

  • So wie ich das nun verstanden habe, funktioniert der Browser nur über LAN und nicht über WLAN.


    Fände es super, wenn das auch über WLAN funktionieren würde.
    Für mich ist das noch eine große Schwachstelle beim XBMC.


    Denn mein Fernseher verfügt nicht über eine Internetkarte und ich würde den PI gerne nutzen um mit dem Fernseher im Netz zu surfen, aber dann extra ein LAN-Kabel legen ist zu umständlich.


    Also wer eine Idee hat wie man das über WLAN ans laufen bekommt bitte Bescheid geben.


    Danke.

    • Official Post

    Das ist korrekt, der Browser funzt nur mit Kabel und DHCP. Sam arbeitet daran WiFi zu integrieren....grade fällt mir auf...im 13er Release hab ichs noch gar nicht probiert...vielleicht klappt es da schon.

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.