Nach restore keine ssh-Sitzung möglich

  • Die Konfiguration entspricht, weil ich Debian (mit der Standardpartitionierung für) anstatt Raspberry Pi OS benütze, nicht den Anforderungen für raspiBackup, hat aber bis jetzt einwandfrei funktioniert.

    Nach dem zweiten misslungenen Versuch einen Upgrade von bookworm auf trixie durchzuführen, habe ich die letzte funktionstüchtige Instanz von bookworm mit raspiBackup wieder hergestellt. Das scheint zwar zu funktionieren, aber ich kann nach dem Start keine ssh-Sitzung mehr aufbauen. Beim ersten mal hat das noch funktioniert. Ich habe gesehen, dass es hier ähnliche posts gibt, aber bisher nichts gefunden, was mir weitergeholfen hätte.

    Die Anmeldung erfolgt mit Zertifikat. Ich nutze nicht den Standardport.

    Ich habe noch dem Alter nach zwei vorhergehende Sicherungen getestet. Auch damit war es nicht möglich eine ssh-Sitzung zu erzeugen. Mir ist nicht klar, ob inzwischen etwas am ssh-client (Linux Mint) geändert wurde oder ob mit dem lokalen Netz etwas nicht mehr stimmt. Ich bin zur Zeit etwas verzweifelt und würde mich freuen, hier Unterstützung zu finden.

    Vielleicht hilft es etwas :


    Vielen Dank.

  • Normalerweise wird alles nach einem Restore gestartet. Es scheint dass der sshd nicht gestartet wurde. Wie hyle schrieb teste das mal.

    Hast Du keinen Bildschirm angeschlossen? Mir scheint da klemmt irgendwas beim Booten des Systems und deshalb wird ssh nicht gestartet. Hast Du z.B. einen USB Stick oder -platte nicht angeschlossen der in der /etc/fstab definiert ist?

  • Danke framp und hyle dass ihr euch Zeit nehmt.

    Kein Bildschirm, keine Tastatur. Nur Netzanschluss. Ob der SSH-Server läuft, würde ich also nur über ssh prüfen können, was ich nicht hinkriege. Der restore stellt das System auf einer USB-SSD wieder her. Das gibt keine Fehler. fstab sollte also nicht das Problem sein.

    Für den restore schiebe ich die SD in den Einschub und boote damit. Zu diesem Zeitpunkt ist eine ssh-Sitzung mit Passwort möglich und starte dann den restore.

    Eine Idee ist zu Testzwecken noch ein deutlich älteres Backup zu restoren.

    Edited 2 times, last by bavoub: Ergänzung (August 19, 2025 at 5:53 PM).

  • Code
    nc -vz <Ziel-IP-Adresse> <port>

    Damit kannst Du von extern testen ob der SSHD Port offen ist.

    Kein Bildschirm, keine Tastatur

    Es ist ratsam fuer solche Faelle immer einen Bildschirm und Tastatur zu haben :wink1: Alternativ kann man noch das systemd Journal auf einem anderen Linuxsystem auslesen. Dazu muss aber das journal persistent konfiguriert sein. Standard ist temporaer.

  • Du kannst es auch vom Client im selben Netzwerk mit nc (soweit installiert) testen, ob der Port am RPi offen ist.


    Unter windows ist nc bzw. ncat Standardmässig nicht installiert.

    Da geht es am besten mit Test-NetConnection  <Hostname oder IP> -Port 22

    Code
    C:\Program Files\PowerShell\7> Test-NetConnection  raspi5 -Port 22
    
    ComputerName     : raspi5
    RemoteAddress    : 192.168.178.32
    RemotePort       : 22
    InterfaceAlias   : WLAN
    SourceAddress    : 192.168.178.2
    TcpTestSucceeded : True
  • Code
    nc -vz 192.168.1.104 <masked>
    nc: connect to 192.168.1.104 port <masked> (tcp) failed: Connection refused

    Connection refused kommt auch wenn an dem Port gar nichts läuft. Dann bleibt nur Monitor und Tastatur, oder die SD an anderem Gerät lesen. Direkter Zugriff wäre IMHO besser.

    Wir sind auf dem Weg in ein neues Jahrtausend,
    bald werden Wunder am Fließband hergestellt.
    Auf dem Weg in ein neues Jahrtausend,
    über Nacht wird alles anders,
    eine schöne neue Welt.

  • Direkter Zugriff wäre IMHO besser.

    Ich denke daran führt nicht vorbei um die Ursache zu lokalisieren.

  • Ich habe Keyboard und Monitor angeschlossen.

    Läuft der SSH-Server überhaupt?

    Das tut er tatsächlich nicht:

    Das kann ich vielleicht sogar erklären.

    Nachdem ich mit meinen Versuchen Debian von der Version 12 auf die Version 13 anzuheben soweit zufrieden war, habe ich versucht, mit raspiBackup eine Sicherung anzulegen. Der Aufruf hat aber einen Fehler erzeugt etwa in der Art "Es fehlt die Berechtigung Linux Dateiattribute zu erzeugen". Anschliessend habe ich auf dem QNAP erfolglos versucht, diese Rechte einzustellen. Dabei ist mir wahrscheinlich ein Fehler unterlaufen und die Rechte auf den Zertifikaten sind fehlerhaft.

    Wenn ich jetzt nicht völlig falsch liege, sollte es also genügen, die Rechte auf den Zertifikaten wieder herzustellen. Da ich damit überhaupt keine Erfahrung habe, würde es mich freuen, wenn man mich dabei unterstützen würde.

    Vielen Dank.

  • "Es fehlt die Berechtigung Linux Dateiattribute zu erzeugen".

    Diese Meldung bedeutet dass Dein ganzer Backup für viele Dateien die falschen Attribute hat :shocked:

    Keine Ahnung wie Du das geschafft hast trotz der Meldung ein Backup zu erstellen. raspiBackup bricht sofort ab bei der Meldung.

  • raspiBackup bricht sofort ab bei der Meldung

    Weil ich vorsichtig vorgehen wollte, habe ich beim ersten Versuch Debian 12 -> Debian 13 wie beschrieben zuerst "apt upgrade --without-new-pkgs" gestartet. Da war raspiBackup noch möglich und von da kommt wahrscheinlich auch "<masked>@debian13-rsync-backup-20250811-131957". Anschliessend hat aber "apt full-upgrade" Probleme verursacht. Also alles wieder auf Null mit der letzten verfügbaren Sicherung von Debian 12. Hat alles einwandfrei funktioniert. Später direkt "apt full-upgrade" aufgerufen. Das ist durchgelaufen. Aber der anschliessende Aufruf von raspiBackup hat dann nicht mehr funktioniert und meine Versuche ausgelöst das zu beheben, wobei mir wahrscheinlich eben ein Fehler passiert ist.

    Nach dem Setzen der Rechte wie von pisel angeregt, ist tatsächlich wieder eine ssh-Sitzung mit der Instanz möglich, aber es gibt Fehler beim boot.

    Ich restore jetzt noch einmal eine Instanz von Debian 12 und setze noch einmal die Rechte auf den Zertifikaten.

    Aber wie weiter weiss ich noch nicht.

    Vielen Dank nochmal für die Unterstützung.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!