.htaccess

  • Hallo,


    ich versuche seid gestern mein www Verzeichnis meines Webserver´s mit Hilfe von .htaccess mit einem Login zu versehen. Hier mal der Inhalt meiner .htaccess:


    AuthType Basic
    AuthName "Relaissteuerung"
    AuthUserFile \var\www\.htpasswort
    Require valid-user


    die .htpasswort liegt im selben Verzeichnis wie die .htaccess ( Ich weiß sie sollte außerhalb liegen aber so ists besser zum probieren). Alle configs von Apache sind auf Standard außer das ich ein paar AllowOverride´s auf All gesetzt hab, weil ich schon ganz Google auf den Kopf gestellt hab und Lösung von verschiedensten Foren ausprobiert hab. Doch alles half nichts.


    Das Problem ist wenn ich die iPv4 meines RasPi´s eingebe bekomme ich kein Einlog-Fenster sondern lande gleich auf dem Inhalt. Von außerhalb meines Netzwerkes funktioniert es genauso nicht.


    Ich hoffe ihr habt eine Lösung.


    Mfg

  • Danke für die Antwort! Hab jetzt mal mit dem Tool die htaccess erstellt. Hilft trotzdem nichts. Ich denke mein Problem liegt nicht an der htaccess, sondern es ist irgendwie so, als würde die Datei gar keine Wirkung haben. Sie greift einfach nicht ein.


    In der log Datei steht immer das wenn ich mich auf den Webserver verbinde:


    192.168.2.102 - - [17/Jan/2014:18:39:49 +0100] "GET / HTTP/1.1" 304 208 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36"

    Edited once, last by maddig ().

  • Einfach den Browser schliessen und nochmal probieren !


    [font="Tahoma, Verdana, Arial, sans-serif"]> In der log Datei steht immer das wenn ich mich auf den Webserver verbinde:[/font]
    >
    [font="Tahoma, Verdana, Arial, sans-serif"]> 192.168.2.102 - - [17/Jan/2014:18:39:49 +0100] "GET / HTTP/1.1" 304 208[/font]
    [font="Tahoma, Verdana, Arial, sans-serif"]304 bedeutet "[font="Times New Roman"]Not Modified" -> der Server findet dass es gar nichts zu lesen gibt[/font][/font]

  • Funktioniert nicht, ich habe sogar gestern meine RasPi neu aufgesetzt und es hat nichts gebracht. Keine Ahnung an was es liegt... Wenn ich XAMPP auf meinem Windowsrechner installiere und dort die beiden Datein Ausprobiere soll ich sofort meine Login Daten eingeben...


    :s

  • * In /etc/apache2/sites-enabled im File 000-default AllowOverrides All gesetzt.
    * apache2ctl restart
    * mit htpasswd ein Passwortfile erzeugt
    * ein .htaccess geschrieben


    Apache Configuration
    AuthType Basic
    AuthName "Restricted Access"
    AuthUserFile /home/pi/pass
    Require user pipi


    Und Apache verlangt ein Login.

  • Also jetzt verstehe ich gar nichts mehr. Ich war grad dabei das zu machen was du geschrieben hast, ich hab die 000default aufgemacht hab nichts darin gemacht weil ich vorher schon alles auf ALL gestellt habe, schließe die Datei wieder und geb zum hundertsten mal sudo service apache2 restart ein und auf einmal funktioniert es ???


    Komische Sache aber es funktioniert.


    Danke für deine Hilfe :thumbs1:

    Edited once, last by maddig ().