Bringe Soundkarte nicht zum laufen

  • Hi. Ich möchte eine externe Soundkarte zum laufen bringen aber leider klappt es nicht. Wäre super wenn mir jemand helfen könnte. Ich hab vor allem das hier versucht: http://www.forum-raspberrypi.d…undkarte-installation-wie


    Anbei ein paar Infos die euch (und dann mir) hoffentlich weiterhelfen.



    Code
    pi@raspberrypi ~ $ sudo lsusb
    Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
    Bus 001 Device 004: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
    Bus 001 Device 005: ID 0d8c:000e C-Media Electronics, Inc. Audio Adapter (Planet UP-100, Genius G-Talk)



    Code
    pi@raspberrypi ~ $ cat /proc/asound/cards
     0 [Device         ]: USB-Audio - Generic USB Audio Device
                          Generic USB Audio Device at usb-bcm2708_usb-1.3, full speed
     1 [ALSA           ]: BRCM bcm2835 ALSbcm2835 ALSA - bcm2835 ALSA
                          bcm2835 ALSA




    /etc/modprobe.d/alsa-base.conf (little messy right now?)




    /etc/asound.conf (hat vorher nicht existiert)

    Code
    pcm.!default {
    type hw
    card 0
    }
    ctl.!default {
    type hw
    card 0
    }



    das hier funktionert nicht.

    Code
    pi@raspberrypi ~ $ aplay -D plug:hw:0 /usr/share/sounds/alsa/Front_Center.wav
    aplay: main:682: audio open error: Device or resource busy



    das hier funktioniert. Aber leider nur über den Klinken-Ausgang.

    Code
    pi@raspberrypi ~ $ aplay -D plug:hw:1 /usr/share/sounds/alsa/Front_Center.wav
    Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono


    Bin für jede Hilfe dankbar! Vielleicht hilft mir auch die eine oder andere Erklärung weiter (Ich weiß nicht so genau was ich tue. Wie man wahrscheinlich sieht.)

  • Raspbian



    Code
    pi@raspberrypi ~ $ cat /etc/issue
    Raspbian GNU/Linux 7 \n \l
    pi@raspberrypi ~ $ cat /proc/version
    Linux version 3.10.25+ (dc4@dc4-arm-01) (gcc version 4.7.2 20120731 (prerelease) (crosstool-NG linaro-1.13.1+bzr2458 - Linaro GCC 2012.08) ) #622 PREEMPT Fri Jan 3 18:41:       00 GMT 2014
    pi@raspberrypi ~ $ uname -a
    Linux raspberrypi 3.10.25+ #622 PREEMPT Fri Jan 3 18:41:00 GMT 2014 armv6l GNU/Linux

    Edited once, last by MrFrei ().

    • Official Post

    sehr seltsam das ist.. Bringt

    Code
    speaker-test -c2 -D hw:0,0

    auch die "device busy" meldung. Ansonsten aktivier die

    Code
    options snd-usb-audio index=-2

    Zeile mal wieder und änder die -2 in eine 0.


    Was für ein Chipsatz hat die Soundkarte?
    Karte abziehen, ranstecken und

    Code
    sudo dmesg

    ausführen. Die letzten Zeilen sollten dann Zeigen das ein USB Gerät angeschlossen wurde und dieses auch genauer benennen.

  • Code
    pi@raspberrypi ~ $ speaker-test -c2 -D hw:0,0
    
    
    speaker-test 1.0.25
    
    
    Playback device is hw:0,0
    Stream parameters are 48000Hz, S16_LE, 2 channels
    Using 16 octaves of pink noise
    Playback open error: -16,Device or resource busy



    Code
    [  425.218073] usb 1-1.3: USB disconnect, device number 5
    [  425.261542] cm109 1-1.3:1.3: cm109_toggle_buzzer_sync: usb_control_msg() failed -19
    [  428.741566] usb 1-1.3: new full-speed USB device number 6 using dwc_otg
    [  429.264996] usb 1-1.3: New USB device found, idVendor=0d8c, idProduct=000e
    [  429.265034] usb 1-1.3: New USB device strings: Mfr=0, Product=1, SerialNumber=0
    [  429.265054] usb 1-1.3: Product: Generic USB Audio Device
    [  430.627408] input: CM109 USB driver as /devices/platform/bcm2708_usb/usb1/1-1/1-1.3/1-1.3:1.3/input/input1



    Hab außerdem gemerkt, dass - wenn ich die Lautstärke voll aufdrehe - ein unregelmäßiges Knacken aus den Lautsprechern kommt. Sonst leider nichts. Änderung der alsa-base.conf brachte keine Änderung.
    [hr]
    Falls mal jemand ähnliche Probleme hat: Bei mir hat die Deinstallation von pulseaudio geholfen.


    Die Soundtests laufen jetzt also. Ich hatte irgendwann mal pulseaudio installiert. Das hat wohl die Soundausgabe irgendwie blockiert. Geholfen hat


    Code
    sudo apt-get autoremove pulseaudio


    und ein Reboot.



    Danke für die Hilfe, manchmal hilft es auch weiter wenn man weiß dass eigentlich alles funktionieren müsste.

    Edited once, last by MrFrei ().

  • Hallo,
    Habe ein etwas anderes Problem,
    Ich habe die speed link vigo Karte an meinem aktiven usb Hub. Alle Menü - Sounds werden korrekt abgespielt. Aber wenn ich eine Serie oder Film wiedergebe kommt kein Ton mehr. Und ich hab keine Ahnung warum?
    Danke.