Wlan mit EDIMAX EW-7811UN zulangsam

  • Hallo Leute


    Habe den WLAN Adapter EDIMAX EW-7811UN am laufen
    ist auch alles installiert und er funktioniert auch.
    Nur die Geschwindigkeit ist mit n bishen zu langsam nur
    100 kb/s


    Liegt das an der Strom Versorgung ?
    habe ein ipad netzteil (Beim iphone stecker soll nicht genug spannung kommen hab ich gelesen) für das Raspberry PI genommen das funktioniert auch.
    Das ding hat 5,2V also 2AA also sollte genug strom da sein.


    Trotzdem nur diese langsame geschwindigkeit beim Wlan...


    Woran kann das liegen ?
    Über antworten würde ich mich freuen ..:)

  • Das sollte weniger an der Spannungsversorgng bzw. dem verfügbaren Strom liegen, sondern einfach an der Baugröße. Überlege mal wie groß die Antenne in dem Stick sein kann. Je kleiner die Antenne desto schlechter der Empfang und somit auch die erreichbare Geschwindigkeit.

  • Danke für die info. Du hast recht.
    Hab den Stick mal an meinen normalen PC getestet der bekommt auch keine höhere Geschwindigkeit.
    Aber dann finde ich das eine Sauerei vom Hersteller wenn 150mbit/s versprochen werden und noch nicht mal 1 mbit/s ankommen.

    Edited once, last by sebema ().

  • Wenn Du den Pi neben den Router stellst wird er die 150mbit auch schaffen. Je schlechter der Empfang, desto langsamer ist Wlan, da kann der Hersteller nichts für, das liegt an Deinem Wlan.

  • ja aber der Wlan stick an meinem richtigen Computer der neben dem PI steht bekommt auch laut Hersteller maximal 150mbit und ist trotzdem 12x mal so schnell.... Aber liegt halt an der kleinen Antenne da kann man nix machen

  • komisch. Ich habe so einen Edimax. Klein und knuffig. Der arbeitet bei mir im Schnitt mit so 16Mbit/s via ssh, was ich ausreichend finde. Mehr geht wahrscheinlich auch über andere Protokolle.
    Zwischen Pi und Access-Point ist eine dickere Wand. Läuft via WPA2.

  • Hey,
    ich wollte mich auch mal der Meinung anschließen, dass der Adapter zu langsam ist. Bei mir schafft er, obwohl er direkt (3 cm) neben meinem Access Point steht und an einem Usb Hub mit Stromversorgung angeschlossen ist nur R:0,5-1,1 Mbyte/sec W:1,4-1,6 Mbyte/sec.
    Für mich ist das unverständlich, da mir der Hersteller 150 Mbps versprochen hat! Kann man da wirklich nichts machen, damit er schneller wird? Weil ich ihn als File Server eingerichtet habe und ihn auch über Wlan ordentlich nutzen möchte.

  • Ich habe 3 von diesen Sticks und sie arbeiten trotz der kleinen Antenne überraschend gut. 150 Mbit/sec werden aber nur im n-Modus (mit 40 Mhz Bandbreite) erreicht. Der Accesspoint muß auch entsprechend konfiguriert sein. Betrieb zu nahe am Accesspoint ist auch nicht zu empfehlen, mind. 3m Abstand würde ich halten.


    Mögliche Ursachen:
    - schon andere Kanäle probiert? vielleicht ist generell zu viel in der Nachbarschaft los?
    - Konfiguration des Accesspoints prüfen
    - Störstrahlung durch Fremdeinwirkung
    - Inkompatibilität mit Software bzw. Chip im Accesspoint (habe ich anderweitig auch schon erlebt)


    Der EW-7811UN wird am Raspberry sehr häufig verwendet und funktioniert eigentlich gut, ich kann es nur bestätigen. Habe im Moment zwei Ziegelmauern dazwischen, Entfernung zum AP ca. 7m:


    Code
    1. wlan0     IEEE 802.11bgn  ESSID:"myessid"  Nickname:"<WIFI@REALTEK>"
    2.          Mode:Managed  Frequency:2.452 GHz  Access Point: 20:CF:30:B8:21:38  
    3.          Bit Rate:150 Mb/s   Sensitivity:0/0  
    4.          Retry:off   RTS thr:off   Fragment thr:off
    5.          Encryption key:****-****-****-****-****-****-****-****   Security mode:open
    6.          Power Management:off
    7.          Link Quality=100/100  Signal level=77/100  Noise level=0/100
    8.          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
    9.          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


    Gruß, mmi

  • Quote


    Konfiguration des Accesspoints prüfen


    Sollte kein Problem sein, da mein Pc ebenso über Wlan mit dem Access Point verbunden ist.


    Quote


    schon andere Kanäle probiert? vielleicht ist generell zu viel in der Nachbarschaft los?


    Mit meinem normalen Wlan-Stick empfange ich 3 Netzwerke und mit dem Edimax nur den Access Point. Und wie gesagt, am Pc habe ich ja bis zu 5mbyte/s


    Quote


    Störstrahlung durch Fremdeinwirkung


    Wüsste nichts, was das stören könnte, da eigentlich nichts zwischen Access Point und dem Raspberry ist.



    Übrigens schafft er, wenn er an meinem Pc ist auch nur maximal 3,5 mbyte/s


    ----------Edit:
    Ich habe gesehen, dass der Stick nicht im n modus ist. Wo kann ich das einstellen ?

    Edited once, last by Jack_477 ().

  • Quote from Jack_477 pid=10208 dateline=1365769954

    Ich habe gesehen, dass der Stick nicht im n modus ist. Wo kann ich das einstellen ?


    Das ist natürlich eine Erklärung, aber annähernd 54 Mbit/s sollten eigentlich jetzt schon erreicht werden.
    Einstellen mußt Du es einerseits am Router/AP - zumindest im Mischbetrieb (bgn) soll ja auch n zugelassen sein.
    Du könntest ja testweise dort mal ausschließlich n einstellen. Der Edimax sollte dann eigentlich ohne weitere Konfiguration
    diesen Modus verwenden.


    Nachdem keine ältere Hardware mehr vorhanden ist, ist bei mir ausschliesslich n konfiguriert. Dann kannst Du unter
    "/etc/modprobe.d/" z.B. eine Datei "wlan.conf" anlegen mit folgendem Inhalt:

    Code
    1. options cfg80211 cfg80211_disable_40mhz_24ghz=0
    2. options 8192cu rtw_ht_enable=1 rtw_cbw40_enable=1


    So habe ich 150 Mb/s. ;)


    Wenn Du dann immer noch solche Geschwindigkeitsprobleme hast, würde ich mal (leihweise) einen anderen Router (mit einem anderen WLAN-Chipsatz) probieren.

  • Die wlan.conf hat leider nicht funktioniert.


    Allerdings bekomme ich wenn ich iwconfig eingebe nicht wie oben:


    Code
    1. wlan0     IEEE 802.11bgn


    sondern nur:


    Code
    1. wlan0 IEEE 802.11bg



    Aber ist der nicht normalerweise auf n eingestellt ? Tut mir leid für meine Anfängerfehler :(

  • Das macht ja nichts, jeder war mal Anfänger. ;)


    iwconfig muß "802.11bgn" anzeigen, sonst wird die oben beschriebene "wlan.conf" nicht funktionieren.


    - Du bist sicher, daß der Router den N-Modus beherrscht und die Konfiguration des Routers (über Webbrowser einstellbar) auch den N-Modus zulässt?
    - Hast Du auch die neueste Betriebssystemversion auf dem RPi installiert ? (Bei den Versionen von 2012 gab es mit dem Realtek 8192 noch Probleme).
    - "overclocking" ggf. mal auf Standardwerte (700 Mhz) zurücksetzen
    - Netzteil kann mind. 1A ?


    Wenn das alles nicht hilft und Du sonst nichts verstellt hast, kann ich nur auf eine Hardwareinkompatibilität tippen - versuche es mal mit einem anderen Stick mit anderem Chipsatz.

  • Quote


    iwconfig muß "802.11bgn" anzeigen, sonst wird die oben beschriebene "wlan.conf" nicht funktionieren.


    Das tut es ja leider nicht, wie schon in meinem vorigen Post erläutert.


    Quote


    - Du bist sicher, daß der Router den N-Modus beherrscht und die Konfiguration des Routers (über Webbrowser einstellbar) auch den N-Modus zulässt?


    Ziemlich sicher, da ich meinen PC über den Router und Access Point betreibe und dort habe ich ja 5 mbyte/s


    Quote


    - Hast Du auch die neueste Betriebssystemversion auf dem RPi installiert ? (Bei den Versionen von 2012 gab es mit dem Realtek 8192 noch Probleme).


    Habe ihn erst vor ca. 1 Monat gekauft und dann die neueste Raspbian Version runtergeladen.


    Quote


    - Netzteil kann mind. 1A ?


    Betreibe ihn über ein 5V/2A Netzteil über den Usb Hub in dem oberen Usb Port.

  • Quote from Steakschen pid=10947 dateline=1366308943


    Huhu
    ich hab das Problem das der Wlan-Stick wohl erst nach 2 minuten nachm Booten startet, kann ich das irgendwo ändern?
    MfG


    Das scheint an DHCP-Server/Konfiguration zu liegen. Versuche es mal mit einer statischen IP.


    Jack_477 : Mehr fällt mir dazu leider nicht mehr ein, wie schon erwähnt: ich würde mal einen anderen Stick probieren.


    Gruß, mmi