Zugriff auf Fritz NAS

  • Folgendes Problem kommt mir zwar ziemlich primitiv vor aber ich komm zum Verrecken nicht weiter:


    ich habe an meiner fritzbox 7390 eine 500GB Festplatte als NAS hängen. Komme vom Windowsexplorer am laptop auch drauf, genauso wie über die weboberfläche via fritz.nas sowohl vom laptop als auch vom raspi. Was nicht geht ist, dass ich vom grfischen explorer, wo mir unter netzwerk FRITZ!NAS angezeigt wird darauch zuzugreifen. Beim draufklicken kommt immer: "Empfangen der Speicherliste vom Server ist gescheitert" und nachdem ich das bestätigt hab kommt "Der angegebene Ort ist nicht eingehängt", die 2te meldung kommt auch wenn ich auf den laptop vom Pi aus zugreifen will.
    Ich weis nicht ob es relevant ist das ich webmin installiert habe und das auch super läuft, ich also vom laptop(Win7) den raspi sehe.
    Hoffe das war soweit verständlich ;)

  • Ich denke, dass ein Problem fehlender Berechtigungen.


    Sind auf dem Laptop und dem Raspi dieselben user mit denselben Passwörtern eingerichtet?


    Auf der Fritzbox ähnlich. Aber hier ist es abhängig von der Firmware: aktuell gib es Neue. Bislang gab es nur den ftpuser, jetzt kann man eigene User-Namen vergeben.


    Testen kann man am Besten auf der Konsole (z.B. mit lxterminal):


    smbclient -N -L fritz.box


    Aufgepasst:
    - wenn nicht als root angemeldet, dann muss immer ein "sudo" davor
    - smbclient muss installiert sein


    Wenn ein Zugriff erlaubt ist, kommen Informationen über Freigaben und anderes, ansonsten die Fehlermeldung:
    session setup failed: NT_STATUS_LOGON_FAILURE


    Das Gleiche auch mal Richtung Laptop probieren:


    smbclient -L laptop-name -U bekannter_name_auf_dem_laptop


    Bei der alten firmware-Version der Fritzbox gab es den user ftpuser mit Passwort 123456


    also mal testen


    smbclient -L fritz.box -U ftpuser


    nach der Passwort-Abfrage sollten Informationen angezeigt werden.


    Wenn auf der fritzbox user eingerichtet sind, mit diesen Namen testen.


    smbclient -L fritz.box -U eingerichteter-name-auf-der-fritzbox

    Keep it simple [,&] stupid

  • Quote

    Sind auf dem Laptop und dem Raspi dieselben user mit denselben Passwörtern eingerichtet?


    Weis ich nicht. Ich habe auf dem RasPI nur den standart User "Pi" und auf dem PC auch nur einen User mit Admin Rechten. In wiefern ist es wichtig die gleichen benutzer zu haben.


    Quote

    Bislang gab es nur den ftpuser, jetzt kann man eigene User-Namen vergeben.


    Was ist das? habe davon noch nie gehört. wo ist dieser User eingerichtet?

    Quote

    Testen kann man am Besten auf der Konsole (z.B. mit lxterminal):



    smbclient -N -L fritz.box


    funktioniert und es kommen besagte infos


    Quote

    smbclient -L laptop-name -U bekannter_name_auf_dem_laptop


    wenn ich das eingebe kommt die PW-Abfrage aber dann: Error returning browse list: NT_STATUS_ACCESS_DENIED



    wenn ich das mache kommt zwar auch die PW-Abfrage aber dann der Fehler: Session setup failed:NT_STATUS_LOGON_FAILURE


    wei kann das sein wenn der zugrif vom laptop einfach so klappt?

  • Das sieht doch gut aus! Wir müssen jetzt nur noch mit den richtigen Namen und Passwörtern arbeiten.


    Zwingend brauchen wir identische Namen auf beiden Seiten nicht, macht es aber einfacher.


    Der Anwender "ftpuser" ist standardmäßig eingerichtet auf der fritzbox (bei mir eine 7270, die 7390 wird nicht anders sein).


    Bitte die firmware der fritzbox überprüfen, am besten updaten.


    Mit der Version 5.50 gibt es zwar noch den ftpuser, aber scheint kein Passwort zu haben. 123456 gilt nicht mehr.


    Mit dem Wechsel auf 5.50 mußte(!) ich Folgendes auf der fritzbox machen.


    Auf der box unter "System" - "Fritzbox-Kennwort" den Haken bei "Anmeldung mit FRITZ!Box-Benutzernamen und Kennwort" setzen und übernehmen.
    Anschließend fritzbox-Benutzer hinzufügen und die passenden Berechtigungen setzen.
    Ich verwende Namen, die auf allen Rechnern identisch eingerichtet sind - auch auf dem Raspi.
    Testweise den Benutzer pi mit passenden Passwort auf der Box einrichten.


    Dann sollte
    smbclient -L fritz.box
    aus der Konsole als user pi funktionieren und somit auch das mounten der Freigaben.


    Der Zugriff auf den Laptop ist ebenfalls eine Frage des Benutzers und des Passwortes. Vielleicht auch mal hier den Benutzer "pi" einrichten und dann testen.


    Warum der Zugriff vom Laptop auf die fritzbox funkioniert, kann ich von hier nicht beantworten, da ich das veränderte Verhalten der fritzbox zuerst auf einen Linux-Rechner bemerkte und die fritzbox wie oben beschrieben einrichtete. Danach gab es auf den Windows-Rechner keine Probleme. Ob es sie vorher gab, weiß ich nicht.

    Keep it simple [,&] stupid

  • Also da stellt sich mir noch folgendes Problem: Ich wohne noch zu hause, die fritzbox steht bei meinem vater, der hat das PW und ist z.Zt. nicht da.
    wie kann ich denn den Benutzer Pi einrichten?

  • Du brauchst nicht extra einen Benutzer auf dem RPI einzurichten. Du musst nur wissen mit welchem Benutzer du dich am Share der Fritz!Box anmelden musst.


    Wenn du ein den Share am Laptop öffnen kannst, dann musst wirst du doch sicher einen Benutzer angegeben haben? Oder ist das als Netzlaufwerk direkt in den Explorer eingebunden?



    Hast du mal versucht den Share über die IP-Adresse und nicht über den Namen aufzurufen?

    "The best way to predict your future is to create it!"

    Edited once, last by s-e-a ().

  • Vielleicht nicht deutlich genug formuliert.


    Nicht auf dem pi einen user einrichten - sondern auf der fritzbox - wie oben beschrieben.


    Ansonsten gibt es den Benutzer "ftpuser" auf der fritzbox. Aber wie oben beschrieben, ab der firmware-Version 5.50 nicht mehr mit dem Passwort 123456.


    Die 7390 hat die neue firmware schon länger als meine 7270, daher denke ich, dass die fritzbox die neue firmware hat. Somit führt kein Weg am Vater vorbei, sorry.


    Aber das Ganze kann man schon mit dem Laptop probieren. Welches MS Windows ist denn auf der Kiste? (ich vermute mal, es ist MS und kein Linux)

    Keep it simple [,&] stupid

  • Der laptop läuft unter Win7 und damit komme ich ja ganz einfaxh auf die FP and der fritzbox. da muss ich keinen benutzer und kein PW eingeben nur unter Netzwerk FRITZ!NAS auswählen. wird da als ganz normaler netzwerpc angezeigt.


    EDIT:
    Hab grade nochmal etwas rumprobiert:
    Im grafischen explorer auf dem RPI:
    Wenn ich in der netzwerkumgebung meinen Laptop auswähle will er Login und PW haben. ich hab aber keine ahnung was das sein könnte.
    Wenn ich auf den fritz.nas zugreifen will kommt sofort die fehlermeldung OHNE Abfrage.


    Ich komm garnichtmehr klar :s

    Edited once, last by greySwan ().

  • ohje, da fängt einer ganz von vorn. macht nichts, kriegen wir hin;)


    zuerst: deine neuen Versuche bestätigen meine Annahmen: Wir müssen Namen und Passwörter zusammenbringen.


    zu login und pw:
    da fragt der andere Rechner nach einen Benutzername (auch user, account etc.) und nach einem Passwort.


    Heute gibt es eigentlich kein Betriebssystem mehr, dass ohne Benutzername arbeitet- auch wenn man es nicht sieht (z.B. Android auf dem Smartfone)
    Auch MS Windows kann man so einrichten, dass man sich nicht anmelden muss und es kein Passwort gibt.
    Das gilt aber nur, wenn man direkt an er Maschine sitzt. Will man über das Netzwerk auf den Rechner zugreifen, braucht man einen gültigen Anwender und ein PW


    Bei Win7 mal den Taskmanager aufrufen und den Reiter "Benutzer" anklicken. Dort wird der korrekte Anmeldename angezeigt. Mit diesem Namen den Zugriff vom Pi versuchen (egal ob über den Desktop oder mit smbclient)
    Bleibt das Passwort. Wenn auf dem Win7-Rechner kein PW gesetzt ist, es vom Pi ohne versuchen - ob es geht, weiß ich nicht, habe schon ewig nicht mehr Rechner ohne PW.


    Über die Benutzerkontensteuerung von Win7 kann man eins setzen (oder mit Strg-Alt-Entf)


    Der Win7-Rechner hat die Information, wie er auf die Fritzbox zugreifen darf - nämlich Name und Passwort.
    Ist aber tief versteckt im System: "Anmeldeinformationsverwaltung" - gibt es für jeden Benutzer


    Für meine fritzbox vor firmware 5.50 gab es eine Datei mit Inhalt ftpuser und 123456.
    Diese Information habe ich nicht selbst angelegt - ich vermute die fritzbox hat es über upnp dem Win7 verraten.
    Debian (und somit die Pi) kann das wahrscheinlich nicht - muss man selbst angeben.


    ---


    Die fritzbox verhält sich anders beim Zugriff vom Pi.
    Dies bestätigt genau meine älteren Ausführungen. Nach dem update meiner box hatte ich genau das gleiche Verhalten. Ich musste erst auf der box entsprechende Benutzer anlegen, danach lief alles wieder wie gewünscht.
    Und identisch wie der Zugriff auf MS-Win-Rechner.

    Keep it simple [,&] stupid

  • Also gelöst aber ganz seltsam..
    hatte bis grade kein PW an meinem laptop gesetzt und hatte auch schon versucht vom RasPi nur mit dem benutzer und ohne PW -da ja keins gesetzt war- auf dem laptop anzumelden = ging nicht!
    hab dan mal spasshalber nen PW gesetzt und mich mit dem angemeldet und es ging. is halt so.


    weiter das Problem mit der box:
    vom pc komm ich ja drauf, d.h. es muss schon ein benutzer vorhanden sein. wenn ich aber vom pi drauf zugreifen will kann ich garkeinen benutzer auswählen da sofort die fehlermeldung kommt.


    in der "Anmeldeinformationsverwaltung" hab ich übrigens nur die infos für Den Raspi und den q-nap server gefunden.


    -------
    OT:
    kannman das unter windows iwie ausschalten, das der über netzwerk ne abfrage macht?

  • Systemsteuerung -> Verwaltung -> Lokale Sicherheitsrichtlinie -> Sicherheitsoptionen -> Konten: Lokale Kontenverwendung von leeren Kennwörtern auf Konsolenanwendung beschränken
    auf 'deaktiviert' stellen.


    Schön ist das aber nicht.