Apache Webserver und PHP Modul

  • Hallo liebe RaspberryPi-Freunde,


    ich habe hier ein, für mich, seltsames Problem.


    Auf meine RaspberryPi (OS: Raspbian) läuft ein Apache Webserver.
    Dort laufen kleine Webseiten die ich selbst programmiert habe.


    Nun wollte ich von PHP aus EMail verschicken.
    Ich habe mich dann an folgende Anleitung gehalten -> Link


    Jedoch bekomme ich seitdem 1/2 stündlich eine Email mit folgendem Inhalt:


    [font="Courier New"]PHP Warning: Module 'mysql' already loaded in Unknown on line 0[/font]



    Die Email geht an "postmaster@raspberrypi" und schlägt natürlich fehl, weil es die Adresse nicht gibt.


    Leider habe ich keinen Plan, was passiert, bzw. warum diese EMail kommt...
    EMail kann ich ohne Probleme verschicken und alle Webseiten laufen wie gewohnt.


    Vielen Dank für eure Unterstützung


    Gruß Sebastian

  • Hallo,


    wie kann ich das prüfen?


    Was ich bisher geprüft habe ist folgendes:


    /etc/php5/apache2/conf.d/20-mysql.ini und /etc/php5/conf.d/20-mysql.ini ist jeweils die Zeile "extension=mysql.so" einkommentiert.
    Allerdings ist das bei der Datei "20-mysqli.ini" identisch.


    In der "php.ini" unter dem Verzeichnis "/etc/php5/apache2" ist auch eine Zeile "extension=mysql.so" zu finden.


    Hänge diese zusammen?
    Sollte ich davon einen entfernen?

  • Vielen Dank dbv! :thumbs1:


    Ich habe die php.ini geändert und den Apache gestoppt/gestartet.
    Apache läuft nach wie vor und bis jetzt noch keine EMail vorhanden.


    Wenn morgen keine im Posteingang liegt, erledige ich dieses Thema.


    :danke_ATDE: